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Understanding the Appointment Book workflow

The appointment book workflow in Bp Premier covers all of the events from booking an appointment to pro-
cessing payment by the patient.

Every practice is different, but the appointment book workflow for front desk and providers will often look
like:

1. An appointment is booked from the Appointment Book.
2. The patient is arrived and automatically added to theWaiting Room.
3. The provider starts the visit fromWaiting Room and begins the consultation.
4. The provider finalises the visit in Patient Record and ends the consultation.
5. The patient's account (invoice) is created or finalised from the Appointment Book.
6. Payment from the patient is processed at reception (for private practice fees).
7. The appointment is closed.
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Book or update an appointment

To open the appointment book from themain Bp Premier screen, select View > Appointment book or press F12.

Book a new appointment
There aremany different ways to create a new appointment, depending on how your staff like to use Bp Premier.

1. Double-click any slot, or click the slot to book in the Appointment Book and choose one of:
start typing the patient surname
click the Add new appointment button in the left hand side of the screen
press F3 on the keyboard
right-click the appointment and select New appointment
click the Add new appointment icon in the toolbar
select File >New Appointment.
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An Add appointmentwindowwill appear, where you can book patient or non-patient appointments.

Book appointment for a patient

2. To book a new appointment for a patient, enter the first few letters of the patient’s surname in the Search
for field. A list of patients whose surnamematches the letters entered will appear.

3. If the search list is too long, continue entering the patient’s surname, add a comma, and enter the first few
letters of the patient’s first name.

4. You can search for the patient byMedicare No. or Record No. by changing the radio button.
5. When the desired patient has been found, select them from the list and specify:

the appointment type
appointment details (text field)
appointment length
who booked the appointment and if it is a recurring appointment.
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6. If you wish to edit a patient’s details before booking an appointment, select the View details button to open
the Patient details screen.

7. If the appointment is urgent and the patient is available, select Add to waiting list for cancellation to add the
patient to the Cancellation list.

8. If your practice uses Bp Premier's clinical reminders, select Send Reminder to also generate a reminder of type
'Appointment' against the patient.

9. Click on the Book appointment button to save the appointment to the appointment book.

Book appointment for a non-patient

2. To book a new non-patient appointment, leave the Search for field blank and select an appointment type. The
appointment types that can be used for non-patient appointments are:

Meeting
Assist
Nursing Home visit
Teleconference
Drug rep
Other.

3. Enter the appointment information into theDetails field. The details will appear in the appointment book.
4. Click on the Book appointment button to save the appointment to the appointment book.

TIP Custom appointment types can be created from Setup > Configuration > Lists > Appointment types.

Add a new patient quickly
If a patient does not exist in Bp Premier, you can quickly add them from the Add appointment screen.

1. Click theNew patient button. TheNew patient screen will be displayed.
2. When opened from the appointment book, the only mandatory fields from this screen are the Family Name

and Given Name fields, to allow you to book an appointment quickly. Complete these fields and click Save to
return to the Add appointment screen.

3. When the patient attends the appointment, complete the rest of the information required in the Patient
details screen.

Edit an appointment
1. To edit an appointment, choose one of:

right-click the appointment and select Edit appointment
select the appointment and click the Edit appointment button on the left hand side
select File > Edit Appointment.
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The Appointment details screen will be displayed. You can edit all appointment details except for who the
appointment is for. If you need to change the patient for an appointment, you must delete and rebook.

2. Click the Save changes button to return to the appointment book.

Can I see who edited an appointment?

To see who last updated an appointment, right-click the appointment slot and select View text, or press F10.

View a patient's appointment history
SelectManagement > Appointment history from themain screen. Search for a patient to open the Appointment
history screen for that patient.

Tick Include family members to display the appointment history for all members of the patient's family.

Bp Premier Appointment Book Guide Page 8



Start and finalise a visit

After a patient has arrived at the practice and their appointment has been marked as 'arrived', the provider can start
the visit from the appointment or waiting room.

To open the waiting room from themain Bp Premier screen, select View > Waiting room or press Ctrl + F12.

Preview patient notes
Previewing from the waiting room opens the patient’s record, but does not start the consultation timer. No visit is
created in the database and Today’s notes is not available. The patient’s name is not removed from the waiting
room. This allows a provider to view a patient record without starting a visit.

Select a patient in the waiting room and click Preview notes to open the patient record in previewmode.

Start the visit
Providers may prefer to open records from theWaiting Room, which only displays information about patients who
have arrived.

To start a visit from the Appointment Book, choose one of:

double-click the appointment in the appointment book
select the appointment and click the Start Visit button on the left hand side
right-click an appointment and select Start visit.

To start a visit from theWaiting Room, choose one of:

double-click on the appointment in the waiting room
press the F2 button on the keyboard
select the patient record and click the Start Visit button at the top of the screen
right-click an appointment and select Start visit.

The Patient clinical recordwill now open and the provider can begin the consultation.

Finalise a visit
Finalising a consultation generates invoice items and other billing information, ready for front desk staff to process
payment after the patient returns to reception.

1. When you have finished consulting with the patient, click the Finalise visit button from the patient record to
display the Finalise Visit screen.
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TIP If the patient record was opened from the appointment book or waiting room, the Finalise visit
screen automatically opens when a patient record is closed after consultation, and you do not need to
click Finalise visit.

If you click Finalise visit, Bp Premier will insert an entry into the appointment book for the current time
and mark the appointment as 'At billing'.

2. The Visit length is calculated from the time that the patient record was opened.
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3. The Account type defaults according to the billing configuration:
If Setup > Configuration > Billing > Billing precedence is set to ‘Patient’, the type defaults to theUsual
account recorded in the patient’s demographic.
If Billing precedence is set to ‘Doctor’, the type defaults to theDefault account type recorded in the pro-
vider’s Edit user details.

4. Type in theMBS item number. The description of the item will be displayed with the fee associated with the
account type.

If the provider would like to always default the item number to a specific item (for example, 'item 23'):

1. Set theDefault Item No. in Setup >Users.
2. Tick Always use the default MBS Item in the Finalise window checkbox in Setup > Preferences >Gen-
eral.
3. Set Billing precedence to 'Doctor' in Setup > Configuration > Billing.

The default item will appear regardless of the length of the visit. If there is no default item, the visit length
will determine the default consultation item.

5. To add this item to the account, double-click on the description. The item will appear in the Items to bill sec-
tion.

6. If theDefault list checkbox is ticked, the list shows the customised fee items for the practice. These could be
either MBS items that have had their default fee customised, or non-MBS items that the practicemanager has
created for items that the practice regularly charges for. The non-MBS items are listed first in alphabetic order,
followed by theMBS items.

7. If you can't remember theMBS item number, use the Search MBS fields to search for items:
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Type directly into the search box to filter the list of items
Type into the search box and press Search MBS to search for MBS items containing the search text in
the description.

TIP Medicare rules mean that it is not possible for two consultation items to be added to the one account
. The Finalise visit screen will delete any existing consultation item number if you add a new consultation
item.

8. To add additional items, repeat steps 4–7.
9. Items to bill displays items that have been selected by the user or added automatically. Items in this list

have the following right-click menu options:
To remove an item from the list, right-click on the item and select Delete.
If the item is a Care plan, Excision, or other item that needs further description, right-click and select Add
Text. Keep the text to a minimum and refer to your practicemanager for recommendations of the abbre-
viations to use.
If the Account type is a custom schedule, the Vary item option allows you to enter a specific fee to be
charged for this item. Refer to your practicemanager for recommendations on using this field.

10. If an item requires service text, double-click the item to open the Service text popup. Click the ... button to
enter predefined invoice notes.

11. Enter any Notes to reception that you need to bring to the attention of the reception staff. Text entered
here will pop up when reception staff create the patient account, and will be recorded on the account notes.
Provider notes do not appear anywhere on the invoice.

12. Tick theNot normal aftercare checkbox if the consultation is not normal aftercare. This will assist the recep-
tion staff and ensure that the account does not get rejected by Medicare if the patient has had other con-
sultations.

13. Tick the In hospital checkbox if the consultation was performed in a hospital. This affects the fee to be
charged.

14. If the consultation was performed in a nursing home, indicate theNo of patients seen in total so that the
correct fee will be charged.

15. If the provider is finished with the patient clinical record, click the Save and Close button.

If further information needs to be recorded after the consultation, click the Save button and continue work-
ing within the patient record.

Clicking either button will change the status of the appointment to At Billing (green shading) in theWaiting
Room and Appointment Book.

Finalising the patient visit is complete. Front desk staff can now process payment.

Retrieve a patient seen that day
The Previous Patients screen shows all of the patients that have their record opened on a workstation that day
for the logged-in user, and when they were seen. This screen is a convenient shortcut if a provider needs to
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reopen a record for a patient seen earlier. If a patient has seen multiple providers in one day, the patient will appear
on all of the providers’ Previous Patients screen.

To view the Previous Patients screen, press Shift+F2, or from themain screen select View > Previous patients.
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Find, move, or cancel an appointment

The File and right-click context menus in the appointment book provide options for cancelling and rescheduling
appointments. You can also view the users who have created and updated an appointment for auditing pur-
poses.

Swiping a patient's Medicare card while the appointment book is open also provides some shortcuts.

All of the following procedures start from the appointment book.

Find an appointment
1. Press F2 or select File > Find appointment. The Find appointment screen will appear.

2. Enter a partial surname into the Search for field to search for a patient, or select to search byMedicare No.
or Record No.

3. Select a patient in the top list to view that patient's appointments in the bottom list, from oldest at the top
to most recent at the bottom.
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4. Tick Show past appointments to also display historic appointments for this patient.
5. Select the appointment you want from the bottom list and click a button to action the appointment:

Print—Prints the appointment.
Go to—Opens the appointment book at the appointment.
Move—Opens theMove appointment screen to select another time.
Delete—Cancels the appointment. Bp Premier will ask for a cancellation reason.
Close—Closes the screen with no changes.

Cancel an appointment
You can cancel future appointments if the patient or provider becomes unavailable, for example. You may be able to
cancel a past uncompleted appointment, depending on the current status. You can also use theUncompleted
appointments screen to resolve past appointments. See Book or update an appointment on page 5 for more
information.

1. Find the appointment in the appointment book. Press F2 to search for the appointment by patient name if
necessary.

2. Right-click the appointment and select Cancel appointment. Select a reason the appointment was cancelled,
or enter a reason as free text and click Yes.

The appointment will be removed from the appointment book.

NOTE Cancelled appointments can be viewed using the Cancelled appointments utility.

Move an appointment
1. Find the appointment in the appointment book. Press F2 to search for the appointment by patient name if

necessary.
2. Right-click the appointment and selectMove appointment. TheMove appointment screen will appear.

Page 15 Bp Premier Appointment Book Guide



3. Select the day from theMove to calendar to move the appointment, and select a doctor from the list. The
list on the right hand side will show available appointment slots on that day.

4. Tick Include booked appointments to show all appointments.
5. Tick Jump to the moved appointment to open the appointment at the new appointment when finished.
6. Select the appointment slot to move to and clickMove.

Seewho created or updated a booking
To viewwho created and updated an appointment, select the appointment and press F10 or right-click and select
View Text.

The Created by line shows who created or moved a booking. TheUpdated by line shows who last updated a book-
ing.
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Check appointment reminder replies

While checking for replies to Bp Comms appointment reminders you can cancel, move, edit, or change the status
of related appointments.

If you have set up appointment confirmation, you should not need to manually update the appointment book
based on patient replies. However, if a patient has replied with a non-standard response, you can use the
Appointment Reminder Replies window to review such replies.

1. From the appointment book, select Utilities > Check Appointment Reminder Replies. The Appointment
Reminder Replies window is displayed.

2. Search for replies using the fields at the top left:
Appointment date range
Sent date range
Date range during which reply was received
Delivery status

3. Filter the appointments shown using the checkboxes at the top right:

Bp Premier Appointment Book Guide Page 18



Type text in Reply text to search for replies containing that text
Hide appointments when attendance already updatedwill only show appointments which have not been
confirmed or declined
Hide appointments with no patient reply only shows appointment reminders that have been replied to
by a patient
Hide deleted appointments removes deleted appointments from display.

4. Themiddle section of the screen shows the appointment reminders that have been sent and the status. Select
a message to see the sent text of the reminder and the reply text, if any.

5. Click Check Replies to check for any new replies that have been received. Bp Premier will show all replies
received, with themost recent at the top of the list.

6. Tick the checkbox Check for replies when I open this window to check for replies automatically.

Action appointments

If the patient has replied 'Yes' or 'No' (or any acceptable reply that has been configured in Setup > Con-
figuration > Appt Reminders), appointment attendance status is automatically updated. Other responses will
require manual update of appointment attendance status.

7. To update the appointment associated with a reply, select the SMS reply from the list and click one of the
action buttons along the bottom.

Button Description

Attending Mark the appointment as attendance confirmed.

Not attending Mark the appointment as attendance declined.

Reset attendance status Reset attendance to neither confirmed nor declined.

Edit appointment Edit appointment details. Not all details can be changed.

Cancel appt Cancel the appointment and supply a reason.

Move appt Move the appointment to another slot.

Appt status Change the status of the appointment, such as to 'Did not attend'.

8. Click Close to close the reminder replies screen.
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Rebook a patient from the cancellation list

The appointment book has a cancellation list, which holds patients who have future appointments but would
like to be seen earlier if a cancellation occurs. If an appointment is cancelled, you can set the cancellation list to
appear automatically.

Can I add a patient to a wait list without booking an appointment?

No. The cancellation list is for patients who have a future booking that can bemoved forward. Bp Premier's
appointment book does not have a 'wait list' that contains patients without a booking who are waiting for an avail-
able appointment that day.

Add a patient to the cancellation list
1. If you are booking an appointment for a patient, on the Appointment details screen, tick the Add to wait-

ing list for cancellation checkbox as shown below.

If the patient already has a booked appointment, right-click on the appointment and select Edit Appoint-
ment. Tick the Add to waiting list for cancellation checkbox.

2. If the patient is happy to see any provider if a cancellation occurs, not just their usual doctor, also tick the
Will see any provider for cancellations checkbox.
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3. Click Save to save the appointment.

Bring forward a patient's appointment
When an appointment is cancelled, the cancellation list screen can be used to bring forward a patient’s appoint-
ment.

1. Place the cursor in the appointment slot which is available and select View >Waiting list for Cancellations or
press Ctrl + F11. The Patients awaiting cancellations screen will appear.
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The screen lists all patients with future appointments who are waiting for a cancellation with the provider
shown. The list is sorted in the order that patients were added to the cancellation list.

2. To include patients waiting for cancellation who will see any doctor, tick Include patient who will see any-
body.

3. If you need to access more information about the patient, click the Patient details button at the bottom of
the screen.

4. To rebook a patient, select the patient in the list and click Select.
5. If the patient's original appointment is less than a week in the future, a message will appear. Click Yes to

accept.
6. The Accept cancellationwindowwill appear showing the patient’s details.
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7. To rebook the patient's appointment, click Accept.

To keep the patient on the waiting list, tick the Leave on waiting list for another cancellation box and click
Accept.

You will return to the appointment book.

Remove a patient from the cancellation list
1. Place the cursor in any appointment slot which is available and select View >Waiting list for Cancellations or

press Ctrl + F11. The Patients awaiting cancellations screen will appear.
2. Select the patient from the list and click Remove.
3. Click Yes at the prompt.
4. Click Close to close the cancellations list.

Automatically display the cancellation list
You can set the cancellation list to automatically appear whenever an appointment is cancelled, to help staff remem-
ber to fill cancelled appointments.

1. Select Setup > Configuration from themain Bp Premier screen.
2. Select the Appointments tab.
3. Tick the Show Cancellation list when an appointment is cancelled checkbox.
4. Click Save to save changes.
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Keyboard shortcuts

The following shortcuts are available from the server or workstation desktop:

Ctrl+Shift+B—Opens Bp Premier
Ctrl+Shift+P—Opens the Bp Premier backup utility.

Main screen

Key Ctrl+ Shift+

F2 Open patient Find Invoice Previous patients

F3 Inbox Create patient account Setup > Configuration

F4 Word processor Process payment Setup > Users

F5 Refresh screen Account holder history Setup > Preferences

F6 To Do List Patient billing history Setup > Sessions

F7 Log out current user Banking batches Setup > Practice Fees

F8 Internal messages Debtors list

F9 Print stored prescriptions Online claiming (bulk billing)

F10 Patient list Reports

F11 Contacts

F12 Appointment book Waiting room MIMS

Provider Inbox

Keyboard shortcut Action

Ctrl+N Indicate Normal result.

Ctrl+A No action required.

Ctrl+P Print report.

Alt+R Add reminder to patient.

Alt+A Add action.

Alt+S Add to past history.

Alt+M Add cervical screen.
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Keyboard shortcut Action

Alt+I Add INR.

Alt+P Previous result.

Alt+X Next result.

Alt+K Skip.

Alt+N Finish and close.

Patient record

Key Ctrl+ Alt+ Shift+

F2 Open patient Export patient

F3 New record (for item selected
in patient tree)

Observations Ceased Rx

F4 Word processor Medical certificate

F5 Refresh screen INR manager

F6 To Do List Request pathology Outstanding requests Request imaging

F7 Allergies and adverse reactions

F8 Internal messages Percentile charts Blood group Family & social history
> Occupation

F9 Print current open record Drug sheet Print eHealth health
summary

F10 Edit patient details Family & social history
> Family

Family & social
history > Alcohol

Family & social history
> Social

F11 Contacts Inbox

F12 Appointment book Pharmaceutical
product explorer

Travel medicine Patient education
materials

Patient tree view

Keyboard shortcut Go to

Ctrl+Alt+T Today's notes

Ctrl+Alt+V Past visits

Ctrl+Alt+X Current Rx
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Keyboard shortcut Go to

Ctrl+Alt+H History

Ctrl+Alt+I Immunisations

Ctrl+Alt+R Investigation Reports

Ctrl+Alt+C Correspondence Out

Ctrl+Alt+N Correspondence In

Ctrl+Alt+P Past prescriptions

Ctrl+Alt+O Observations

Ctrl+Alt+F Family/Social

Ctrl+Alt+Y Obstetric

Ctrl+Alt+S Cervical screening

Ctrl+Alt+E EPC

Ctrl+Alt+A Health assessments

Ctrl+Alt+L Care plans

Ctrl+Alt+M Medication reviews

Ctrl+Alt+D Diabetes cycle of care

Appointment book

Key Ctrl+ Shift+

F2 Find appointment

F3 New appointment Add account item

F4 Arrive patient

F5 Refresh screen

F6 To Do List Billing history

F7 Process payment

F8 Internal messages

F9 Print day sheet Print appointment list

F10 Account history
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Key Ctrl+ Shift+

F11 Contacts

F12 Waiting room

Waiting room

Key Ctrl+

F2 Start visit

F3 Add to waiting room Create account

F4 View notes Close waiting room

F5 Refresh screen

F6 To Do List Billing history

F7 Process payment

F8 Internal messages

F10 Account history

F11 Contacts

F12 Waiting room
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