Bp Premier Saffron Release Notes
These release notes describe the changes made to Bp Premier since version Jade SP4 1.10.4.910.
Release Date

13 January 2021

Release version

Bp Premier version Saffron (1.11.0.924)

Notes last updated

22 January 2021

What is in this release?

This release of Bp Premier includes secure messaging updates, other enhancements,
and bug fixes.
Review the new features described below, and Enhancements on page 13 for all other
changes.

Which version can I
upgrade from?

You can upgrade to version Saffron from Bp Premier version Indigo SP1 (1.9.1.863) or
later. To check the current program version that you have installed, select Help > About.

Which data update do
I need?

You must install the October 2020 Data Update or later before you can upgrade to
version 1.11.0.924. However, Best Practice Software recommend making sure you have
the most recent Data Update installed before you run a program upgrade.

Which database and
operating system versions
are supported?

No changes to supported operating systems or database since Jade SP3. SQL Server 2019
is supported.

When should I upgrade?

Best Practice Software recommend running the program upgrade outside of business
hours.

How do I upgrade?

Brief upgrade instructions are included in this document.

What do I do after
upgrading?

After upgrading, the Setup Third-Party Integrations screen will prompt you to enable
the specific partner role for any third-party database integrations that your practice uses.
You must enable integrations from this screen; all legacy integrations will be disabled
after upgrading to Saffron.
Review the section Upgrade notes on the next page for more information on changes
after upgrading.

Copyright Statement
This material is classified as commercial-in-confidence. Unauthorised distribution of this information may constitute a
breach of our Code of Conduct, and may infringe our intellectual property rights. This information is collected and managed
in accordance with our Privacy Policy, available on our website. © Copyright 2021
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Upgrade to Saffron 1.11.0.924
You must have the October 2020 data update or later installed before you upgrade to 1.11.0.924. The installation
file will have been provided to you by your Best Practice Software representative.
1.
2.
3.
4.
5.
6.

Back up your Bp Premier database before running the upgrade.
Synchronise all workstations in remote database mode with the Bp Premier server before you upgrade.
Download and run the latest Drug Update on your Bp Premier server computer.
Log all users out of the server and all clients before you upgrade.
Download and run the 1.11.0.924 update on your server and all clients.
Log back in to Bp Premier and resume use.

Upgrade notes
Third-party integrations
All legacy database integrations will be disabled after you upgrade to Saffron. The database account BPSRawData
has no permissions to any stored procedures. The accounts BPSClinical, BPSBIlling, and BPSAppointments have
been removed.
After upgrading, the Setup Third-Party Integrations screen will prompt you to enable the partner-specific role for
any third-party database integrations that your practice uses. You must enable integrations from this screen
immediately after upgrading, or through Setup > Configuration > Database in the software, or your database
integrations will cease to function after upgrading.
Best Practice Software recommend that practices with third-party integrations with the Bp Premier database
check that their integration is working as expected after the upgrade. If not, and you have enabled the application
role for the integration, it is possible that the vendor has not yet deployed an updated integration for the Saffron
version. Contact the third-party solution provider for an updated version.
What if my integration isn't third-party?
Practices with in-house custom integrations with the Bp Premier database (that is, integrations that the practice
has created in-house rather than purchasing a third-party solution) can contact the Best Practice Software Commercial Partnerships Team for more information on the changes in Saffron and the Bp Partner Network.
Password length
In this release, the maximum user password length has been changed from 10 to 20 characters. All password text
fields to log in to Bp Premier and other functions like utilities and BDI have been made conformant to a length of
20 characters.
In previous versions, password text fields only accepted the first ten characters of a password, even if the user
had typed in more than ten characters. This could lead to users potentially believing their password was longer
than it really was. After upgrading, any such users who try and log in with their 'long' password will be denied
access, because it will not match the ten characters stored in the database.
If your staff are having trouble logging in after upgrade, they must enter only the first ten characters of their
remembered password at the login screen. After they successfully log in, users with the ability to change their
own passwords can do so and create a new password of up to 20 characters.
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Secure messaging
Saffron includes support for the requirements of the ADHA Secure Messaging Industry Offer, which aims to
greatly reduce paper-based messaging exchanged between health service providers and organisations. The secure
messaging improvements will allow practices to:
Create, send, and receive messages that can understood by all parties including clinical information systems
like Bp Premier and secure messaging directories.
Look up and retrieve message recipients from new FHIR-based directories.
Connect to the HI and My Health Record services using NASH PKI Organisation Certificates and current
encryption standards.

FHIR online directories
Bp Premier Saffron includes support for version R4 FHIR-compliant online provider directories.

IMPORTANT At the time of release of Bp Premier version Saffron, January 2021, there are no version R4 FHIRcompliant online provider directories available to select in Bp Premier.

If you follow the instructions in this article and set up FHIR interoperability for your practice, no version R4 directories will be available from the Online Directory Messaging Provider list in the Configuration screen. The FHIR
HealthLink directory will be available, but this option is not yet compliant to version R4.
As vendors release R4-compliant provider directories, new FHIR directories will be added to Bp Premier in a
monthly Data Update and published in the Data Update release notes. After you install the Data Update, the directory will be available for selection as a provider directory and can be browsed and synchronised with Bp Premier
local contacts.
HL7 version
If you have selected an R4 compliant FHIR directory and set up the sending facility, Bp Premier can send HL7 files
as version 2.4 with embedded PDFs, if the recipient can accept that version. If you do not select a messaging provider or leave the sending facility blank, Bp Premier will always send HL7 files as version 2.3.1.
Address book contacts
Users can search and retrieve recipients for addressing in referrals and correspondence, and synchronise local contacts with FHIR online directory entries. You can search FHIR directories by suburb and postcode. Synchronised
local contacts are checked for any updates from the online directory when addressed in correspondence.
Search results include both health service providers for individuals and organisations, clearly distinguished in the
results panel. When searching for a category specific to organisations, Bp Premier will return only organisation results.
Following up correspondence
Sent and received messages can be followed for FHIR directory contacts through the View > eReferrals and View
> Incoming reports functions, and errored messages can be audited through the log file viewer.
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If a recipient cannot accept a HL7 2.4 compliant message, messages will be sent by HL7 2.3.1 instead. Bp Premier
can accept CDA packages with both SHA-1 and SHA-2 encryption with valid or invalid digital signatures. For invalid
signatures, Bp Premier will accept the package but warn the user that the message and contents may have been
tampered with, for manual deletion or handling by the user.

NASH PKI validation and expiry
Bp Premier now accepts both SHA-1 and SHA-2 NASH PKI certificates when validating to the HI or MHR services.
Impending NASH certificate expiry is now alerted to the Principal Doctor and Practice Manager user roles on login,
and also displayed at the bottom of the My Health Record Document List. The time before expiry is alerted (for
example, 90 days) is configurable.

Results acknowledgement
Bp Premier now runs a set of scheduled tasks daily that identify the following:
sent messages that have not been acknowledged in 72 hours since the send time
sent messages that have received a negative acknowledgement.
and sends a report to a nominated user with the information for actioning. This function is configurable from Configuration > Results Import.

Active ingredient prescribing
Prescriptions written for PBS and RPBS medication will now have the medication's active ingredients listed on
them by default, rather than a brand name. You can still include a brand name on the script as well as active
ingredients, if the prescriber considers the brand name necessary for safety or other reasons.
The Add Rx workflow is largely unchanged from previous releases. You can still search for medication by brand
name.

Change to script
Up to three active ingredients will be printed followed by dosage strength, separated by a plus sign. For medications with four or more ingredients, the brand name will be printed instead.
If the prescriber has chosen to also list a brand name on the prescription, the brand name will be included in
brackets after the active ingredients.

Exceptions
A number of exceptions exist in which Bp Premier will continue to print only the brand name on the script, including but not limited to:
custom preparations
paper-based medication charts in residential aged care facilities
over the counter medication
non-medicinal PBS and RPBS items, such as dressings and food supplements
vaccines
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For a more complete list of exceptions, refer to the Active Ingredient Prescribing article in the online help (Help
> online > search for 'aip').

National Cancer Screening Register
Bp Premier Saffron features an integration with the National Cancer Screening Register (NCSR). Patients registered
with the National Cervical Screening and Bowel Cancer Screening programs will feature a dedicated NCSR 'hub' in
their clinical record. From the hub, you can:
view test results and screening histories
manage NSCR-specific correspondence
submit forms to the Register, such as iFOBT kit requests, colonoscopy and histopathology reports, and optin/opt-out
manage a patient’s screening participation
nominate other people to assist your patient (such as a personal representative or another Healthcare Provider)
provide NCSR feedback.
NSCR alerts are also displayed in the regular Notifications list for a patient, such as 'Patient has an iFOBT Positive
result this round', and you can record NSCR-specific actions for follow-up.
NSCR is enabled at the practice level and the provider level. If users have access to the patient record and enable
NCSR in user preferences, Bp Premier will prompt the user to install the NCSR components on login. NCSR setup
will require a few minutes to install the hub components.
To enable NCSR integration, your practice will need a PRODA account with Services Australia (previously DHS).

Medicare refunds
Saffron introduces a Medicare Refunds function for cases where a batched item needs to be refunded after the
claim has already been paid.
Currently, this is a manual process of submitting the paperwork, refunding the incorrect value, and reclaiming the
item, and requires a support call to Best Practice Software to remove the payment and adjust the service. The
Medicare Refunds option records the refund in a new Refund/Adjust Payment screen. This screen allows you: to
mark a service as refunded; record a reason for refund; and record the amount to refund and the refund method
(Direct Credit or Cheque). When you save the refund, Bp Premier will automatically create the service and payment adjustments required.
You can also add a free text comment to supply additional information about the adjustment.
The Billing History screens will show the service with a status of ‘Written off’ and the service adjustment will have
a description of ‘Voided Service…’. A payment reversal credit and a refunded deposit record will also indicate that
the money was refunded to Medicare or allocated to another invoice. The Management Reports will show the service adjustments as ‘Written off’ and payment adjustments with a status of ‘Medicare or DVA refund’, making it
easier to identify changes to doctor payments.
Access to Medicare Refunds is controlled by a new user permission Medicare Refunds.
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Additional Medicare refund options such as part refunds, assigning payment to another item, and changing number of patients will be added in future releases.

Improved filtering
An Apply filters button has also been added to the Online Claiming screen to make it easier to apply multiple filters. In the past, the screen would refresh each time you changed one of the filters. A large number of batches
loaded in this screen could take some time to refresh. Filter options will now only be applied when this button is
clicked, allowing you to select multiple filters before the screen refreshes.

Electronic prescribing
This release of Bp PremierBp Premier includes an updated version of the electronic prescribing functionality that
was introduced in Jade SP3. Practices will no longer need to down and run an enablement utility and confirm their
practice lies in a Community of Interest.
ADHA has advised that government funding will be extended for ePrescriptions until 31 March 2021.
Fast tracked ePrescriptions will continue to be supported at no cost to practices. For practices who are permitted
to use them, ePresciptions will continue to work in Jade SP3 after 30 September 2020.
This information is correct at time of writing but subject to change.

Security
Password security and user account access has undergone significant changes in Saffron to conform with ADHA
standards for practice management systems that use electronic prescribing. A new tab Security has been created
in Setup > Configuration that allows Bp Premier administrator to manage password and access security in the following ways:
Minimum password length
Maximum password age in days before mandatory reset
Minimum number of days before a password can be reused
Minimum password strength (stronger settings require inclusion of non-alphanumeric characters, for
example)
Minimum number of user login attempts before lockout
Minimum period of inactivity in minutes before a user's account is locked out
Minimum wait period in seconds before login can be reattempted after lockout.

Bp Comms
Sending a token to SMS or App will also now generate a patient contact note for auditing purposes.

Active script list
Active Script List escripts will be available in a future release of Bp Premier. Electronic prescribing in Saffron will still
use the token model.
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On upgrading to Saffron
After the server and clients have been upgraded to Saffron, Best Practice Software recommend that an administrator enter the Configuration screen and configure password security for your practice. After setting up password security, all Bp Premier users whose passwords do not meet the criteria will be alerted to update their
passwords when they next log in.
If a user does not have the ability to change their own password, an administrator will have to do this so the user
can log in.
Best Practice Software recommend that you communicate these changes, particularly the inactive period lockout,
to your practice staff and update any guidelines you have about locking access when away from workstation.

Supported Prescription Exchange Services
eRx is the only supported Prescription Exchange Service for electronic prescribing in Saffron. Support for MediSecure and electronic prescriptions will be available in Saffron Service Pack 1 later in 2021.
If your practice uses MediSecure and will not be issuing electronic scripts, you can upgrade to Saffron and continue to use Medisecure as normal.

NOTE You cannot enable multiple Prescription Exchange Services concurrently within Bp Premier. If your practice uses MediSecure and you wish to use electronic prescribing, Bp Premier will prompt you disable MediSecure before enabling eRx.

Real-time prescription monitoring
Real Time Prescription Monitoring is a clinical tool available to practices running Bp Premier to help doctors and
pharmacists make safer decisions when prescribing certain high-risk medicines.
Real Time Prescription Monitoring is currently available in Victoria only, as 'SafeScript'. However, other states are
also working toward National Data Exchange integration.
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Notice of sunset versions
Jade SP2 (1.10.2.893) and all prior versions are considered sunset when Saffron is released in January 2021.
Support for Jade SP3 and Jade SP4 ceases at the end of March 2021. At this time, the Fast Track ePrescribing
period ends and both service packs will be non-conformant. Practices that wish to continue using electronic prescribing must upgrade to Saffron or later after this date.
For more information on sunset versions, search for 'sunset' in the Bp Premier Knowledge Base (Help > Online).

Where do I find more information?
Select Help > Online from Bp Premier to open the Knowledge Base and search for more resources on the enhancements in Bp Premier Saffron.
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Bug fixes
Bp Function

Release Notes

Key

Billing

Some MBSGroup M12 items were prompting for a referral when invoiced, but no
referral was required. This has been fixed.

27946

Upgrading

A prompt to replace fonts sometimes appeared when upgrading to previous
versions. This no longer appears, and no longer affects silent installations.

39273

Billing

The Number of Patients Seen quantity was not being sent to Medicare for items
with no Multiple Procedure Override where items in the same batch had
Multiple Procedure Override selected. This has been fixed.

44356

Add Rx

You no longer need to double-click New Condition when adding a new condition
in the reason for prescription panel when adding a new Rx.

23097

Appointment book

Ticking Hide providers without available sessions now hides visible providers that
don't have any sessions at the selected location, including those with an
'elsewhere' status.

12672

Best Health App

Attempting to onboard a location where the time between the Bp Premier
server and the Best Health App system is out of sync results in the message 'An
error occurred uploading the practice details to the server'.

14843

Bp Comms

When setting up Bp SMS or Best Health App, the user is now prompted to set the
primary and secondary preferred contact method if left blank and Save is clicked.

17157

Billing History

If you backdated a payment, and adjusted the payment in the Patient or Account
Holder Billing History screens by changing the Location or amount, the payment
date was reset to today's date, causing an inaccuracy. This has been fixed.

17381

The date range for the payment date picker when creating or adjusting a
payment is now set from <earliest service date against related invoice(s)> to
<Today>.
Check for payments

Some sites with Multiple Minor IDs experienced issues running Check for
payments for Tyro Bulk Bill Easyclaims. This has been fixed.

12664

Contact notes

Printing an individual contact note no longer causes Bp Premier to fail.

21451

Electronic
prescribing

When resending a token from Past Prescriptions, if the user is not configured
with eRx at that location, the option to email is removed from the resend
methods list.

26689

EPC

When reprinting an EPC document, the first page of the printed report now
prints in portrait.

12665

eReferrals / My
Health Record

Attempting to send an eReferral or generate an Event Summary where the
Investigation test name contains a '&' character resulted in an error. This is now
fixed.

13483

HealthLink Forms

Correspondence Out now refreshes when the HealthLink browser window is
closed, showing any forms that were submitted.

13485
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Bp Function

Release Notes

Key

HealthLink Forms

Bp Premier now correctly passes the provider number for the logged-in location
to the Medicare Provider Number field, instead of the Usual location provider
number.

13481

Immunisations

When submitting immunisations to AIR, a demographics error in a patient record
now indicates the correct patient.

19631

Immunisations

When submitting immunisations to AIR, the 'Patient's Medicare card number
must be supplied' alert now indicates the correct patient.

25189

Installation

A fatal error occurred when opening Bp Premier on a server or client if the
BPSSamples database does not exist. This has been fixed.

27790

Incoming reports

Bp Premier now uses the MDM^T02 segment of a CDA message, and not the
Intended Recipient, to address the result correctly.

12668

Incoming results

Bp Premier generated an error when Auto-allocate was attempted from
Incoming Results. This has been fixed.

21323

Invoices

Some care plan items could not be claimed together, or more than once, on the
same invoice. All care plan items can now be claimed correctly on a single
invoice. Some items claimed multiple times will require service text or restriction
code.

20239

Invoicing

You can now bill item 30001 on a direct bill invoice.

13537

Medicare forms

The Medicare Statement of Claim now prints clearly with no overlapping lines.

22267

Online claiming

When billing item 31340 and an associated item to Medicare, item 31340
replaced an incentive item and was sent twice. This has been fixed.

25828

Online Claiming
(batched)

Resent Batches are no longer checked during a check for payments.

23103

Online claiming
(batched)

When a processing report was downloaded via Get Processing Report, for claims
that are paid in the batch, payment service and payment part service records
were not created unless the service had been adjustment. This has been fixed.

14673

Pathology

Some results were not being imported correctly after being parsed and escaped
for database security. This has been fixed.

15886

Pathology

Sometimes an 'Invalid column name' error was generated when e-ordering or
printing a pathology request. This has been fixed.

19737

Pathology

You can no longer create a Favourites list with no tests from the patient record.

8567

Pathology

When importing a test list via View > Contacts > Edit Contact > Setup E-ordering >
Import test list , Bp Premier incorrectly identified text within Collection
Requirements as valid tests. This has been fixed.

12998

Patient record

The topmost icon in the patient tree view has been reinstated.

21170

Prescribing

The SNOMED code is now set correctly when the Reason for prescription field is
blank.

23026
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Bp Function

Release Notes

Key

Prescribing

The checkbox Preferences > Prescribing > Always save as Reason for visit now
remains unticked if unticked and Save and Close is clicked.

20169

Recall appointments

Deleting a supplied appointment type could result in the Recall appointment not
selected by default when booking an appointment from the Follow up Inbox. This
is now fixed.

12667

Recall appointments

The system appointment type 'Recall' can no longer be edited or deleted.
Practices can still create custom 'recall' appointment types.

50379

Reminders

When sending reminders, removing groups of patients from the list more than
once could result in reminders being sent multiple times. Patients are now
removed from the list successfully when the list is refreshed.

12669

Remote download

Editing the dose for Current Rx while in remote download no longer generates an
error.

23781

Reports

Incoming reports can now be scrolled through the entire document when first
viewed in the PDF viewer.

22293

Reports

Incoming HL7 files that contain a NUL character are now imported without error.

26506

Results import

If an imported HL7 file had more than one OBX segment that contained a PDF, the
PDF segments were not displayed and an error thrown. This has been fixed.

13480

Results import

Embedded links in reports are now formatted correctly on importing and will
open when clicked.

9564

Results import

Subject category is now populated correctly for HL7 files with PDF or HTML
segments in Correspondence In.

13484

Results import

PIT files import and are listed successfully in Incoming Reports.

26006

Secure messaging

CDA eReferrals now corrrectly contain the account ID in the MSH-6 segment.

25093

Statement of claim

The Statement of claim and benefit payment no longer prints the benefit amount
over two lines at the service line and the total.

9618

Telehealth billing

A user could not invoice multiple Telephone and Telehealth MBS item numbers
for combinations of Management Plans and Team Care Arrangements. This has
been fixed.

18944

Today's notes

If you recorded an antenatal visit for a patient and then clicked 'Jump to another
patient record', the antenatal notes were carried over into the new patient's
notes. This no longer occurs.

23545

Upgrading

Update Databases has been updated to fix Application Role caching issues that
may cause Bp Premier to freeze.

23412

Upgrading

Bp Premier sites that were not using Bp SMS can now adjust appointment
reminder consent correctly after upgrading to Indigo SP1 or later.

8192

Upgrading

A timeout during a data update was causing partner app roles to have incorrect
permissions. This has been fixed.

27003
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Bp Function

Release Notes

Key

Pathology requests

Issue with tests from previous requests being printed on new requests when
selecting 'No' to the prompt asking if you wish to change the laboratory fixed.

48558

Billing

Intermittent Issues reconciling item 291 and other similar items when claimed
with item 288 is resolved

41277

eScripts

eScripts now cancelling correctly when a paper script is printed.

49842

eScripts

Error message that appears when a practitioner's qualifications exceed 50
characters is now more user friendly.

50056

Prescribing

Issues with prescribing Palexia have been resolved.

50261

Prescribing

Adding an adverse reaction no longer ceases other eligible Rx.

50270

Billing

Care plan and attendance items can now be bulk billed on the same day.

50085
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Enhancements
Bp Function

Release Notes

Key

Active ingredient prescribing
Active ingredient
prescribing

If prescribing a custom prep, no NDE precheck is performed regardless of
whether a monitored drug has been added as an ingredient.

30978

Active ingredient
prescribing

When represcribing a brand that is no longer valid (has been phased out) and AIP
is implemented, the user is notified that the brand is no longer available but the
generic is still available, and that the Active Ingredient will be prescribed on the
script.

26167

Alternative brands are now populated when a discrepancy between quantity and
repeats exist.
Add Rx

See Active ingredient prescribing on page 4 for more information.

13030

Secure messaging
Certificate validation

SHA-2 NASH certificates are supported for connecting to the HI and My Health
Record services.

13660

Certificate validation

Impending NASH certificate expiry is now alerted to the Principal Doctor and
Practice Manager user roles on login. The default period of notification before
expiry is 60 days.

13614

Contacts

When synchronising a local contact from an online directory, the contact's
messaging provider will now be set to the Online Directory Messaging Provider
selected in Setup > Configuration > General, if a compliant directory has been
chosen.

20256

Messaging
configuration

New dropdown list Online Directory Messaging Provider has been added to
Configuration > General to record the messaging provider used when a FHIR R4
compliant online directory is chosen in the Online Directory for Contacts field.

17353

Messaging
configuration

A new button and popup screen Configure Sending Facility has been added to
Configuration > Messaging > Messaging Provider. This function retrieves your
practice details from the online directory, or manually configures your practice
as an endpoint in the secure messaging chain, and must be completed to be able
to send HL7 2.4 messages.

20257
20255

If you are unsure of how to set up your sending facility, your secure messaging
provider can assist.
Online directories

You can now search by suburb as well as postcode in an online directory.

13616

Online directories

Search results include both health service providers for individuals and
organisations, clearly distinguished in the results panel. Organisations are
collapsed by default.

13617

When searching for a category specific to organisations, Bp Premier will return
only organisation results.
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Bp Function

Release Notes

Key

Online directories

Specialty Code mappings have been updated to support Institutions.

13618

Online directories

When addressing a synchronised contact, Bp Premier now checks that local
contact has the most up-to-date details from the online directory.

13619

Results
acknowledgement

HL7 acknowledgements have been updated to support the conformant HL7 2.4
standard.

13625

Results
acknowledgement

Bp Premier now runs a set of scheduled tasks daily that identify sent messages
that have not been acknowledged in 72 hours since the send time, and sent
messages that have received a negative acknowledgement.

13627

Nominate a user to receive the report from Configuration > Results Import.
Secure messaging

When a compatible online directory and recipient has been chosen, letters sent
via secure messaging will now be sent via HL7 2.4 with a PDF display segment.

13623

Secure messaging

A PDF payload is now possible for HL7 2.3.1 and 2.4 secure messages.

13009

Secure messaging

The checkbox Include a Formatted OBX in REF has been moved from
Configuration > General to Configuration > Messaging > Messaging Provider, and
can now be set per messaging provider.

13626

This option has the same effect as previous versions: a Fomatted Text equivalent
of the contents is also included in the message.
Secure messaging

Bp Premier alerts the user if the intended recipient for a FHIR R4 directory
cannot accept that HL7 version, and suggests sending as an alternate version.

16385

Medicare certificates

If a site imports a certificate with a policy number of 1.10.1.1, Bp Premier will
detect as a dual NASH SHA-1 certificate and disable the Medicare radio button in
the import certificate utility. Importing this certificate will import as both HI and
NASH certificate.

28178

Medicare refunds
Banking Batch

The Banking Batch function includes Medicare refunds that apply.

14493

Patient Billing History

The Patient Billing History function includes Medicare refunds, and includes new
Comment and Refund columns.

14487

Find Invoice

The Find Invoice function includes Medicare refunds.

14492

Online Claiming

A new Refund/Adjust Payment screen is available from the Online Claiming
screen top and right-click menu to handle whole refunds of Medicare payments.

14479

See Medicare refunds on page 5 for more information.
Online Claiming

A Comment column is now visible in the Online Claiming screen.

14486,
14494

Online Claiming

Payment records aren't created when re-downloading payment reports if all
services in the batch have been refunded. Services that have refunds aren't reset
when re-downloading Processing reports.

14491
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Bp Function

Release Notes

Key

Online Claiming

The top half of the Online Claiming screens includes a new column Refund. The
bottom half of this screen includes new columns Refund, Invoice No, and
Comment.

14477

Online Claiming

An Apply filters button has been added to the Online Claiming screen to stop
refresh slowness.

14476

Reports

Management Reports will show the service adjustments as ‘Written off’ and
payment adjustments with a status of ‘Medicare or DVA refund’.

14490

User Permissions

A new user permission now controls access to the Medicare refunds function.

430

Contact notes

A new contact note reason 'eScript Token' has been created, and will
automatically be created when an electronic prescription token is prescribed for
a patient. This contact note cannot be resent from the Contact Notes function.

24097

electronic
prescriptions

Electronic prescriptions can be resent to App.

26387

Electronic
prescriptions

The maximum quantity authorised to dispense is included when prescribing
controlled drugs via electronic prescription.

23775

Electronic
prescriptions

The authorisation reference number is included when prescribing controlled
drugs via electronic prescription. The actual label corresponds to the state of
issue (for example, “Approval number” in QLD and ACT).

23776

Electronic
prescriptions

The Revalidation prompt when prescribing controlled drugs via electronic
prescription checks for password security compliance.

25594

Electronic
prescriptions

Electronic prescriptions can be resent to SMS.

26399

Electronic
prescriptions

Electronic prescription tokens can now be sent to Best Health App. Bp Comms
credits are required.

18632

Electronic
prescriptions

Electronic prescription tokens can now be sent to Bp Comms SMS. Bp Comms
credits are required.

18631

Electronic
prescriptions

Depending on the location of the practice and the logged-in user category for the
prescriber, the following information is included in the electronic
prescription: 'for ocular treatment only', 'for optometris use only', or 'for
midwifery use only'.

23777

Log viewer

You can export readable logs from the BPS Log Viewer utility. A user requires
Configuration permission set to 'Allow Access' and Prescription permission set to
'Add/Edit/Delete'.

23774

Password security

Setting to enforce password reuse time limit.

18644

Password security

Setting to enforce lockout timeout from failed login attempts.

18625

Password security

Setting for minimum password length.

18641

Prescribing
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Password security

New Security tab in Setup > Configuration that controls password security
options.

18624

Password security

Setting to enforce an inactivity timeout and account lock.

18626

Password security

Setting to force creation a new password after set time.

18643

Password security

Passwords are now checked for compliance with password security settings.
Users whose passwords do not meet the new settings will be prompted to
change their password.

19823

Password security

Setting to enforce password complexity.

18642

Password security

If the 'Strong' password complexity configuration option is enabled, case
sensitivity is enforced when logging in to Bp Premier.

23773

Password security

Maximum password length has been increased to 20 characters.

19640

Password security

The Security tab contains a link to the Knowledge Base article for guidance on
password security settings.

19435

Prescribing

When prescribing a cream or similar type of drug, Bp Premier sends both the
quantity (number of units) and a unit size (for example, 30 grams, 50 grams) to
eRx.

29724

Prescribing

A Consent to Upload to ASL check box has been added to the Availability panel
of the Add Rx or Edit Rx workflow to indicate that the Rx will be uploaded to the
patient's Active Script List.

28176

Real-time
Prescription
Monitoring

Medications prescribed by electronic prescription are now checked against the
National Data Exchange when the electronic prescription is sent if the NDE is
enabled for the user and applies to the practice's state.

26577

Real-time
Prescription
Monitoring

Enable real-time prescription monitoring checkbox is now available in user
preferences for all Australian states. Note that RTPM is currently available in
Victoria only.

26573

Remote download

When in remote download mode, only password lockout period, number of login
attempts, and password complexity remain in effect. Other password security
settings will not apply to users in remote download.

23972

Security

A new button Permission changes has been added to the Security Audit function
to show historical permission changes.

19825

Utilities

Bp Utilities have been updated to handle new password security parameters.

19235

National Cancer Screening Register
FHIR

A new FHIR tab has been added to Setup > Configuration for setting FHIR
permissions for each FHIR-enabled vendor integrating with Bp Premier.

14273,
14274

FHIR

Before any FHIR-enabled vendors can be configured for FHIR, the FHIR API needs
to be installed on the server first, and the ports utility run to open up the FHIR
port.

14281
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FHIR

When setting permissions in Setup > Configuration > FHIR tab, if FHIR API has not
been installed, Bp Premier will alert the user.

14275

FHIR

You cannot install FHIR components on a client.

14282

FHIR

A Port setting exists in the FHIR tab to choose the port used by the FHIR service.

14278

NCSR

NCSR integration can be enabled for the practice in Configuration.

14190

NCSR

NCSR integration can be enabled for the provider in user preferences.

14193

NCSR

The NCSR utility will write notifications for the patient into their record, and these
will display in the notifications panel for actioning.

14196

NCSR

The NCSR Hub can be opened from the patient clinical record.

14199

NCSR

The NCSR Forms screen can be opened from the patient clinical record.

14200

Patient record

The Reason column fill the full width of the notifications table when the screen is
expanded.

14202

Patient record

The appropriate form, or the NCSR Hub, opens when an NSCR notification is
ticked.

14201

Patient record

NCSR data is updated automatically when the patient’s record is opened

14194

Utilities

The Support Ports utility has been updated to include the FHIR port setting.

14936

Appointment Book

The appointment book now loads and refreshes significantly faster.

15767

Auditing

Bp Utilities > Security audit can now be exported as a CSV document. The
document contents will contain the data on screen according to the selected
filters.

29875

Bp Comms and
Licencing

Bp Comms functions (sending messages to SMS and Best Health App) are now
available for Bp Premier sites with a Clinical-only licence. Clinical-only sites will be
able to use all electronic prescribing sending methods after upgrading to Saffron.

28144

Other

Scheduled appt reminders will not be available for clinical-only sites.
Database viewer
account

BPSRawData, and the following views in the Database Browser utility—BPS_
Prescriptions, BPS_All_Prescriptions, and BPS_CurrentRx—will not have access to
the SCID (eRx) and Barcode (MediSecure) columns in any table.

26580

eRx

Blank Medicare expiry fields are now transmitted as NULL to eRx.

27298

HealthLink Forms

Performance when using HealthLink Smart Forms has been significantly
improved in Saffron.

13541

Installation

SQL Server 2019 is an option for new installations of Bp Premier Saffron.

13026

Patient Demographics

Users with a role of 'Practice nurse' can now be selected as a patient's Usual
Doctor in demographics.

29030
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Radiology

You can now add a custom body region and a test name as free text in the regular
and e-Ordering Imaging request screens.

8562

MSH-6 in the ORM file is now populated with the short name for e-ordering
radiology providers.

Known Issues
Bp Function

Description

Key

Configuration

An option Enable Service Registration Assistant for management of users and
locations is visible in Setup > Configuration. This function is not yet available and
should not be enabled at your practice. The option will be disabled in a future
update of Bp Premier.

--

Prescribing

Best Practice Software has identified an issue when prescribing Venlafaxine with
the dosage of 37.5mg capsules, which then prints as Venlafaxine 75mg.

--

This has been resolved in the January 2021 Data Update. Best Practice Software
recommend running this data update to resolve this issue.
Upgrading and
Installation

The links to release materials in the Bp Premier Saffron Install and Upgrade
Wizards point to old versions of Bp Premier.

--

For information on What's New, Best Practice Software recommend selecting
Help > Online within Bp Premier after upgrading and viewing What's New, or the
new feature links from the knowledge base home page.
Prescribing

Strength is not printed for Champix Starter pack, Varenicline Starter pack and
Arava Combination Pack when Active Ingredient Prescribing is enabled.

50971

Referrals

From the patient record, selecting Correspondence out > Add > Send HL7 and
then closing the document will prompt to save changes even if the user has
made no changes to the last saved version of the document.

51140

If this prompt appears, and you are sure that you have made no changes since
the last time you saved this document, you can click No to this prompt.
Behaviour is otherwise as expected.
Electronic
prescribing

If the total length of qualifications recorded in the provider details is over 50
characters, the user will be alerted that the qualifications list sent with the token
is too long. The script will still be printed.

41072

Best Practice Software software recommend that the qualifications list for users
who receive this message truncate their qualifications to under fifty characters.
This is a limitation imposed by the electronic script token format and not Bp
Premier.
Electronic
prescribing
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Ceased eScripts are unable to be cancelled or deleted from Past Prescriptions.

44439
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