
Bp Premier Saffron SP1 Release Notes
These release notes describe the changes made to Bp Premier since Saffron build 1.11.0.924.

Release Date  09 June 2021

Release version Bp Premier version Saffron SP1 (1.11.1.934)

Notes last updated 19 July 2021

What is in this release? This release of Bp Premier includes support for MediSecure and electronic prescribing,
HPI-O multilocation support, other enhancements, and bug fixes. Review New Features
on page 3 for more information on major changes in this release.

Which version can I
upgrade from?

You can upgrade to version Saffron SP1 from Bp Premier version Indigo SP1 (1.9.1.863)
or later. To check the current program version that you have installed, select Help
> About.

Which data update do
I need?

You must install the May 2021 Data Update or later before you can upgrade to version
1.11.1.934. However, Best Practice Software recommend making sure you have the
most recent Data Update installed before you run a program upgrade.

Which database and
operating system versions
are supported?

No changes to supported operating systems or database since Saffron 1.11.0.927.

When should I upgrade? Best Practice Software recommend running the program upgrade outside of business
hours.

How do I upgrade? Brief upgrade instructions are included in this document.

What do I do after
upgrading?

No particular configuration is required after upgrade. If you have previously disabled
MediSecure for providers in order to use electronic prescribing, you can reenable
MediSecure after upgrading.

Copyright Statement

This material is classified as commercial-in-confidence. Unauthorised distribution of this information may constitute a
breach of our Code of Conduct, and may infringe our intellectual property rights. This information is collected and managed
in accordance with our Privacy Policy, available on our website. © Copyright 2021
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Upgrade to Saffron SP1 1.11.1.934

You must have theMay2021 data update or later installed before you upgrade to 1.11.1.934. The installation file
will have been provided to you by your Best Practice Software representative.

1. Back up your Bp Premier database before running the upgrade.
2. Synchronise all workstations in remote databasemodewith the Bp Premier server before you upgrade.
3. Download and run the latest Drug Update on your Bp Premier server computer.
4. Log all users out of the server and all clients before you upgrade.
5. Download and run the 1.11.1.934 update on your server and all clients.
6. Log back in to Bp Premier and resume use.

Upgrade notes

No particular configuration is required after upgrading to enable new features. MediSecure can now be enabled
for providers who wish to useMediSecure and send electronic prescription tokens. The workflow for indicating
permitted brand substitution has changed in Saffron SP1.

When your practice upgrades to SP1, if messaging providers are set up using the same path for incoming and out-
going files and Allow acknowledgementswas previously ticked, this checkbox will be disabled and the practice
manager and principal doctor will receive a message in Bp Premier notifying them of the need to provide separate
folders for different messaging providers.

Best Practice Software recommends that practices who use the eOrdering functionality for pathology or imaging
reconfigure their eOrder laboratories using the new eOrder configuration in Saffron SP1. Search for 'eOrder' in the
knowledge base for more information.

Where do I findmore information?

Select Help > Online from Bp Premier to open the Knowledge Base and search for more resources on the enhance-
ments in Bp Premier Saffron SP1.
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New Features

Waiting list

As of Saffron SP1, patients with or without an existing appointment can be added to the cancellation list.

Allow Brand Substitution

In Saffron SP1, The Allow brand substitution checkbox functionality is linked to the Print brand name on scripts
checkbox. If you select a brand in the first panel of the NewRxwizard, the Allow brand substitution checkbox in
the third panel will be greyed out and unticked. If you select Print brand name on scripts, the Allow brand sub-
stitution checkbox will be enabled and ticked. You can then choose whether or not to leave the Allow brand sub-
stitution checkbox ticked.

Subpoena Tool

You can now export from the Subpoena Tool to PDF.

Support for Medisecure and electronic prescriptions (tokens)

Saffron SP1 includes support for sending electronic prescription tokens if you have enabled MediSecure. The work-
flow for sending electronic script tokens is the same for both eRx and MediSecure. At the end of the Add Rx work-
flow, you can choose to send to 'escript' instead of printing the script.

For more information on how to send, resend, or cancel an electronic script, select Help > Online from Bp Premier
and search for 'electronic script'.

The option Upload to My Health Record is now enabled in the NewRxworkflow ifMediSecure is configured as
the Prescription Exchange Service (and the patient has a valid Health Identifier and My Health Record). This option
is ticked by default, indicating the patient has opted in. This option can be unticked if the patient has requested
that their medications not be uploaded to their My Health Record.

You can still enable only one of eRx or Medisecure for a provider, not both.

Electronic ordering configuration for pathology and imaging

Saffron SP1 introduces a new setup screen for configuring pathology and imaging e-ordering, and synchronising
eOrdering laboratory contact details with the Bp Premier internal contacts list. The new setup screen groups the
functions found under Setup > Preferences > Pathology and Imaging and View > Contacts, allowing system admin-
istrators to configure eOrdering defaults for providers from one screen.

The process of submitting electronic orders remains unchanged.

Patient Health Identifier validation

Bp Premier will prompt for a patient's Individual Health Identifier (HI) to be reverified from patient demographics if
changes have been made to a patient's identifying details (such as name, sex, DOB, Medicare/DVA number) in
demographics or through a third party integration, such as an online appointment booking system.
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Bp Premier will also check the patient's HI verification status when creating an eReferral or eOrder request. If the
HI is unverified, the HI will not be submitted with the eReferral or eOrder. A patient requires a verified HI to send
an eReferral in CDA format; the eReferral will be sent in a REF format instead.

You may see this prompt in Bp Premier workflows such as creating an invoice, booking an appointment, or arriv-
ing a patient: 

Click OK to continue. Best Practice Software recommend opening the patient's demographics and clicking Save to
update and reverify the patient's HI before continuing.

NOTE This prompt will only appear for appointment-related workflows if the Configuration options Pop up
notes when making appointments and Pop up notes when patient arrives have been ticked.

eReferral acknowledgements

When setting up a securemessaging provider, Bp Premier includes a path for acknowledgement messages.

IfAllow acknowledgements is ticked, the Path for incoming messages field must be unique for each messaging
provider.

Medicare refunds

Saffron SP1 includes enhancements to theMedicare Refund function introduced in Saffron.

A new option 'Part refund to Medicare' is available for selection from the Refund/Adjust Paymentwindow. This
allows for practices to return part of a payment when the practice has been overpaid by Medicare. The payment
remaining for the item is automatically calculated and updated in billing history and payments, services, and trans-
actions reports.

The values forNo. of patients and the In hospital checkbox can now also be changed when refunding a part pay-
ment, to allow for overpayments from Medicare because an incorrect number of patients was sent in the original
claim.
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Cancellation List enhancements

Patients without an existing appointment can now be added to the cancellation list. Select View >Waiting list for
cancellations > Add to cancellation list to add a patient without an existing appointment to the cancellation list.
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Other enhancements

Bp Function Release Notes Key

Immunisations Batch Expiry date has been added as a column in the patient record
immunisations, Immunisations screen, and Send to AIR screen for
additional information about an immunisation record.

60178

MBS items On older versions of Microsoft SQL Server, when trying to save an
MBS item that contained a short MBS description that was too long,
Bp Premier would generate an error: 'The index entry of length n
bytes for the index exceeds the maximum length.

Users on affected SQL Server versions now receive a message
prompting the user to modify the short MBS description to under
1000 characters, or let Bp Premier automatically truncate the
description.

59636

Imaging layouts You can now select from multiple layouts when setting up imaging
preferences in Setup > Preferences > Imaging and Patient record
> Imaging Request > User setup. Previously, you were required to
create a different lab record if a laboratory used multiple layouts.

When editing a layout, the Reload button resets layout values for the
selected layout to their original values.

59736

59745

Check for payments The alert that appears when checking for payments on the same
database from multiple computers now also appears if the same user
is logged into Bp Premier and runs a check for payments on multiple
computers. The alert text has been updated to instruct the user to
finish check for payments on the original machine.

56982

eOrdering Barcodes can now be generated for Imaging eOrder requests. The
barcodes are generated using the site id (MSH-4) and order number
(ORC-4) and the layout location available for configuration if the lab
has been configured for eOrdering.

The barcode will print in the specified location if the layout location
has been configured, otherwise it will not be printed. The barcode
will also be printed if a previous request is reprinted.

8563

eOrdering eOrdering labs can configure a set of 'generic' favourite tests that can
be applied to all doctors through the Bp Premier eOrdering portal.
Doctor-specific favourite lists are still configurable.

13143

eOrdering Order Number / Barcode is now all uppercase when printing imaging
and pathology eOrder requests.

54503

Invoices MBS items 229 and 230 can now be billed on the same invoice. 14638

Electronic Prescribing Prescribers are presented with a Preview screen for approval
automically when sending electronic scripts.

54249
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Bp Function Release Notes Key

Pathology / Radiology Up to five recipients can be can be added to receive copies of the
request from the Copies tab. The copied to contacts will be printed
on the request and also added to the OBR-28 segment of the ORM
generated.

13141

Prescribing The workflow for indicating permitted brand substitution has
changed in Saffron SP1.

When a prescriber selects Print Brand Name on Script, the Allow
brand substitution checkbox is ticked by default. The prescriber
makes the decision to uncheck Allow Brand Substitution, which will
print "Brand Substitution not permitted" on the script.

54243

Cancellation List Further improvements have been made to the new Patients
Awaiting Cancellationswindow:

The Show Expired Cancellation list items checkbox will display
cancellation list entries that have expired (no longer available) if
ticked.
The columns Type, User, Date, and Time have been added to the
display.

53923

IMM.OUT transfers The Imm.OUT data file used by legacy Clinical-only licensed users has
been updated to use the latest Pracsoft format, which includes
additional values.

A new checkbox Include vaccine serial number and Health
Identifiers under Use Pracsoft format for immunisation data
transfer has been added to Setup > Configuration for use by these
practices.

54199

Subpoena tool The subpoena tool now offers PDF as an export option. The user is
notified of any selected content that could not be included in the PDF
output, with an option to copy to clipboard.

12673

Electronic scripts The QR code for electronic script tokens has been resized and
reformatted for better scanning.

49771

Database There is now an option in Setup > Configuration > General to select
the size at which the documents database 'rolls over' and a new
database is created when the size is reached. You can set this
rollover size to 1.8 GB or 9.5 GB.

23398

Electronic scripts When a prescription is sent by electronic token, or a user is created
or edited, Bp Premier now checks that all prerequisites for sending
an escripts have been completed with valid values. If some
prerequisites are missing, Bp Premier will alert the user with the
missing information required.

30078

Pathology / Radiology Up to five recipients can be can be added to receive copies of the
request from the Copies tab. The copied to contacts will be printed
on the request and also added to the OBR-28 segment of the ORM
generated.

13141
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Bug fixes
Bp Function Release Notes Key

Upgrade After upgrading to Saffron SP1, surgical consultation items correctly prompt for a
referral from the Account Details screen.

60513

Check for payments A check for payments on a DVA batch resulted in an Online claiming error. This
has been fixed.

60945

Check for payments Services where the matching service is not present in the Medicare Processing
Report are now marked as unpaid. Previously, some unpaid services were
marked as paid if they did not appear in the processing report.

431

Reminders When opening the Reminderswindow, and some other windows in Bp Premier,
sometimes the user received an 'Application Code Error causing Access
Violation' error. This no longer occurs.

41179

Patients.IN import When importing data from Patients.IN via Bp Service, the UR_NO / ExternalID
field was trimmed during the import process, which could result in duplicate
patient files that needed to be merged. The UR_NO field is no longer trimmed
when imported through Bp Service.

23952

My Health Record If a practice name in Setup > Practice details contained the '&' character, this
caused an error with Event Summary uploads to a patient's My Health Record.
This is now fixed.

49705

Invoicing Surgery consultation items were not prompting for referral details in Account
details screen when the provider had Requires referral for Medicare Billing
ticked. This has been fixed.

54981

Vaccinations The Sequence Number generated for Pneumococcus in the Immunisation
Schedule for Aboriginal and Torres Straight Islander demographics at 12 Months
was incorrect. The Sequence Number is now correct.

57009

Secure Messaging
Acknowledgements

For generating acknowledgements upon import of a message, Bp Premier will
check to match the sending facility in the HL7 message against the sending facility
set up under Results Import > Acknowledgements. If a match is found, Bp
Premier uses the matching path.

Otherwise, when a message is imported, if Allows acknowledgements is checked
and an acknowledgement path is set for that messaging vendor (determined by
the import path), Bp Premier will output an acknowledgement to the specified
path for that messaging vendor.

55490

Past visits In Jade SP2 and later, printing Past Visits by any method excluded Patient Name
and other header information. This has been fixed.

24504

Finalise visit The Finalise visit window no longer errors when searching for MBS item numbers
greater than 100000.

20161

Invoices Paying off a single invoice with two separate cheques no longer generates an
error.

43936
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Bp Function Release Notes Key

Correspondence Out From the patient record, selecting Correspondence out > Add > Send HL7 and
then closing the document prompted to save changes even if the user has made
no changes to the last saved version of the document, potentially creating
duplicate documents. This has been fixed.

51140

Bp Partner Network Upgrading to Saffron now correctly detects all Management Report stored
procedures.

53553

Incoming reports In version Saffron, HL7 reports were not populating the Addressed to field in the
Incoming Reports window. This has been fixed.

54069

Real Time
Prescription
Monitoring

Printing Monitored Drugs from Stored Prescriptions now correctly performs a
Real Time Prescribing Check.

54504

My Health Record Uploads to My Health Record of eRx scripts were failing due to an incorrect
AMT Code System value. This has been fixed.

54531

Database restore Restoring a database from a previous version of Bp Premier to version Saffron
now restores without errors.

54141

Patient Record
Correspondence out

CDA referrals can now be opened successfully from the Correspondence Out list. 54288

eOrdering Duplicate barcodes sometimes appeared on eOrder pathology requests. This has
been fixed.

28145

eOrdering When reprinting an eOrder pathology request from Previous Requests,
sometimes the barcode was missing on the reprinted request. This has been
fixed.

14613

eOrdering Multiple free text tests recorded in a pathology request ORM are now all printed
in the PDF request within the Freehand Tests section, not just the last free text
entry.

44528

Imaging requests The Use again option in the Imaging Request window now populates the new
request with the original details correctly.

42628

Imaging requests Free typed tests in the Other tests field for Imaging Requests were being omitted
from ORM file. This has been fixed.

43466

Active Ingredient
Prescribing

The printed script for Champix Starter pack 0.5 mg x 11; 1 mg x 42 Tablet has
now shows the Strength when AIP is enabled.

50971
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Known issues

Bp Function Issue description Key

Waiting list Practices may be unable to add patients with a future appointment that was
booked before the upgrade to the waiting list for cancelled appointments.

When cancelling an appointment, or accessing the Waiting list for cancellations
screen from an empty slot, the next patient in the cancellation list cannot be
selected because the Select option is greyed out for these patients.

Patients with appointments booked after the upgrade work as expected.

Workaround

Edit the patient's future appointment, untick and retick the Add for waiting list
for cancellation option, and save the appointment. The patient will become
selectable from the Waiting list for cancellations screen.

60454

Email from Word
Processor

When sending to email from the word processor, if two recipients are added, Bp
Premier will place a semicolon between the recipients. If the email is sent, Bp
Premier will alert an 'invalid address' error.

Workaround: for emails from the word processor with multiple recipients,
manually change the semicolon in the recipient list to a comma. The email will
send successfully.

61957

HealthLink In Saffron SP1, Allows acknowledgements is automatically ticked and the option
disabled where HealthLink is added as a messaging provider, because
acknowledgements must be enabled when using HealthLink.

However, if the Healthlink messaging provider has the same paths entered more
than once, Allows acknowledgements is unticked for the HealthLink messaging
provider and cannot be re-enabled without Support assistance.

Best Practice Software Support are working on a resolution to this issue.

61917

eOrdering (SP1) If your practice has configured an eOrder provider through Contacts > Setup > E-
Ordering that uses multiple supplied layouts, only the default supplied layout is
available for selection in Setup > Preferences > Imaging.

60657

eOrdering (SP1) In Preferences > Imaging, when selecting the preferred layout for an imaging lab
that:

has been configured for eOrdering through Contacts > Setup > eOrdering,
and
has a supplied layout

selecting 'Plain paper' will always revert the layout back to the supplied layout.
Custom layouts can be selected successfully.

This issue will be resolved in a future Data Update. In the meantime, Best Practice
Software have provided a script that users who have upgraded to Saffron SP1 can
download and run to resolve this issue. Click here to obtain and run the script.

60657
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Bp Function Issue description Key

Multiple sites and
NASH certificates

If a practice upgrades to Saffon SP1 and sets up multiple HPI-O and NASH
certificates for different locations, Bp Premier will not automatically distribute
the NASH certificate for all locations on startup; only the default NASH certificate
will be updated when Bp Premier is opened.

You can manually update NASH certificates for all locations in Setup
> Configuration on each PC. However, manual update for all locations requires
you to:

have Windows administrator rights
reinstall certificates for each location, for each PC
repeat installation for each Windows user account that uses Bp Premier.

Best Practice Software software recommends that NASH certificates for multiple
locations be distributed through aWindows group policy. Your IT service provider
can assist.

60587
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