
Known issues
As part of our ongoing commitment to provide products and services that add value to our users, the following is a summary of known issues that may occur in supported
versions of Bp Premier, including the version in which the issue was fixed, and workarounds where available.

Issues are grouped by version detected, and where indicated if the issue affects earlier versions also.

Identifying an issue by callstack

Where relevant, the callstack identifier for an issue is included in the issue description below. This is the text that appears near the top of a 'callstack' alert that provides
details about an error. This can be useful searching the known issues list.

Saffron SP3 Rev 1

Bp Function Issue Key

Billing When attempting to send batches that include the DVA Allied Health item numbers KM or OT80, an error occurs. 69028

Copyright Statement
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Saffron SP3

Bp Function Issue Fixed in Key

User categories If a provider's user category is set to either Contract Doctor or Registrar, an error occurs when the provider attempts to create an Event
Summary or Shared Health Summary for My Health Record.

Saffron
SP3 Rev
1

68472

Electronic
Prescribing

When re-prescribing an electronic prescription token from the current Rx screen using Medisecure, an incorrect bar code is added to printed
tokens.

Saffron
SP3 Rev
1

68531

Immunisations Immunisations created in Saffron SP2 or earlier cannot be adjusted and resent in Saffron SP3 or later. Saffron
SP3 Rev
1

68553

Online claiming A limited number of practices are experiencing an issue where Medicare payment reports displayed in the Online Claiming screen are not
reflecting the correct totals or batches.

Not yet
resolved

68845

Online claiming Practices set up in PRODA with multiple minor IDs and a single B2B device are unable to send claims via patient claiming. Saffron
SP3 Rev
1

68785

Online Claiming Patient claims with a $0 payment amount are not appearing in the patient claims list. Saffron
SP3 Rev
1

68796

Medicate Web
Services

Practices set up in PRODA with multiple minor IDs and a single B2B device are failing the active PRODA device check in Bp Premier. Saffron
SP3 Rev
1

68830
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Bp Function Issue Fixed in Key

Tyro The following issues have been identified when performing a check for payments for Tyro bulk bill easyclaims:

Non-bulk bill easyclaim transactions are retrieved.
If reports for unpaid claims are not ready, the correct prompt does not appear.
If no records are retrieved, an error appears.

Not yet
resolved

68874

Billing When creating an invoice with multiple items and the number of patients seen has been added to the invoice, all items include information
about the number of patients, instead of just the items that require the number of patients added.

This can cause the incentive or any additional items that do not require the number of patients number to be specified to be rejected by
Medicare.

Saffron
SP3 Rev
1

68722

Reports When running an online claiming report and the report includes multiple batches with the same batch number, all services with the same
batch number are listed together under the first batch date.

This issue may occur for any reports that group batches by batch number.

Not yet
resolved

68801

Printing When printing PDF documents with excessive margins from Correspondence In, an error occurs. The error also occurs when attempting to
print the document via the subpoena tool or via a patient health summary.

Saffron
SP3 Rev
1

68890

Immunisations Immunisation Information Payments that your Doctors or Nurse Practitioners are expecting from Services Australia may have instead been
issued to your practice, if the immunisations were recorded as given by another practice staff member.

These Information Payments will appear on the immunisation payment statement for your practice’s location, instead of appearing on the
statement for the individual provider.

Not all practices will be affected by this issue. For more details on the issue in the Immunisation screen, review this supporting Knowledge
Base article.

Saffron
SP3 Rev
1

N/A

Immunisations If you open the Influenza Immunisation screen from a patient record using the keyboard shortcut Ctrl+F1, you are unable to save a record
with any item other than the default Influenza vaccination.

Workaround: Change the default influenza vaccination in Setup > Immunisation Batches > Default Influenza Vaccine.

Saffron
SP3 Rev
1

68879

Bp Premier All Known Issues Page 3

https://kb.bpsoftware.net/support/AIRProviderNumber.htm
https://kb.bpsoftware.net/support/AIRProviderNumber.htm


Bp Function Issue Fixed in Key

Prescribing The Regulation 49 check box in the prescribing wizard has reverted back to its previous label, Regulation 24.

When prescribing a medication with repeats, the number of repeats must be altered before the regulation 24 check box can be selected.
Changing the number of repeats should not be required for the Regulation 24 check box to be selected.

Not yet
resolved

68323

Patient Billing
History

In the Patient Billing History, when right-clicking a service and selecting Show Medicare/DVA transmissions, a fatal error occurs if the service
was sent via Tyro.

Saffron
SP3 Rev
1

68371

Patient Claiming When sending a payment via Patient Claiming to Services Australia, users may experience data validation errors.

Workaround: To minimise validation errors, please ensure Patient Demographic data is in the expected format for Services Australia. In most
cases, the returned error message will be descriptive enough to identify the erroneous data needing correction.

Not yet
resolved

68276

Upgrading When upgrading to Saffron SP3, update databases does not complete successfully.

Workaround: Run the Update Database.exe utility in C:\Program Files\Best Practice Software\BPS by right-clicking on the file and selecting
'Run as administrator'.

Saffron
SP3 Rev
1

68312

Patient Claiming When sending a payment via Patient Claiming to Services Australia, if the invoice contains MBS and non-MBS items it will fail to lodge.

Workaround: Users will need to process MBS items separately via Patient Claiming.

Saffron
SP3 Rev
1

68282

Electronic
Prescribing

Medications that include a ‘<’ character in their strength field cannot be sent via ePrescribing for Practices using eRx.

Workaround: This is currently being investigated.

Saffron
SP3 Rev
1

68100

Immunisations Practices that do not have a HPI-O entered receive an error message when attempting to upload immunisations to AIR, or use AIR
functionality.

Best Practice Software suggest entering a practice HPI-O to ensure immunisation data can be transmitted to AIR. Visit the Services Australia
Website for information on how to apply for a HPI-O.

Workaround: This is currently being investigated for practices that do not have a HPI-O.

Saffron
SP3 Rev
1

68273
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Bp Function Issue Fixed in Key

Patient Claiming When sending an invoice that requires a referral via patient claiming, if the contact included in the referral has a 7 character provider number,
an error will appear indicating that the provider number is invalid.

Workaround: Add a '0' (zero) to the start of the provider number in Setup > Users.

Saffron
SP3 Rev
1

68184

Prescribing When printing a patient drug sheet or patient health summary, if a prescription includes complex instructions, then the complex instructions
will show twice.

Not yet
resolved

68141

AIR If the patient has a special risk group alert recorded in the AIR, updating the patient's indigenous status will remove the special risk group
Alert.

NOTE This is an issue with AIR, not Bp Premier.

Not yet
resolved

N/A
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Saffron SP2 Rev 1

Issue Release notes Fixed in Key

Email When setting up outgoing email via Setup > Configuration > Email, if TLS encryption is disabled, a port cannot be set.

Workaround:

1. When setting up outgoing email via Setup > Configuration > Email, tick Enable TLS encryption for Outgoing mail.
2. In the Outgoing mail (STMP Server): section, click Add or Edit. The Setup outgoing mail server screen will appear.
3. Specify the port you wish to use or keep the default port. If you are adding a new email, complete the rest of the fields on the screen and click

Save.

Ignore the message that the SMTP test connection has failed

4. Untick Enable TLS encryption for Outgoing mail.

Not yet
resolved.

67166

Health
Summaries

When creating a Health Summary in the patient record via File > Print Health Summary, the inactive past history section in the Health Summary
incorrectly lists the patient's active past history instead.

Workaround: When creating a Patient Health Summary, select View. The Word processor will appear. Use the Past History List (Inactive) autofill
key under Clinical to manually populate the correct Inactive History information.

Saffron
SP3

Incentive
items

In Saffron SP2 or later, If the MM Location selector in Location Details is set to any value other than ‘MM1’ and ‘MM2’, the MM location incentive
item is not applied correctly to bulk bill invoices. The old incentive items 10990 or 10991 are still being applied.

Workaround: No current workaround. The correct incentive item can be added manually, but the incorrect incentive item cannot be removed.

Best Practice Software are working on an update to the January Data Update and will communicate to practices as soon as available.

Saffron
SP3

67545
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Saffron SP2

Issue Release Notes Fixed in Key

Prescribing (MediSecure) Prescribing Estalis Sequi via Medisecure omits the second active ingredient (Norethisterone) from the ETP message.

Workaround

When prescribing, tick Include Brand Name. This includes brand but does also include both active ingredients correctly.

This issue will be fixed in Saffron Service Pack 3.

Saffron SP3 67345

Payment details screen Ticking Pay Gap does not populate the payment method fields, or the Gap: or Payment total: fields in the Payment details
screen with the gap amount.

Saffron SP2 Rev1 66703

Online patient verification When performing an online patient verification from the appointment book by right-clicking on an appointment and
selecting Online patient verification, clicking OK on the prompt causes the appointment book window to minimise.

Saffron SP3 65575

Patient record Longer phone numbers and ethnicity information is cut off early in the demographic information at the top of the patient
record.

Saffron SP2 Rev1 66645

Prescribing An error occurs when clicking the Drug Combination button in the Current Rx wizard. Saffron SP2 Rev1 66822

Subpoena tool A fatal error occurs when exporting the following data in the subpoena tool:

Prescriptions
Past History
Current RX
Immunisations
Requests
Visit Notes
Actions.

Saffron SP2 Rev1 66814
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Issue Release Notes Fixed in Key

Subpoena tool If the following workflow is used in the Subpoena tool, the exported subpoena file will include all content preceding the
date range, regardless of the date range selected:

1. In the Subpoena tool, select a date range.
2. Click Select on the item filter.
3. Click Deselect all.
4. Click Insert.
5. Click Export.

Workaround: Use either of the following workflows when using the Subpoena tool instead.

1. In the Subpoena tool, select a date range.
2. Untick items you do not wish to include in the output.
3. Click Export.

1. In the Subpoena tool, select a date range.
2. Click Select on the item filter.
3. Individually deselect any items you do not wish to include in the output.
4. Click Insert to add the remaining items to the output.
5. Click Export.

Saffron SP2 Rev1 67127
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Saffron SP1

Issue Release Notes Fixed in Key

Contact export Contacts exported from Jade SP3, Jade SP4, Saffron or Saffron SP1 cannot be imported back into any version of Bp Premier. Saffron SP2 64598

Electronic Prescribing When represcribing an ePrescription token from Current Rx with Medisecure, Bp Premier will print the previous
ePrescription bar code on paper tokens instead of the new bar code that is generated and sent to MediSecure.

Not yet resolved. 64676

Email from Word Processor When sending to email from the word processor, if two recipients are added, Bp Premier will place a semicolon between
the recipients. If the email is sent, Bp Premier will alert an 'invalid address' error.

Workaround: for emails from the word processor with multiple recipients, manually change the semicolon in the recipient
list to a comma. The email will send successfully.

Saffron SP2 61957

eOrdering (SP1) If your practice has configured an eOrder provider through Contacts > Setup > eOrdering that uses multiple supplied
layouts, only the default supplied layout is available for selection in Setup > Preferences > Imaging.

Saffron SP2 60657

eOrdering (SP1) In Preferences > Imaging, when selecting the preferred layout for an imaging lab that:

has been configured for eOrdering through Contacts > Setup > eOrdering, and
has a supplied layout

selecting 'Plain paper' will always revert the layout back to the supplied layout. Custom layouts can be selected successfully.

This issue will be resolved in a future Data Update. In the meantime, Best Practice Software have provided a script that
users who have upgraded to Saffron SP1 can download and run to resolve this issue. Click here to obtain and run the script.

Saffron SP3 60657
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Issue Release Notes Fixed in Key

Waiting list Practices may be unable to add patients with a future appointment that was booked before the upgrade to the waiting list
for cancelled appointments.

When cancelling an appointment, or accessing theWaiting list for cancellations screen from an empty slot, the next
patient in the cancellation list cannot be selected because the Select option is greyed out for these patients.

Patients with appointments booked after the upgrade work as expected.

Workaround

Edit the patient's future appointment, untick and retick the Add for waiting list for cancellation option, and save the
appointment. The patient will become selectable from theWaiting list for cancellations screen.

Not yet resolved. 60454

Multiple sites and NASH
certificates

If a practice upgrades to Saffon SP1 and sets up multiple HPI-O and NASH certificates for different locations, Bp Premier will
not automatically distribute the NASH certificate for all locations on startup; only the default NASH certificate will be
updated when Bp Premier is opened.

You can manually update NASH certificates for all locations in Setup > Configuration on each PC. However, manual update
for all locations requires you to:

have Windows administrator rights
reinstall certificates for each location, for each PC
repeat installation for each Windows user account that uses Bp Premier.

Best Practice Software software recommends that NASH certificates for multiple locations be distributed through a
Windows group policy. Your IT service provider can assist. Information is also available on the Microsoft technical
knowledge base.

Saffron SP2 60587
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Saffron

Issue Release Notes Fixed in Key

MEDRefer Unhandled exception error presented when signing in or signing out of the MEDrefer in the Bp Word Processor address
book and action does not take effect. Sign in or sign out performed will take effect upon restarting Bp.

Saffron SP1. --

Scheduled Reminders After upgrading to Saffron, some users experienced SMS messages not being sent from Bp Premier for scheduled SMS
appointment reminders.

Saffron SP1. 54257

Debtor list Debtor list did not show name of contact where accounts were billed against a contact with no first name. Saffron SP1. 54259

Scheduled reminders The options Exclude appointments that already have a reminder sent and Exclude appointments made within the last
X days in Setup > Configuration were reversed when the Utilities > Send Appointment Reminders function was opened.

Saffron SP1. 48314

Reminders The Added by and Added on values for a patient's reminders now show the original date that the reminder was created
and the user who created the reminder, not the user logged in when the reminder was sent.

Saffron SP1. 43938

Scheduled reminders The options Exclude appointments that already have a reminder sent and Exclude appointments made within the last
X days for Scheduled Reminder setup in Setup > Configuration > Bp Service > Configure Appointment Reminders now
inherit by default from the values in Setup > Configuration > Reminders, but can be edited in the scheduled reminder
setup.

Saffron SP1. 57062

My Health Record Uploads to My Health Record of eRx scripts were failing due to an incorrect AMT Code System value. This has been
fixed.

Saffron SP1. 54531

eOrdering When reprinting an eOrder pathology request from Previous Requests, sometimes the barcode was missing on the
reprinted request.

Saffron SP1. 14613

eOrdering Duplicate barcodes sometimes appeared on eOrder pathology requests. Saffron SP1. 28145

Database restore Restoring a database from a previous version of Bp Premier causes missing functions and Stored Proceduress. Saffron SP1. 54141
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Issue Release Notes Fixed in Key

Real Time Prescription
Monitoring

Printing Monitored Drugs from Stored Prescriptions did not perform a Real Time Prescribing Check. Saffron SP1. 54504

Incoming reports HL7 reports were not populating the Addressed to field in the Incoming Reports window. Saffron SP1. 54069

Bp Partner Network Upgrading to Saffron detected Management Report stored procedures as missing. Saffron SP1. 53553

Invoices Paying off a single invoice with two separate cheques no longer generates an error.

Callstack indicators:

PAYMENTWINDOW:SAVEPAYMENT Line: 337

PAYMENTWINDOW:SAVEPAYMENT Line: 339

Saffron SP1. 43936

Finalise visit The Finalise visit window no longer errors when searching for MBS item numbers greater than 100000.

Callstack indicator:

CSERVICE:LOADMBSDETAILSFROMLIST Line: 33

Saffron SP1. 20161

Past visits In Jade SP2 and later, printing Past Visits by any method excluded Patient Name and other header information. This has
been fixed.

Saffron SP1. 24504

Secure Messaging
Acknowledgements

For generating acknowledgements upon import of a message, Bp Premier will check to match the sending facility in the
HL7 message against the sending facility set up under Results Import > Acknowledgements. If a match is found, Bp
Premier uses the matching path.

Otherwise, when a message is imported, if Allows acknowledgements is checked and an acknowledgement path is set
for that messaging vendor (determined by the import path), Bp Premier will output an acknowledgement to the
specified path for that messaging vendor.

Also review acknowledgement path updates in the Bp Premier Saffron SP1 release notes.

Saffron SP1. 54453

55490
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Issue Release Notes Fixed in Key

Vaccinations The Sequence Number generated for Pneumococcus in the Immunisation Schedule for Aboriginal and Torres Straight
Islander demographics at 12 Months was incorrect. The Sequence Number is now correct.

Saffron SP1. 57009

Invoicing Surgery consultation items were not prompting for referral details in Account details screen when the provider had
Requires referral for Medicare Billing ticked.

Saffron SP1. 54981

My Health Record If a practice name in Setup > Practice details contained the '&' character, this caused an error with Event Summary
uploads to a patient's My Health Record. This issue also occurred in version Jade SP4.

Saffron SP1. 49705

Patients.IN import When importing data from Patients.IN via Bp Service, the UR_NO / ExternalID field was trimmed during the import
process, which could result in duplicate patient files that needed to be merged.

Saffron SP1. 23952

Reminders When opening the Reminders window, and some other windows in Bp Premier, sometimes the user received an
'Application Code Error causing Access Violation' error. This no longer occurs.

Callstack indicator:

CMENU:_GETMENUITEMEXTRA Line: 23

Saffron SP1. 41179
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Issue Release Notes Fixed in Key

CDA referrals Opening a CDA Referral from the Correspondence Out panel in the patient record, by double-clicking or right-clicking
and selecting View, causes a fatal error in Bp Premier. The user will be prompted to close Bp Premier if this error is
generated.

Callstack indicator:

CDAVIEWER:DOCUMENT:ASSIGN Line: 12

Workaround: Best Practice Software recommend viewing sent CDA referrals by either:

Clicking the document in the patient tree, which will display the ereferral contents correctly in the right-side panel.
Right-clicking the document in the Correspondence Out panel and selectingMove to Correspondence In. This will
temporarily move the item to the Correspondence In section. Sent CDA referrals can be moved back after Best
Practice Software has resolved this issue.

Saffron SP1. 54288

Scheduled
SMS appointment
reminders

After upgrading to Saffron, some users have experienced SMS messages are not being sent from Bp Premier for
scheduled SMS appointment reminders.

Workaround: Best Practice Software recommend that you confirm SMS messages are being sent from a reminder
schedule after upgrading to version Saffron. If not, you will have to manually send appointment reminders by SMS using
the single message function.

Best Practice Software are working on resolving this issue.

Saffron SP1. 54101

Configuration An option Enable Service Registration Assistant for management of users and locations is visible in Setup >
Configuration. This function is not yet available and should not be enabled at your practice. The option will be disabled
in a future update of Bp Premier.

Saffron SP1. --

Upgrading and
Installation

The links to release materials in the Bp Premier Saffron Install and Upgrade Wizards point to old versions of Bp Premier.

For information on What's New, Best Practice Software recommend selecting Help > Online within Bp Premier after
upgrading and viewing What's New, or the new feature links from the knowledge base home page.

Saffron SP1. --
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Issue Release Notes Fixed in Key

Electronic prescribing If the total length of qualifications recorded in the provider details is over 50 characters, the user will be alerted that
the qualifications list sent with the token is too long. The script will still be printed.

Best Practice Software software recommend that the qualifications list for users who receive this message truncate
their qualifications to under fifty characters.

This is a limitation imposed by the electronic script token format and not Bp Premier.

Saffron SP1. 41072

Referrals From the patient record, selecting Correspondence out > Add > Send HL7 and then closing the document will prompt to
save changes even if the user has made no changes to the last saved version of the document.

If this prompt appears, and you are sure that you have made no changes since the last time you saved this document,
you can click No to this prompt.

Behaviour is otherwise as expected.

Saffron SP1. 51140

Prescribing Strength is not printed for Champix Starter pack, Varenicline Starter pack and Arava Combination Pack when Active
Ingredient Prescribing is enabled.

January 2021 DU. 50971

Prescribing Best Practice Software has identified an issue when prescribing Venlafaxine with the dosage of 37.5mg capsules, which
then prints as Venlafaxine 75mg.

This has been resolved in the January 2021 Data Update. Best Practice Software recommend running this data update
to resolve this issue.

January 2021 DU. --
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Issue Release Notes Fixed in Key

Secure messaging Not all clinical systems are able to receive PDF payloads. In this case, a Formatted Text segment can also be included
which can be received as an alternative. However, some secure messaging providers will not transmit a secure message
containing a PDF if the recipient cannot accept this. If a secure message cannot be delivered due to PDF content, the
secure messaging software may trigger an alert or error message advising the user that the file cannot be sent.

Workaround: If you send a secure message and receive an alert advising that it cannot be sent because the receiver
does not support the payload type (PDF), Best Practice Software recommend ticking the Include a formatted text OBX
in REF checkbox in Setup > Configuration >Messaging > Edit messaging provider.

If the message still cannot be sent by secure messaging with this option ticked, Best Practice Software recommend
requesting the intended recipient of the secure message contact the Argus Telstra Health Help desk (1800 952 282) so
that their mail rules configuration can be updated to receive this payload.

Dependent on secure
messaging system.
Nothing to resolve.

--

Secure messaging After upgrading to Saffron, a new field Allows acknowledgements in Setup > Configuration > Messaging > Add is ticked
by default for existing providers.

Best Practice Software recommend you confirm that your messaging provider's software accepts acknowledgements if
you leave this option ticked. If you are unsure or your messaging provider does not yet support accepting
acknowledgements, untick this option for all providers after upgrading to Saffron.

Dependent on secure
messaging system.
Nothing to resolve.

--

Custom preparations Deleting an ingredient from a custom preparation deletes that ingredient permanently regardless of whether the
preparation is saved. Also occurs in Jade.

Not yet resolved. 41216

Appointment book
preferences

When increasing the default appointment length in Setup > Configuration > Appointments, the prompt to ask users
whether changes should apply to current session settings only appears when reducing the default length.

Not yet resolved. 55324
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Issue Release Notes Fixed in Key

Referral Bp Premier errors when exporting to HL7 a specialist referral letter containing a custom preparation that has a strength
of more than 10 concurrent numbers.

Callstack indicator:

GETNUMERICPART Line: 25

Not yet resolved. 54897

Pathology When creating a new pathology request, if you go to Previous requests and select Use again, the Billing type from the
previous request updates the Default billing in the logged-in user's pathology preferences (Setup > Preferences).

This issue affects all supported versions of Bp Premier.

Saffron SP3 55097

Password security If a password is set beginning with the digits '8' or '9', the following utilities generate an 'incorrect password' error on
attempted login: BPCertificateManager and BPS_ImportExportUtility.

Not yet resolved. 54143

Electronic prescribing Ceased eScripts are unable to be cancelled or deleted from Past Prescriptions. Also occurs in Jade SP3. Saffron SP2 44439

Last updated 17 May 2022

Bp Premier All Known Issues Page 17



Known issues for older versions
The known issues for older sunset versions of Bp Premier are listed below. Some issues have been resolved through subsequent Program Updates.

See End of support (sunset) for older versions on page 52 for more information.
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Jade SP3

Issue Release Notes Fixed in

Imaging requests Free typed tests in the Other tests field for Imaging Requests were being omitted from ORM file. This has been fixed. Saffron 40943

Imaging requests The Use again option in the Imaging Request window now populates the new request with the original details correctly. Saffron 42628

eOrdering Multiple free text tests recorded in a pathology request ORM are now all printed in the PDF request within the
Freehand Tests section, not just the last free text entry.

Saffron SP1 44528

Incoming results Results including some PDFs will not display correctly in Bp Premier. When opening these files in Bp Premier, a blank
document will be displayed.

As a workaround, the PDF file can be opened outside of Bp Premier in Adobe Acrobat and will display correctly.

Saffron SP2 27340

Merging records Patient records can be merged while open, which can cause issues with the record data. Not yet resolved. 27310

Jade SP2

Issue Release Notes Fixed in Key

Pathology Request The Requested tests and Clinical details fields can be truncated on the request printout if you type in a large amount of
text and then select items from the picklist.

Not yet resolved. BP-
2429
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Jade SP1

Issue Release Notes Fixed in Key

Pathology/Imaging
Requests

Adding multiple contacts in the Copies tab duplicates the first contact on every subsequent contact. Not yet resolved. BP-
2131

Contact Note List Tab order of controls is incorrect. Not yet resolved. BP-
2110

Contact Notes -
Remote download
mode

Resending messages from the contact notes list when in remote download mode causes a fatal error. Not yet resolved. BP-
2117

Contact Notes -
Remote download
mode

Contact notes list is not in date order in remote download mode. Not yet resolved. BP-
2118

Bp Comms Status Bp Comms status in the patient's demographics is incorrect in remote download mode. Not yet resolved. BP-
2119

Jade

Bp Function Release Notes Fixed In Key

Clinical record
Investigations

In Indigo, Jade, and Jade SP1, when using the Next and Previous buttons to move through reports in the Investigations
viewer, the page header for the investigation is not displayed correctly.

Saffron SP2 BP-
2280
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Bp Function Release Notes Fixed In Key

Appointment Book
Elsewhere locations

Bookings at 'Elsewhere' locations are not being hidden in the appointment book when a specific layout is selected. Jade SP3 BP-
1828

Check for Payments In Jade and Indigo SP1, if a Check for payments is run simultaneously, Bp Premier will report a lock on Check for
Payments elsewhere in the practice. However, the Check for Payments button remains enabled. The button should be
disabled until the function lock is released.

Jade SP1 BP-
1890

ADF Discharge Summary In Jade and Indigo SP2, printing an ADF Discharge Summary can take up to a minute to finalise. Not yet resolved. BP-
1877

Appointment Book In Jade and Indigo SP1, if the default appointment length is less than the session length and you choose to make
multiple slots unavailable through the appointment book right-click menu, Bp Premier creates multiple unavailable
records in the database. This does not affect users, but may affect third parties that integrate with the database.

Not yet resolved. BP-
1882

Best Health App Messages with a null body sent to app are still being transmitted. Not yet resolved. BP-
1895

Best Health App If the Onboarding window in Bp Premier Configuration cannot authenticate with Amazon Web Services, the window will
still load and display practice locations for onboarding after errors are displayed.

Not yet resolved. BP-
1780

BMI tool Patient risk text remains displayed in the BMI tool if invalid data is entered. Not yet resolved. BP-
1825

Bp Comms Cancelling from the demographics window after enrolling a patient for Best Health App leaves the patient enrolled for
Best Health App.

Not yet resolved. BP-
1787

Bp Comms Fact sheets can still be sent to app when Best Health App is disabled. Not yet resolved. BP-
1751

Bp Comms Message
Queue

If the Message Queuing service is stopped and the Best Practice Messaging Service is started, the MessageQueue log
incorrectly reports the Message Queue service as not installed.

Not yet resolved. BP-
1906
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Bp Function Release Notes Fixed In Key

Bp Comms Message
Queue

The error message shown when attempting to send a message to patient app does not distinguish between the
Message Queue service not started or not installed.

Not yet resolved. BP-
1902

Bp Comms Messaging
Service

If the Best Practice Messaging Service is not available, and a user attempts to send a message from the appointment
book and selects No to the service unavailable alert, an error is shown and the window does not close.

Not yet resolved. BP-
1905

Bulk Document Import Pressing F5 no longer refreshes the window. You must use the menu item Refresh. Not yet resolved. BP-
1773

Complex accounts In Jade and Indigo SP2, the Add Another function on the Complex Account window does not work as expected for
MBS items.

Not yet resolved. BP-
1891

EPC Care Plan If you add a custom field to the GP Management Plan template inn Jade or Indigo SP2, the custom field prompt will
appear twice when the care plan is previewed or printed.

Not yet resolved. BP-
1907

Immunisations When editing an existing immunisation, if the patient's vaccine name did not exactly match the vaccine name in the
drug database, the Available Vaccines list would default to the top entry 'ACTHiB' and this would change the vaccine if
the edited record was saved. This issue was previously fixed for upper and lower case differences.

Not yet resolved. BP-
1796

Online help Clicking F1 in the Provider Inbox does not always open the Bp Premier online help in the default browser. Not yet resolved. BP-
1822

Patient Notifications In Jade and Indigo SP1, the Open Visit option in the Notifications section right-click menu does not work for reminders. Not yet resolved. BP-
1653

QLD WorkCover In Jade, Indigo, and Indigo Rev 1, if the certificate DigiCert High Assurance CA.cer has been installed multiple times,
QLD WorkCover invoicing can produce an error.

A workaround is to open certificate manager, Action > Find Certificates, search by serial number, and remove duplicate
certificates.

Not yet resolved. BP-
1172

Today's notes In Jade and Indigo SP1, FEV1/FVC values are duplicated in Today's notes when resaving respiratory function values that
have not changed.

Not yet resolved. BP-
1790
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Indigo and service packs

Issue Workaround Fixed in Key

Indigo SP1 and SP2

Duplicate payment
records can occur if two
users run Check for
Payment at same time.

When running the
Services - By Account
Type (Grouped by item)
report and similar reports,
a 'Subquery returned
more than 1 value' error
may be returned. This
error may be caused by
performing multiple
service adjustments
within Online claiming.

This issue may also
appear in Indigo and
Indigo Service Packs.

Please contact Best Practice Software Support for advice if you experience this issue. Jade BP-
1294
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Issue Workaround Fixed in Key

From the Follow up
Reminders screen,
selecting a reminder and
clicking Contact Notes will
only show those Contact
Notes specifically related
to that sent single
reminder record, not all
contact notes associated
with the history of the
reminder.

No known workaround. Jade SP1 BP-
1004

The appointment book
will not automatically
refresh and must be
manually opened and
closed to refresh.

This issue occurs if the
operating system time on
a Bp Premier client differs
by more than a few
seconds from the time on
the Bp Premier server.

Resynchronise the time on the client machine to be exactly the same as the time on the Bp Premier server.

Close and re-open the appointment book to refresh.

Jade BP-
1585
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Issue Workaround Fixed in Key

When using a workstation
with a database that has
been remotely
downloaded, an 'Invalid
Object Name' error occurs
when printing
prescriptions. The
prescription can be
printed, but SafeScript
checks will not occur.

No known workaround. Jade BP-
1563

Users are omitted from a
Shared Health Summary
report if their User ID
does not exist in the
Invoices table (that is, the
user has never been
associated with an
invoice).

Applies to practices that
are running version Indigo
and have run the February
2019 Data Update.

Create and cancel and invoice for any omitted users so that they are recorded in the Invoices table.

Install the March 2019 Data Update to install the corrected version of this report.

March 2019 Data Update. BP-
1584

When adding batches to
the Banking window,
some sites may
experience long waits to
load available batches.

Contact Best Practice Software Support for a script to resolve the issue. Indigo SP1 BP-
1478
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Issue Workaround Fixed in Key

During an upgrade to
Indigo Service Pack 1,
Update Databases may
fail due to an error if the
Windows user running the
upgrade does not have
local permission to access
the directory
C:\ProgramData\Best
Practice\Log.

This can affect the
transfer of your SMS
credit balance.

You will need to manually rerun Update Databases after the upgrade. This can take up to two or more hours,
depending on the size of your database, and is best run after hours.

Until you have performed the resolution steps below, SMS usage at your practice will be limited as follows:

The use of SMS within the practice and all locations will cease to work, and all SMS schedules configured to run
will not proceed.
The practice would need to fail back to manually calling all patients with appointments for subsequent days to
confirm patient attendance, and reschedule those patients waiting for an available appointment.
The practice will not have the ability to send out ad hoc SMS notifications, such as a doctor running late.

Perform the following steps after normal business hours: 

1. Back up the Bp Premier database.
2. Double-click the file C:\Program Files\Best Practice Software\BPS\Update Database.exe.
3. Log back in to Bp Premier and check the vale of your SMS credit . The value from before the upgrade should be

transferred.

If you have further concerns if your site experienced this error, and you have rerun Update Databases after hours,
export BP log files and send the log zip file to Bp Premier Support.

This issue is caused by
local permissions.

BP-
1577
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Issue Workaround Fixed in Key

When enrolling a patient's
phone number, Bp
Premier checks to see if
any other patients have
the same mobile phone
number recorded.

However, this check will
not report a duplicate
number if the same
phone number has been
recorded with spaces.

For example, if a number
has been recorded as
'0404040404' for one
patient and '0404 040
404' for another, Bp
Premier will not detect
the duplicate.

This issue may also
appear if you have
upgraded to the Jade
version.

Ensure that your staff record phone numbers with consistent formatting when entering patient details. Jade SP1 BP-
1672
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Issue Workaround Fixed in Key

When submitting
vaccination records to AIR
electronically, if a patient
has incorrectly entered
demographic information
(for example, their suburb
and postcode do not
match), selecting Send to
AIR will cause an error
message.

The error message
indicates that the last
patient listed has
incorrect demographic
information. However,
any patient listed may
actually have incorrect
details.

1. Narrow down the list of patients by changing the filters Immunisations given since and Filter by doctor.
2. Click Send to AIR.
3. Repeat steps 1 and 2 until you have a small list of vaccines that will not send.
4. check the demographic information of each patient in the list and ensure that the following fields have been

recorded correctly:
Address (to include residential address information)
City/Suburb (to include just city or suburb information, for example 'Bundaberg', not 'Bundaberg QLD'
Postcode (ensure the postcode recorded has four digits and matches the city or suburb).

Once the patient is identified and their demographic information is amended, the rest of the vaccines will send
correctly.

Not yet resolved. BP-2628

When importing an
MDM HL7 message, Bp
Premier uses the
CDA Intended Recipient
component to address the
result, rather than the
MSH component of the
MDM.

No known workaround. Not yet resolved. BP-
2019

Page 28 Bp Premier All Known Issues



Issue Workaround Fixed in Key

If a practice has any
SMS appointment
reminder schedules
existing, the option Use
Bp Service for sending
automated appointment
reminders in Setup
> Configuration > Bp
Service has no effect. SMS
appointment reminders
will still send at the
scheduled time even if
this option is not ticked.

This known issue also
exists in Jade and Jade
SP1.

If your practice does not intend to send SMS appointment reminders by schedule, delete all SMS schedules defined
in Bp Premier, and then untick the option Use Bp Service for sending automated appointment reminders.

Not yet resolved. BP-
2182
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Issue Workaround Fixed in Key

Adjusting an invoice after
a failed Bulk Bill Easyclaim
transaction does not
update the services on
the invoice correctly. This
issue most commonly
occurs when the Tyro
transaction fails because
the patient’s Medicare
card details have not been
updated.

This issue may also be
experienced for sites
running Indigo and Indigo
Revision 1.

If you experience this issue, call Bp Premier Support for assistance in correcting Bulk Bill Easyclaims that have
required invoice adjustments.

Not yet resolved. BP-
1487
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Issue Workaround Fixed in Key

If a non-RTF format result
file has been saved to a
patient file under
Investigations, and a
workstation downloads
the database remotely to
operate in remote mode,
the result file will no
longer be viewable

If while in remote
database mode the result
file is moved to
Correspondence In, and
the remote database
session is synchronised
back to the server, the
result file is replaced by
the blank file and is no
longer readable.

This also can also occur
for sites running Indigo
Revision 1.

If a blank result appears in Investigations while in Remote Database mode, do notmove this file to Correspondence
IN.

Not yet resolved. BP-
1593
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Issue Workaround Fixed in Key

Marking an item in the
Correspondence In
section of the patient
record as 'Given' can
cause slowness if the
patient has a large
number of documents in
Correspondence In.

This issue also occurs for
version Indigo.

No known workaround. Not yet resolved BP-
1261

The HealthLink online
directory does not refresh
existing search results
when a name is cleared
from the Name search
field.

Clear the postcode value and re-enter it to regenerate search results. Not yet resolved BP-
1118

A 'numeric overflow' error
may appear that is
generated by Bp Premier's
system logging.

If this error occurs more than once, restart Bp Premier on the computer that experienced the error. Not yet resolved BP-
1200

The Backup database
button on the BPS Backup
utility may be disabled
when running a manual
backup.

Set the registry key HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Best Practice Software\Best
Practice\Database > Server to 'local' and reattempt the manual backup. Your IT support can assist with updating the
registry.

You may need to change the registry value back to its original setting.

Not yet resolved BP-
1336
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Issue Workaround Fixed in Key

The default location for a
manual backup (normally
the last manual backup
location) is reset if an
automatic scheduled
backup is set up or run.

Manually change the default location to the desired location when performing a manual backup. Not yet resolved BP-
1341

When you right-click a
batch and select Get
processing report, the
Online claim processing
report does not list the
surname of the patient for
DVA claims.

Save the report, double-click the batch, and review all of the rejections with the patients' first name and surname. If
a practice is only interested in viewing the data, you can print the report or go to View > Processing reports.

Not yet resolved BP-
1116

When creating a Bp
Comms SMS template
with autopopulate fields
that do not apply to the
selected template type,
an unrecoverable error
can occur.

Do not manually insert or cut and paste fields between different SMS template types. Only ever insert autopopulate
fields by selecting from the list of available fields in the Edit Bp Comms Template window.

Not yet resolved. BP-
1550

When searching the
HealthLink online
directory for contacts, the
Maximum Distance
search field is not
consistently enabled
when a postcode is
entered.

No known workaround. Not yet resolved BP-
1121
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Issue Workaround Fixed in Key

If a contact category has
multiple specialist codes
mapped, when searching
for the category plus
either a name or
postcode, the results
returned include
providers that do not
belong to the category
selected.

No known workaround. Not yet resolved BP-
1122

Indigo Revision 1

HealthLink Forms — An
error occurs when
opening a form if the
patient has an
investigation result that
has a null value for the
report header and report
body.

Email Best Practice Software Support to resolve if this issue occurs. Not yet resolved. BP-988

HealthLink Forms — An
error occurs during
prepopulation when a
clinical image does not
exist in the document
database.

Identify which clinical image does not open correctly. Contact the original sender of the clinical image for the image
to be resent. Delete the original bad image.

Not yet resolved. BP-977

Indigo

Page 34 Bp Premier All Known Issues

mailto:support@bpsoftware.net?subject=HealthLink Forms - investigation result has NULL report header and body


Issue Workaround Fixed in Key

When adding or editing
Carer details within the
Care Plan window,
the Delete button is only
enabled if the patient has
a Next of Kin set. When
attempting to delete the
details, an incorrect
prompt appears.

Set a Next of Kin in the patient's demographics. Jade BP-192

HealthLink forms — error
resuming all parked
forms.

The workaround for this known issue is to not park a form. Jade BP-775

HealthLink — the
description returned in
the Patient_PastHistory_
Description and Patient_
Problem_Description
concepts does not have
the complete condition
details. The description is
missing the side, acute,
severity, provisional and
fracture details.

No workaround is available yet. Jade BP-886
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Issue Workaround Fixed in Key

Medicare certificates in
the MedicareCerts folder
are not imported when
BPCertificateManager.exe
is run from inside Bp
Premier.

Run BPCertificateManager.exe as a Windows administrator from the /BPSupport folder on the affected computers
and click Reinstall Certificates.

Indigo SP1 BP-96

Phone options have been
removed when trying to
create a manual query in
the Database search
utility.

After you have created your query using the Setup search buttons, manually edit the text in the SQL Query box to
add the phone number fields and values to search on. You can search for 'HomePhone', 'WorkPhone', or
'MobilePhone'.

Indigo SP1 BP-782

In the Word Processor,
inserting an AutoFill drops
the cursor to a new line
automatically when the
user presses the space bar
and not the Enter key.

Manually reposition the cursor on the same line after inserting. Indigo SP1 BP-797

HealthShare actions are
not automatically
recorded in Today’s notes.

Manually record details in Today’s Notes when fact sheets have been given to the patient. Indigo SP1 BP-706

The content for the ADF
Post Discharge Summary
is not generated until the
user clicks
the Preview button or
finalises the EPC item.

Click the Preview button or Finalise the EPC item before saving and closing the window. Indigo SP1 BP-703
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Issue Workaround Fixed in Key

Immunisation data is not
being correctly output to
a linked IMM.OUT file,
including provider name,
provider number, and
sequence number.
Duplicate vaccinations can
be generated when
output to IMM.OUT. 6
month Rotavirus
(sequence 3) vaccination
remains checked after it is
deleted.

No workaround is available yet. Indigo SP1 BP-772

The following error is
logged at times when
printing scripts using eRx:
'The description for Event
ID 0 from source eRx
Standard Adapter Service
cannot be found'.

No workaround is available for Indigo. Indigo SP1 BP-779

An error occurs when
saving an immunisation
when the user has No
Access or View only
permissions to clinical
notes. The immunisation
is not added due to this
error.

Increase the user's permissions to allow access to clinical notes to save the immunisation. Jade BP-181
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Issue Workaround Fixed in Key

Appointment Book — No
prompt apears when
moving an appointment
which may run in to an On
the day appointment.

Cut and paste the appointment you want to move into the correct appointment location. Indigo SP1 DEV-
8938

Error populating data for
HealthLink Smart forms.

Open the patient's demographics and resave. Jade SP1 BP-947

You can no longer adjust
the accept fee when
adjusting a service from
the Bulk Payment screen.
This action was possible in
previous versions of Bp
Premier.

No workaround is available yet. Jade SP1 BP-854

The Best Practice Help
Library is outdated.

Select Help > Online to open the online Knowledge Base for Bp Premier. Jade DEV-
9114

Microsoft updates force a
reboot when installing
.NET features during
Indigo installation; If IT
have scheduled anything
else during server
downtime, IT cannot do
this until Bp Premier
upgrade or installation is
complete.

No workaround is available yet. No longer applicable. BP-709
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Issue Workaround Fixed in Key

Online Claiming — Not
duplicate service indicator
missing when multiple
services are marked NDS.

Send services on separate invoices and select appropriate indicators. Not yet resolved. BP-99

If a custom preparation is
prescribed and printed,
any changes made to the
ingredients of the
preparation are reflected
in the past prescription
entry in the patient
record.

Create a new custom preparation if the ingredients need to be changed from a previous prescription. After you save
the new custom preparation, you can delete the old custom preparation.

Not yet resolved. BP-166

If a site links to Medilink
and has enabled the
floating waiting list, the
floating Waiting List
window function cannot
be disabled in Indigo.

Try one of the following:

Before you run the Indigo Program Update, go to Setup > Preferences > General > and untick the box Show wait-
ing list if enabled to Medilink.
If you have already run the upgrade, call Best Practice Software Support to receive a script to disable this func-
tion.

Not yet resolved. BP-189

Appointment Book SMS
Reminders — Exclude
appointments made
within the last x
days default dependency
issue.

The checkbox Exclude appointments that already have a reminder sentmust be ticked for the Exclude
appointments made within the last x days default to work. Otherwise, Exclude appointments that already have a
reminder sent must be manually selected when sending the SMS.

Not yet resolved. BP-193
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Issue Workaround Fixed in Key

An error code 50 that
requires you to close Bp
Premier can occur in any
screen.

This known issue is under investigation. If this error occurs, check Bp Premier to make sure that the most recent data
you entered before encountering the Error code 50 has been saved correctly. Any data that did not save will need to
be re-entered.

Not yet resolved. BP-707

Unable to remove a
reminder type if the
reminder reason tied to
this is deleted.

Contact Support to request a script to recover the deleted reminder reason. Not yet resolved. BP-701

Unable to submit surgical
operation numbers
(30071, 31356) via
EasyClaim for private
accounts.

Add separate sites restriction code to the item to allow the EasyClaim tickbox to be used. Not yet resolved. BP-874

After merging users, if the
user was configured to
use eRx, the settings for
eRx will be lost.

Reconfigure eRx for the new merged user. Not yet resolved. BP-699

Opening Setup E-ordering
window still reads from
SONICPATH table.

Email Support for a script to remove old e-ordering paths. Not yet resolved. BP-976

Bp Device — Error
inserting record when the
name contains an
apostrophe.

Remove the the apostrophe from the patient surname prior to completing the assessment. After the assessment the
apostrophe can be put back into the surname.

Not yet resolved. BP-970
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Issue Workaround Fixed in Key

Patient Search —Multiple
word surnames causes
result to disappear.

Add a comma after the surname. Not yet resolved. BP-796

You can no longer adjust
the accept fee when
adjusting a service in a
manual batch from the
Reconcile Direct Bill Batch
screen. This action was
possible in previous
versions of Bp Premier.

No workaround is available yet. Not yet resolved. BP-761

When importing a patient,
new Audit-C items are not
imported.

No workaround is available yet. Not yet resolved. BP-187

The multiple location
work loads the selected
location on the Login
window into the User
object. This only stores
the Location in memory.

No workaround is available yet. Not yet resolved. DEV-
7941
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Issue Workaround Fixed in Key

The accident date control
is not shown when
creating an account for a
provider who does not
have a default item
number. Adding an item
or performing an update
of another control (e.g.
entering notes, changing
service date) makes the
accident date control
appear.

No workaround is available yet. Not yet resolved. DEV-
10049

The SMS username field
on the SMS Connection
Information window
(Setup > Configuration >
SMS Messages) does not
trim white space
characters. This
causes Test connection to
display an error.

No workaround is available yet. Not yet resolved. DEV-
9185

In the Deleted Clinical
Data Utility, any
Correspondence In or Out
that has been deleted
isn’t displayed.

No workaround is available yet. Not yet resolved. DEV-
9745
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Lava and service packs

Issue Workaround Fixed in Key

Lava SP3

If two users submit a pathology request at exactly the same time, a
duplicate RequestID can be generated causing issues.

No workaround is available yet. Jade BP-
888

In Patient Record > History & Examination > Gynae, the Smear taken
checkbox should read ‘Cervical screen taken’ to reflect the changes to
cervical screening from Dec 01 2017.

No workaround required. This is a cosmetic issue that does not affect
recording of gynaecological history and examination.

Indigo DEV-
9751

MBS items 99 and 104 reconcile incorrectly when Medicare has paid the
benefit for the 99 on 104. The same issue occurs when attempting to
process an item 288 with other psychiatrist items (296, 306, 302, 291,
348, 352).

This issue can also occur when processing DVA batches that have the
same item numbers.

No workaround is available yet. Jade SP3. BP-
689

When reprinting any of the EPC documents (excluding Medication
review), the first page of the printed report is in landscape orientation,
with the rest of the report in portrait.

Open the documents and print rather than printing from EPC.
Documents will be printed correctly.

Not yet resolved. BP-
891

Can't bill MBS item 30001 on a Medicare Direct Bill voucher. No workaround is available yet. Not yet resolved. BP-
907

Lava SP1

Bulk bill accounts are sending 10991 instead of 30071. If a held patient account needs to be changed to Medicare, cancel the
held account and bill a new Medicare account.

Indigo SP1 BP-74
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Issue Workaround Fixed in Key

If you download an online claiming Processing report for a service that
has been resent and fully paid off in a manual batch, the report will not
display the payment information correctly.

Contact Support if you need to adjust items in this scenario. Indigo SP1 DEV-
7601

On-the-day appointments cannot be viewed in the Week view of the
Appointment Book.

Do not use the Week view to book appointments around on-the-day
appointments.

Indigo DEV-
8242

When paying off an account partially by EFT (using Tyro) and partially by
direct credit, an error occurs after clicking Process.

Process the payments separately. Indigo DEV-
9071

The preventative health notification for Influenza vaccinations is not
displayed for Aboriginal and Torres Strait Islander patients under the age
of 50.

No workaround is available yet. Indigo DEV-
7632

If a processing report is downloaded for a batch, and there is a service
record in the Bp Premier database but the ClaimServiceID does not exist
in the report downloaded, this service will have its Paid amount
updated to its TotalFee, whether it was paid or not.

Bp Premier should correctly leave it as unpaid. The practice should
confirm with Medicare whether the service was paid or not.

No workaround is available yet. Saffron SP1 BP-
1027

Bulk Document Importer — Fatal error after changing file order for
merged images.

Do not expand the display before assigning to a patient to prevent the
error.

Not yet resolved. BP-
188

An error occurs when sending an eReferral or an Event Summary with
an investigation result name containing the character '&'.

Exclude the test to upload the eReferral or Event Summary successfully. Not yet resolved. BP-
702

If an appointment is booked into the first appointment slot after
midnight, the appointment produces an error when opened on that day.

Do not create an appointment in the first slot after midnight. Not yet resolved. DEV-
9025
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Issue Workaround Fixed in Key

When over 600 batches are returned when displaying Medicare claims,
not all batches are displayed.

Choose a shorter date range to search for batches. Not yet resolved. BP-
878

The Backup history in Bp Utilities does not display backup file sizes. Print the backup history, which will print the correct information. Not yet resolved. DEV-
9393

Lava

Slowness can occur when printing the DB4 form. No workaround is available yet. Indigo SP1 BP-62

Online claiming — Get processing report function reverses payments
made in later batches.

Manually pay off items in a manual direct bill batch after processing. Indigo SP1 BP-92

Online claiming — Processing report not correctly resetting services. No workaround is available yet. Indigo SP1 BP-97

Online Claiming — Adjusting unpaid services can action paid services. No workaround is available yet. Indigo SP1 BP-98

Adjustments — Adjusting an account and adding a duplicate item
doesn't allow time of service to be set.

Cancel the invoice and create a new invoice with correct item numbers
and service date.

Indigo SP1 BP-
131

An unstable internet connection can cause Bp Premier to freeze when
waiting for a response from Medisecure when prescribing.

No workaround is available yet. Indigo SP1 BP-
789

An error may appear if a script is ceased midway through being printing. Wait until a script has finished printing before ceasing medication. Indigo SP1 BP-56

Printing Medicare forms takes longer due to increased document sizes
and different printer environments.

No workaround is available yet. Indigo SP1 BP-62

In the Patient Billing History screen, if an account is adjusted that
has Number of Patients allocated, the number of patients will reset to 1.

Ensure the Number of patients is reset to the correct number after
adjusting an account.

Indigo DEV-
5887

If an appointment is booked via online appointments, it will not appear
in the appointment history unless Include family members is ticked.

Tick Include family members in the appointment history window. Indigo DEV-
6173
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Issue Workaround Fixed in Key

If the billing provider for an immunisation has an open bracket '(' in their
surname, the immunisation will not be sent to AIR.

Remove brackets from provider's surnames. Prior to Lava, brackets were
often used to indicate a provider record at multiple locations.

Indigo DEV-
6216

When using the word processor, the provider number field will always
return the user's provider number linked to their usual location, not the
provider number linked to the location at which the user has logged in.

Manually change the wrong provider number to the right provider
number in the document.

Indigo DEV-
6411

If Tyro is enabled on a workstation, private patient claiming will invoke
Tyro functionality despite the Easyclaim checkbox being disabled.

Tick and untick the Send via patient claiming checkbox. This will untick
the disabled Send via Easyclaim checkbox.

Indigo DEV-
7711

When attempting to connect to My Health Record when the NASH
certificate has expired, a message appears 'Connecting to My Health
Record' and Bp Premier will become unresponsive.

Import a valid NASH certificate. Indigo DEV-
7742

An error occurs when exporting old Management reports as either PDF
or RTF. The report is not exported.

Run the utility Old Reports Update that can be supplied to you by Best
Practice Software Support.

Indigo DEV-
7799

When running a compressed backup (manual or scheduled), no error
message is given when there isn't enough space to process all of the
databases in the _Working directory.

Try the following:

Regularly check the content of backups to ensure that all databases
are present.
Test backups regularly by restoring to a test server.
Always check there is enough free space on the C: drive (over two
times the size of the database if backing up to a different drive, over
three times the space if backing up to the C: drive).

Indigo DEV-
7979

Errors may occur when clicking buttons on the Appointment Book for a
double-booked appointment.

No workaround is available yet. Indigo DEV-
9072

The Reversed Payments management report doesn't show the reversal
reason.

No workaround is available yet. Indigo DEV-
8361
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Issue Workaround Fixed in Key

Bp Premier closes when clicking Cancel on the Duplicate SMS prompt. Remove the formatting differences between the mobile numbers and
resend.

Indigo DEV-
8733

The Cancelled and written off services management report uses the
user's name who created the account when writing it off, instead of the
user's name who actually wrote it off.

This issue has been resolved in the November 2017 Data Update. Indigo DEV-
8360

There may be slowness opening the Finalise visit screen due to the
amount of data that is processed.

No workaround is available yet. Lava SP3 DEV-
7674

Management reports can display incorrect information if the same
invoice is adjusted or paid when it is accessed by two different people or
open on two different computers.

Ensure your administration staff are aware that this can happen. Don't
adjust an invoice if payment is being made elsewhere.

Jade BP-
593

For workstations running Remote Download, when an allergy is added
via the cease medication process in remote download mode, an error
will occur when the workstation is reconnected to the database.

During a remote download session, only add allergies through Clinical
record > Reactions > Add.

Jade DEV-
8285

See BP-86 below for more information. Jade DEV-
8928

Multiple DVA item numbers, such as 732, cannot be transmitted in a
single invoice.

Add additional service text, invoice note, and restriction code. Indigo DEV-
9242

Results Import - HTML URL link is not rendering correctly when there is
an Inline link. This means when the URL is clicked within the result, it
doesn't load the webpage on the expected patient DICOM data

Replace the text '%20' in the HTML URL with a plus sign '+'. Jade BP-86

For workstations running Remote Download, an error appears when
generating the National In-Patient Medication Chart.

No workaround is available yet. Indigo SP1 DEV-
8149
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Issue Workaround Fixed in Key

When searching for a drug in the Current Rx Add window, a refresh
issue will occur if you misspell the medication. The window will display
medications, but you cannot select one.

Spell the medication you are searching for correctly. Not yet resolved. DEV-
9140

Reverse payment — The Credit payment to payer's account checkbox
resets when you select from the Reason for Reversal dropdown.

Choose a reason for reversal before unchecking the credit check box. Not yet resolved. BP-
134

Daily message font size not changing. Use external software such as Microsoft Word to change font size or
colour, and copy and pasted the adjusted text into the daily message
window.

Not yet resolved. DEV-
5534

Word Processor — Data loss can occur when using large images. Reduce the image height and width in the word processor before saving
the document.

Not yet resolved. DEV-
3603

For Held accounts, the Multiple operations rule reduces the fee
incorrectly.

1. Create an account billed to Medicare.

2. Add items 30196, 30195.

3. Hold the account.

4. Double-click on one of the items that are already reduced.

5. Add something like service text and click OK. The fee will now halve.

Not yet resolved. DEV-
7518

When the Prescriptions permission is set to 'View only', the user is
unable to use the Show compliance option when viewing Rx.

Change the user's permission to 'Add/Edit/Delete'. Not yet resolved. DEV-
7640

If a Provider who is set up for Medisecure prints stored prescriptions, Bp
Premier will send all the stored prescriptions to Medisecure, regardless
of the Medisecure status of the original prescriber.

Use the filtering options in the Stored Prescriptions window before
printing to ensure that the user does not print prescriptions for any
users who are not set up to use Medisecure.

Not yet resolved. DEV-
7686
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Issue Workaround Fixed in Key

Selecting Mark as fully paid in Online Claiming does not create any
payment records for the service, and therefore the Payment reports do
not match the Medicare batch reports.

Only use Mark as fully paid when Medicare has paid the batch external
to the batch and the user wants to indicate that the item has been paid.

Not yet resolved. DEV-
6920

When importing an image via the Bulk Document Import Utility, the
image can be rotated but will rotate back when the import window is
refreshed by ticking any of the following: Inbox, Patient File, Default,
Delete after importing, Add to selected image as a new page.

Tick the checkbox you want to apply before rotating the image: Inbox,
Patient File, Default, Delete after importing, Add to selected image as a
new page

Not yet resolved. DEV-
6152

In the Appointment Book, any slot in an extra session cannot be made
unavailable if the time being made unavailable matches a slot in a
session that is for the same day of week but has been set up as part of a
cycle.

Modify the extra session to move the times that the user wants to make
unavailable.

Not yet resolved. DEV-
7809

You may receive an error that says '… not able to access the database
BPSDOCUMENTS1 under the current security context'.

Contact Best Practice Software support to request a script to fix the
issue.

Not yet resolved. DEV-
7986

When adjusting the fee for a $0 custom item on a custom schedule from
the Finalise Visit window, the amount entered is not retained when
creating the account from the linked appointment. The item will appear
as $0 in the Create Account window and the user will need to change
the amount once again.

Try one or both of the following:

Change the custom fee amount to $0.01 via Setup > Practice fees.
Use the practice fee schedule (the fee schedule is unaffected).

Not yet resolved. DEV-
7992

Workstations running Remote Download cannot access HealthShare
factsheets, HealthLink forms, or Online Help.

Bp Premier resources that require Internet connectivity cannot be
accessed while the workstation is not connected to the Internet.

Not yet resolved. DEV-
8147

If a patient is bulk-billed a second visit on the same day after paying
privately for the first visit (or bulk-billed the first after paying for the
second), Medicare will reject the claim and say 'Benefit previously paid'.
This is because a specific flag isn't set when claiming an additional
service via bulk bill to indicate that the service is not a duplicate.

A possible solution is to create an additional bulk-bill account which will
be recognised as '3rd visit same day'. Change the 3 to a 2 and transmit
via Online claiming. This will add the required flag to indicate that the
service isn't a duplicate. The received exceptions of 'Benefit has been
previously paid' from the second account will need to be written off.

Not yet resolved. DEV-
8266
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Issue Workaround Fixed in Key

Duplex printing will only occur when items are sent to the Windows
default printer.

Print all duplex-required printing to the Windows default printer. Not yet resolved. DEV-
8272

When a CDA result is viewed in Document Viewer, Bp Premier may
select the wrong XML file of the result to view and display the XML code
instead of a readable document. The file system cannot guarantee the
order of the files. The NTFS file system is supposed to order files
alphabetically. However, this is not guaranteed.

This is not a common occurrence. If your practice encounters this issue,
contact Best Practice Software Support for investigation.

Not yet resolved. DEV-
8323

In the Payment screen, an error appears when paying off a single invoice
with two separate cheques.

Separate the cheques into multiple payments against the invoice. Not yet resolved. DEV-
8501

Unable to have a different letterhead for each User's location. Configure the letterhead for each letter when the location is different
than the usual location or have the User profile set up for each location
they work

Not yet resolved. DEV-
696

Issues may be encountered when merging users. Limited details are
merged.

Contact Best Practice Software Support for more information on
merging users.

Not yet resolved. DEV-
9042

If a long appointment is booked into a slot that has an unavailable slot
before and after, the length of the long appointment cannot be
reduced.

Remove one of the surrounding unavailable slots, which will allow you
to edit the long appointment and reduce the length.

Not yet resolved. DEV-
9330

Medisecure — Error printing script with Medisecure app running on
client.

Remove the Medisecure app from the client machine and only run from
the Server

Not yet resolved. BP-
793

In the Clinical > Pregnancy list, the user list displays all users. No workaround is available yet. Not yet resolved. DEV-
8146

After a message is actioned from the Messages screen, Bp Premier will
select the next most recent message instead of the next chronological
message.

No workaround is available yet. Not yet resolved. DEV-
8254
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Issue Workaround Fixed in Key

Information selected about 'Mobility Aid' is not displayed when printing
a Health Assessment.

No workaround is available yet. Not yet resolved. DEV-
8255

When booking an appointment in a session time slot that is longer than
the default appointment length, the increments available allow you to
exceed the maximum hours available in a day.

No workaround is available yet. Not yet resolved. DEV-
8273

When importing patients, you may receive an error message 'Cannot
open database BPSDocuments0 requested by login'.

No workaround is available yet. Not yet resolved. DEV-
8744

When downloading a DVA processing report, the report will only display
the total of services that have an explanation code.

No workaround is available yet. Not yet resolved. DEV-
9282

Shortcut to underline text should be changed back to Ctrl+U. No workaround is available yet. Not yet resolved. BP-
885

Atomised Report values — Header falls out of alignment with the body
when there are more than 340 values.

No workaround is available yet. Not yet resolved. BP-
882

The multiple operations rule is still applied for Private fees. No workaround is available yet. Not yet resolved. BP-
754

When you add a patient directly to the waiting room using the "Add to
waiting room" button, the list of users that is shown does not take into
account what locations a provider works at, allowing the user to add
patients at any location.

No workaround is available yet. Not yet resolved. BP-
705

Unable to select a location when importing documents via the Bulk
Document Import utility.

No workaround is available yet. Not yet resolved. BP-
698

Last updated 28 October 2021
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End of support for older versions
Best Practice Software regularly provides new releases of our software, so that you have the latest mandated regulatory requirements and a range of software improve-
ments covering security features, fixes to known software issues, and new software features. However, regular software releases present an increasing challenging to our
Support team to continue supporting customers using older versions of Bp Premier.

If an older version has been 'sunset', official support for that version has ceased, including the provision of version-specific templates, old reports, minimum software
requirements, and access to Bp Premier Support. Support is always available to assist our users in upgrading to the latest version.

The online Lava and Indigo Knowledge Bases will continue to be available users of those versions of the software.

The following table provides a schedule of current and future sunset versions and dates. To check the version of Bp Premier, select Help > About from the menu.

Bp Premier Version Build No When Bp releases this version Support ceases on this date

Saffron SP3/SP3 Rev1 1.11.3.968/1.11.3.974 TBA TBA

Saffron SP2/SP2 Rev1 1.11.2.952/1.11.2.955 TBA TBA

Saffron SP1 1.11.1.934 Orchid TBA

Saffron 1.11.0.927 Saffron SP3 March 2022

Jade SP3 / SP4 1.10.3.908 Saffron SP1 June 2021

Jade SP2 1.10.2.893 Saffron November 2020

Jade SP1 1.10.1.886 Jade SP3 23 July 2020

Jade 1.10.0.880 Jade SP2 30 June 2020

Version Indigo and all service pack releases are considered sunset from June 2020. This includes versions: 1.9.0.846, 1.9.0.856, 1.9.1.863, 1.9.1.864.
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Bp Premier Version Build No When Bp releases this version Support ceases on this date

Versions Summit and Lava, including all service pack releases, are considered sunset from 10 January 2020. This includes versions: 1.8.4.642, 1.8.5.754, 1.8.6.801, 1.8.7.804, and
1.8.8.810.

What should I do if I'm running a version that will soon be sunset?

The following instructions summarise how to upgrade your version of Bp Premier to the latest version. You may require your IT services provider.

1. Review the What's new page to find out what the latest Bp Premier version is. Download and review the release notes from the What's New page for all versions
between your current version and the latest version to see the new features that have been added and if you need to take any action at your practice to work with
the new features.

2. Review the system requirements for the latest version of Bp Premier. If your server or workstations do not meet the minimum requirements, you may need to
upgrade your hardware or database before you can proceed with a program update.

3. Update to the latest drug database update if you haven't already.
4. Download the latest program update from the corporate website.
5. Back up the Bp Premier database and test that the backup can restore successfully.
6. Outside of regular practice hours, run the latest program update on the Bp Premier server. Follow the instructions on screen in the upgrade wizard.
7. Review the release notes for the upgrade version to see if you need to perform any post-upgrade configuration.

Last updated 28 October 2021
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