
Bp Premier Saffron SP3 Release Notes
These release notes describe the changes made to Bp Premier since Saffron SP2 build 1.11.2.952.

Release Date  08 March 2022

Release version Bp Premier version Saffron SP3 (1.11.3.968)

Notes last updated 31 March 2022

What is in this release? This release of Bp Premier includes Improvements to AIR functionality.

Which version can I
upgrade from?

You can upgrade to version Saffron SP3 from Bp Premier version Indigo SP1 (1.9.1.863)
or later. To check the current program version that you have installed, select Help
> About.

Which data update do
I need?

You must install the February 2022 Data Update or later before you can upgrade to
version 1.11.3.968. However, Best Practice Software recommend making sure you have
the most recent Data Update installed before you run a program upgrade.

Which database and
operating system versions
are supported?

Windows operating system Windows 8.1 or higher is supported. Microsoft Windows
Server 2012 and higher is supported. Microsoft SQL server 2012 and higher is supported.

When should I upgrade? Best Practice Software recommend running the program upgrade outside of business
hours.

How do I upgrade? Brief upgrade instructions are included in this document.

What do I do after
upgrading?

If you have not yet done so in Saffron SP2, you will need to connect to Medicare Web
Services via Setup > Configuration > PRODA. Youmust successfully set up a connection
with Medicare Web Services in order to use online patient verification, online claiming
and AIR functions in this build of Bp Premier.

Are there any known issues
in this upgrade?

Yes. Click here to view the Saffron SP3 known issues list.

Copyright Statement

This material is classified as commercial-in-confidence. Unauthorised distribution of this information may constitute a breach of
our Code of Conduct, and may infringe our intellectual property rights. This information is collected and managed in accord-
ance with our Privacy Policy, available on our website. © Copyright 2022
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Upgrade to Saffron SP3 1.11.3.968

You must have the February 2022 data update or later installed before you upgrade to 1.11.3.968.

1. Back up your Bp Premier database before running the upgrade.
2. Synchronise all workstations in remote database mode with the Bp Premier server before you upgrade.
3. Download and run the latest Drug Update on your Bp Premier server computer.
4. Log all users out of the server and all clients before you upgrade.
5. Download and run the 1.11.3.968 update on your server and all clients.
6. Log back in to Bp Premier and resume use.

Upgrade notes

Take into consideration the following points before upgrading to Saffron SP3:

You must upload all prior immunisation records to the AIR before upgrading to Saffron SP3.
Medicare Web Services and access to AIR functions are not available in remote mode.

NOTE After upgrading to Saffron SP3, to use Online Claiming, AIR functionality, and Medicare, DVA and Con-
cession verification, youmust successfully set up a connection with Medicare Web Services via Setup > Con-
figuration > PRODA if you have not done so already in Saffron SP2.

For information on registering with PRODA, select Help > Online to open the Bp Premier knowledge base and
search for 'proda'. For information on setting up Medicare Web Services in Bp Premier, search for 'mws'.

AIR provider numbers

If providers without individual provider numbers require access to send immunisations to the AIR and view AIR
data, you must add an AIR provider number for the practice location via Setup > Practice details > Practice loc-
ations > Edit.

NOTE
If your practice location has ever provided COVID-19 vaccinations or you have logged into your practice's
PRODA/HPOS AIR account, it is likely that you already have a location AIR provider number. If you already
have a location AIR provider number but you are unsure of what the number is, contact the AIR on 1800 653
809 and ask them to provide it to you.

If you already have a location AIR provider number, you can find the number in PRODA:

1. Log into PRODA.
2. Select Services from the links in the top-right of the screen.
3. SelectMedicare.
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4. Select your organisation.
5. The location AIR provider number will be listed in the identifier table under HPOS - AIR Provider Num-

ber.

If you do not yet have an AIR provider number at location level, you must complete and submit the Application to
register as a vaccination provider form (IM004). You must send the completed form to your state or territory
health department. Once your application has been approved by your state or territory health department, they
will forward the application to Services Australia for processing.

Your location AIR provider number will be seven characters, comprised of letters and numbers.

Until your location has an AIR provider number, only users with a Provider Number assigned in their Location
Manager will be able to send immunisations to the AIR and access AIR information in Bp Premier.

If you require assistance from Services Australia regarding the Location AIR provider number, ensure you men-
tion that you are calling about an 'Ancillary provider for the practice'.

New statuses when performing a check for payments

Some terms used by Medicare and DVA to indicate claim processing statuses have changed under the Medicare
Web Services framework. Your billing staff should be made aware of the new status descriptions that may appear
in Bp Premier when performing a check for payments after you upgrade.

Alert Description

REPORT_NOT_
FOUND

The claim information does not match Services Australia's records. Contact Services Australia for
more information

REPORT_NOT_
READY

The claim has not yet been finalised by Services Australia. Try again later.

REPORT_NOT_
AVAILABLE

The claim was processed and has been rejected. Check the processing report for more
information.

Direct bill claim numbers and Correlation ID numbers

As of Saffron SP3, direct bill claim numbers will reset to A0001 every day for each provider. To search for a par-
ticular batch, use the claim number in combination with the batch date.

The Correlation ID column has been added to the Online Claiming Screen in Saffron SP3. You may need to
provide the correlation ID to Medicare when contacting them about a batch.

Where do I find more information?

Select Help > Online from Bp Premier to open the Knowledge Base.
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New Features

Submit online claims and send immunisations to AIR via Medicare Web Services

In this version of Saffron SP3, sending online claims and sending immunisations to AIR is facilitated through Medi-
care Web Services, rather than the Medicare adaptor and site certificates.

Australian Immunisation Register

In this version of Saffron SP3, information recorded in the Australian Immunisation Register (AIR) can be
accessed from Bp Premier via the View AIR screen in the Immunisation section of the patient record. Information
available via the View AIR screen includes:

alerts
vaccines due
vaccine history
medical contraindications
natural immunities
vaccine trials

The following patient information can also be updated on the AIR via the View AIR screen:

The patient's indigenous status
whether the patient requires additional vaccines due to belonging to a high risk group
whether the patient has a planned catch up schedule.

Immunisation workflow improvements

As of Saffron SP3, individual immunisations can be sent directly to the AIR from the Immunisation screen in the
patient record. You are no longer required to send immunisations to the AIR in bulk, however this workflow can
still be used if desired.

NOTE If you are working in remote mode, you will not be able to access Australian Immunisation Register
(AIR) information in Bp Premier, or send immunisation records to the AIR from the patient record.

Edit pendable patient claims

In Saffron SP3, if a patient claim requires further assessment by an operator, an error will appear indicating that
the claim has been marked as 'pendable', and adjustments may need to be made to the invoice to be accepted
by Medicare.

New preventative health notifications

As of Saffron SP3, preventative health notifications for breast cancer screening and bowel cancer screening will
display in the patient record for eligible patients.

Page 4 Bp Premier Saffron Service Pack 3 Release Notes



Contract Doctor and Registrar user categories added

As of Saffron SP3, the user categories Contract Doctor and Registrar can be selected from the Category: drop-
down menu in the New user and Edit user screens.

New workflow for recording distance travelled for DVA accounts

In Saffron SP3, when creating a DVA account that includes kilometres travelled, you can now select the KM DVA
item number via the Account item screen, and enter the number of kilometres.
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Other enhancements

Bp Function Release Notes Key

Auditing A filter for AIR audit and error logs has been added to the View MWS
Logs . exe utility.

64221

Billing Invoice time stamps now only appear against services if an account
has been flagged as In Hospital, or when adding duplicate services.

67400

Cervical Screening UnderMain Screen > Clinical Menu > Cervical Screening, the Risk
Category column has been added under Cervical Screening Tests,
and the label on the No longer requires pap smears checkbox has
been updated to No longer requires cervical screening.

65257

Electronic prescriptions Electronic prescription information automatically added to Today's
notes after the electronic prescription has been sent now includes
the method that it was sent via.

67827

Immunisations A complete list of sent vaccinations can be viewed via Utilities >
Australian Immunisation Register > View > Sent vaccinations.

67537

Immunisations Immunisations in the AIR can now be saved to the patient record in
Bp Premier.

67774

Immunisations The Check AIR access button has been added to the Immunisation
window. Users can click Check AIR Access to view a list of AIR
information they are authorised to access in Bp Premier.

64043

Immunisations Patient medical contraindication information recorded in the AIR can
be viewed by selectingMedical Contraindications in the View AIR
screen.

64045

Immunisations Users can now send individual immunisations to the AIR from the
Immunisations screen in the patient record by clicking Save and
Send.

64105

Immunisations Under Utilities > Australian Immunisation Register, the Billing
provider column and the Filter by doctor filter have been changed to
Immunised by.

64112

Immunisations Patient vaccine trial information recorded in the AIR can be viewed
by selecting Vaccine trials in the View AIR screen.

64220

Immunisations Users can update immunisations via the immunisation window in the
patient record by right-clicking the immunisation record and
selecting Edit, updating the fields required, then clicking Update and
Save.

64334

Immunisations Patient Natural immunity information recorded in the AIR can be
viewed by selecting Natural Immunity in the View AIR screen.

64610
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Bp Function Release Notes Key

Immunisations The Planned Catch up button has been added to the General tab in
the View AIR screen. Adding a planned catch up schedule for a
patient allows them to have an up-to-date status for family
assistance payments purposes. This information is uploaded to the
AIR.

64099

Immunisations The General tab in the View AIR screen now populates with a list of
vaccines due for the patient from the AIR.

64102

Immunisations Selecting the History tab in the view AIR screen now populates the
screen with the patient's immunisation history from the AIR.

64103

Immunisations Clicking Get individual immunisation History Statement in the View
AIR screen History tab generates a copy of the patient's
Immunisation History Statement.

64042

Immunisations The Indigenous Status button has been added to the General tab in
the View AIR screen. Selecting this button adds an Indigenous status
alert, which is uploaded to the AIR.

64104

Immunisations When submitting an immunisation to the AIR, a confirmation request
now appears if the patient has not been found in the AIR, or if there
is a problem with the immunisation data.

64110

Immunisations The Additional Vaccines Required button has been added to the
General tab in the View AIR screen. Selecting this button adds a
Special Risk Group alert , which is uploaded to the AIR

64114

Immunisations When View AIR is selected, an alert will appear if the patient
demographic does not have enough information to successfully
identify them in the AIR.

64101

Immunisations The Country drop-down menu has been added to the Immunisation
screen. When adding an immunisation in the patient record, if Given
Overseas is selected from the Billing Provider drop-down menu, the
Country drop-down menu is enabled and a country can be selected.

65350

Immunisations When adding an immunisation in the patient record, Given Overseas
can now be selected from the Billing Provider drop-down menu.,

64107

Immunisations When the View AIR button in the Immunisations section of the
Patient record is clicked, the View AIR screen opens.

64113

Installer A message will appear in the Bp Premier installer warning users that
Medicare Web Services must be set up in order to use Medicare,
DVA, Concession verification and the Australian Immunisation
Register in Saffron SP3.

68010

Internal messages Hyper links can now be included in internal messages 32942

Medicare Web Services For clinical-only practices, when Transfer immunisation data back to
the billing package is unticked, immunisations can be sent to AIR via
the patient record.

68107
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Bp Function Release Notes Key

Medicare Web Services If service tracing has been enabled, when a request for a token is
sent, then the following information is logged: the machine the
request was initiated from, the time of the request, and where the
request stemmed from. This will assist with troubleshooting.

67996

Medicare Web Services Backup systems no longer continue to poll PRODA for token
refreshes.

67896

Medicare Web Services A minor ID can now be entered via Setup > Practice Details >
Change. This allows clinical-only practices to enter a minor ID.

67890

Medicare Web Services The PRODA RA (Organisation) field in Setup > Configuration >
PRODA now only accepts numbers.

65308

Medicare Web Services Patient verification time-outs and errors are now handled gracefully. 64941

Medicare Web Services When attempting to send an immunisation to the AIR without a B2B
device configured, a prompt appears indicating that a B2B device
needs to be set up.

67425

Messages On install or upgrade to Saffron SP3, an internal message has been
added for all users listing the features included in the build.

67715

Online claiming Correlation IDs now display in the Online Claiming screen for each
batch, and in the Patient Billing History when a user right-clicks an
invoice billed to Medicare or DVA and selects Show Medicare/DVA
transmissions.

66658

Pathology requests Cervical screening terminology has been updated in the standard and
eOrdering pathology request screens.

50469

Patient record The Maternal Serum Screening Test for SA Pathology has been
updated.

67660

Patient record Bowel cancer screening has been added as a Preventative Health
Notification.

50714

Patient record Breast cancer screening has been added as a Preventative Health
Notification.

50713

Patient record Breast cancer screening and bowel cancer screening preventative
health notifications can be turned off via the Preventative Health
button in the patient record.

65258

Practice Details An AIR provider number field has been added under Setup > Practice
Details > Practice Locations.

64633

Upgrade New Bp Premier download links have been upgraded to HTTPS.
HTTPS links work better in modern browsers.

59913

Users Contract Doctor and Registrar have been added as user categories in
the New user and Edit user screens.

67877

Bug fixes
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Bp Function Release Notes Key

Billing For DVA accounts, when billing the KM item number, the number of kilometres
travelled now records correctly.

65455

Billing Multiple MM location incentives are no longer added to invoices when switching
locations.

67606

Billing MM location incentives are now applying correctly for Medicare Bulk Bill accounts. 67545

Billing Fixed an issue where invoice timestamps were not matching the appointment time or
the time the invoice was created.

67443

Billing The Pay Gap check box in the Payment details screen now works correctly when
paying an existing account.

67098

Bp Comms Auto checking of SMS replies now works correctly for practices using Bp Comms. 67829

Bp Comms Fixed an issue where the character limit for SMS reminders was inconsistent in
different areas of Bp Premier.

24506

Bp Comms Fixed an issue where SMS reminder replies were causing a fatal error if the reply
contained the ' | ' (vertical bar) character

25147

Bp Comms SMS reminders now have a consistent character limit. 67429

Bp Comms templates If Appointment template expects a reply is selected for a reminder template in the
configuration screen, it is also selected for the template when sending the reminder.

67818

Contacts When selecting a contact in the Contacts screen and clicking Add at Address, the
address can now be edited.

64534

Document viewer Fixed an issue where documents were not rendering correctly, and incorrect
documents were displaying.

67931

Document viewer An error no longer appears when viewing PDF documents in Correspondence in or the
Inbox.

67440

Electronic Prescribing Fixed an issue where eScript tokens are cancelled if the patient has a previous
prescription with the same drug name, and the previous prescription is deleted.

65562

Electronic Prescribing Fixed and issue where the brand name and active ingredients for a drug were not
formatted correctly when sending an electronic prescription.

65344

Electronic Prescribing Deleting previous prescriptions will no longer cancel an active eScript token
prescribing the same drug.

65562

Electronic prescribing Fixed an issue where drug names were not displaying correctly on electronic
prescription printouts or sending correctly in electronic prescription tokens.

67345

Electronic Prescribing Electronic prescriptions now send the correct quantity for Ryzodeg Flex Touch 70/30
Pen Devices.

67472

Email Emails will now send correctly when recipients are separated by a space. 67230

Email Fixed an issue where emails with multiple recipients whose addresses are separated
by a space were not sending.

67230
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Bp Function Release Notes Key

eOrdering Fixed an issue where empty eOrder export paths could be saved for an eOrdering
provider by clicking Cancel, then saving.

65571

eOrdering When sending an eOrder, a prompt no longer appears incorrectly advising the user
that a folder has not been nominated for eOrders.

67575

Follow-up inbox The Filter by status field in the Follow up inbox will now remain as nil status by
default when other filters are changed,

67900

Forms A fatal error no longer occurs when using Webview2 forms in some situations. 67118

Healthlink Smart
Forms

Healthlink Smart Forms now show instructions for long term medication. 66829

Imaging The Request tab in the Imaging request screen now renders correctly when the user
does not have a preferred imaging provider.

67576

Medicare Web
Services

Internal messages generated when PRODA will expire in 30 or 14 days no longer
generate every ten minutes.

67732

Online claiming When printing a DB4 form, four copies of the form no longer print when Print 2 copies
of vouchers is selected in Setup > Configuration > Online claiming.

64642

Online Patient
Verification

When performing a bulk online patient verification from the appointment book via
Utilities > Bulk patient verification, patients with no Medicare details no longer have
the same status as the patient above them.

66829

Online patient
verification

When performing an online patient verification from the appointment book by right-
clicking on an appointment and selecting Online patient verification, clicking OK on the
prompt no longer causes the appointment book window to minimise.

65575

Passwords Fixed an issue where Bp Premier was converting the emergency access password to
lower-case only letters.

67412

Pathology requests Fixed an issue where re-using a previous pathology request (Previous requests > Use
again) updates the logged in users default billing to the billing type used in the
previous request.

55097

Patient claiming Fixed an issue where lodgement advice was incorrectly printing instead of a statement
of claim for successful patient claims.

67935

Patient record The Check this box to remove these notes checkbox in the Data notes screen now
works correctly.

65206

Patient record The EDC and LMP dates for the South Australian Maternal Serum Antenatal Screening
Program are no longer editable.

62158

Prescribing Fixed an issue where the indication reason for authority prescriptions was missing for
some drugs.

67117

Prescribing Fixed an issue where clicking the Another button in the New Rx wizard only worked
whenMark for printing was selected.

64341

Printing The print button in the patient record is now working for PDF documents. 67165
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Bp Function Release Notes Key

Printing Fixed an issue where PDF files were not printing when performing a print out of a
patient health summary.

67197

Referrals TCA referral forms now use the correct address for practitioners being referred to. 28250

Results Fixed an issue where if the practice has two patients with the same surname and date
of birth (for example, twins), results for both patients were grouped under one of the
patients in the Inbox.

22413

Search Fixed an issue where the search function was returning the billing provider for
immunisations instead of the 'given by' provider, and a filter option has now been
added for the immunisation billing provider.

67725

Subpoena tool An error no longer occurs when using the Subpoena tool to create a copy of the
patient's file containing documents originally created in ZedMed.

65260

Upgrading Fixed an issue were after upgrading, some sites are unable to view items in the Inbox
or in Patient correspondence.

67294

WebView2 Using two or more pop-up WebView2 forms no longer causes a fatal error. 67118

Word processor if users attempt to access word processor templates containing clinical information
without the correct permissions set, a prompt now appears indicating that they
require clinical access to templates. Previously Bp Premier would freeze.

65282

Known issues

The below list includes all known issues identified in Saffron SP3.

Bp Function Issue Key

Electronic
Prescribing

When re-prescribing an electronic prescription token from the current Rx screen using
Medisecure, an incorrect bar code is added to printed tokens.

68531

Immunisations Immunisations created in Saffron SP2 or earlier cannot be adjusted and resent in Saffron SP3
or later.

68553

Online
claiming

A limited number of practices are experiencing an issue where Medicare payment reports
displayed in the Online Claiming screen are not reflecting the correct totals or batches.

68845

Online
claiming

Practices set up in PRODA with multiple minor IDs and a single B2B device are unable to send
claims via patient claiming.

68785

Online
Claiming

Patient claims with a $0 payment amount are not appearing in the patient claims list. 68796

Medicate Web
Services

Practices set up in PRODA with multiple minor IDs and a single B2B device are failing the active
PRODA device check in Bp Premier.

68830
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Bp Function Issue Key

Tyro The following issues have been identified when performing a check for payments for Tyro bulk
bill easyclaims:

Non-bulk bill easyclaim transactions are retrieved.
If reports for unpaid claims are not ready, the correct prompt does not appear.
If no records are retrieved, an error appears.

68874

Billing When creating an invoice with multiple items and the number of patients seen has been
added to the invoice, all items include information about the number of patients, instead of
just the items that require the number of patients added.

This can cause the incentive or any additional items that do not require the number of
patients number to be specified to be rejected by Medicare.

Workaround: This issue will be resolved in Saffron SP3 Revision 1, due in May 2022.

68722

Reports When running an online claiming report and the report includes multiple batches with the
same batch number, all services with the same batch number are listed together under the
first batch date.

This issue may occur for any reports that group batches by batch number.

68801

Printing When printing PDF documents with excessive margins from Correspondence In, an error
occurs. The error also occurs when attempting to print the document via the subpoena tool or
via a patient health summary.

68890

Immunisations Immunisation Information Payments that your Doctors or Nurse Practitioners are expecting
from Services Australia may have instead been issued to your practice, if the immunisations
were recorded as given by another practice staff member.

These Information Payments will appear on the immunisation payment statement for your
practice’s location, instead of appearing on the statement for the individual provider.

Not all practices will be affected by this issue. For more details on the issue in the
Immunisation screen, review this supporting Knowledge Base article.

Workaround: This issue will be resolved in Saffron SP3 Revision 1, due in May 2022.

N/A

Immunisations If you open the Influenza Immunisation screen from a patient record using the keyboard
shortcut Ctrl+F1, you are unable to save a record with any item other than the default
Influenza vaccination.

Workaround: Change the default influenza vaccination in Setup > Immunisation Batches >
Default Influenza Vaccine.

68879

Prescribing The Regulation 49 check box in the prescribing wizard has reverted back to its previous label,
Regulation 24.

When prescribing a medication with repeats, the number of repeats must be altered before
the regulation 24 check box can be selected. Changing the number of repeats should not be
required for the Regulation 24 check box to be selected.

68323

Patient Billing
History

In the Patient Billing History, when right-clicking a service and selecting Show Medicare/DVA
transmissions, a fatal error occurs if the service was sent via Tyro.

68371

Page 12 Bp Premier Saffron Service Pack 3 Release Notes

https://kb.bpsoftware.net/support/AIRProviderNumber.htm


Bp Function Issue Key

Patient
Claiming

When sending a payment via Patient Claiming to Services Australia, users may experience data
validation errors.

Workaround: To minimise validation errors, please ensure Patient Demographic data is in the
expected format for Services Australia. In most cases, the returned error message will be
descriptive enough to identify the erroneous data needing correction.

68276

Upgrading When upgrading to Saffron SP3, update databases does not complete successfully.

Workaround: Run the Update Database.exe utility in C:\Program Files\Best Practice
Software\BPS by right-clicking on the file and selecting 'Run as administrator'.

68312

Patient
Claiming

When sending a payment via Patient Claiming to Services Australia, if the invoice contains
MBS and non-MBS items it will fail to lodge.

Workaround: Users will need to process MBS items separately via Patient Claiming.

68282

Online
Claiming

When sending a claim via MWS to Services Australia, if the invoice contains a ‘/’ character in
the Service Text or Invoice Notes field, the claim will fail to lodge.

Workaround: To submit the claim, remove the ‘/’ character from the ‘Service Text’ or ‘Invoice
Notes’ field.

68276

Electronic
Prescribing

Medications that include a ‘<’ character in their strength field cannot be sent via ePrescribing
for Practices using eRx.

Workaround: This is currently being investigated.

68100

Immunisations Practices that do not have a HPI-O entered receive an error message when attempting to
upload immunisations to AIR, or use AIR functionality.

Best Practice Software suggest entering a practice HPI-O to ensure immunisation data can be
transmitted to AIR. Visit the Services Australia Website for information on how to apply for a
HPI-O.

Workaround: This is currently being investigated for practices that do not have a HPI-O.

68273

Patient
Claiming

When sending an invoice that requires a referral via patient claiming, if the contact included in
the referral has a 7 character provider number, an error will appear indicating that the
provider number is invalid.

Workaround: Add a '0' (zero) to the start of the provider number in Setup > Users.

68184

Prescribing When printing a patient drug sheet or patient health summary, if a prescription includes
complex instructions, then the complex instructions will show twice.

68141

AIR If the patient has a special risk group alert recorded in the AIR, updating the patient's
indigenous status will remove the special risk group Alert.

NOTE This is an issue with AIR, not Bp Premier.

N/A
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