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Set up BpComms for Best Health App

You can enable Best Health App integration for multiple practice locations. Each location is treated as a separate
entity and you must enable each one individually.

When you open the Best Health Settings setup utility from Bp Premier Configuration, the utility will retrieve
details for all the practice locations you have defined in Setup > Practice Details. You cannot add or remove loc-
ations from Best Health Settings setup, but you can update some practice details.

A user will need the Configuration and Best Health Settings permissions set to 'Add/Edit/Delete' to update Best
Health App settings.

Can I onboardmy practice to the Best Health App yet?

The Best Health App is available for general release. Your practice must upgrade to Jade SP1 and install the Octo-
ber 2019 data update before onboarding to use the Best Health App.

Internet Access Required
Your practice requires internet access to use Best Health App integration. The following URLs should be allowed
for BHA outbound/inbound traffic.

*ap-southeast-2.amazonaws.com (notice "*", so that all URLs ending with "ap-southeast-2.amazon-
aws.com" are whitelisted)
prod.bpbesthealthapi.net
cognito-idp.ap-southeast-2.amazonaws.com
cognito-identity.ap-southeast-2.amazonaws.com
s3-ap-southeast-2.amazonaws.com
*.bpbesthealthapi.net (notice "*", so that all URLs ending with "bpbesthealthapi.net " are whitelisted)

If applicable, whitelist the above URLs in your antivirus and firewalls to ensure that your server and all machines
that will use the Best Health App can access the above URLs.

Turn on Best Health App Functionality
Before using Best Health App, beta testers must make this functionality available in Bp Premier by running a
script.

1. Download the script to turn on Best Health App here. Clicking the link will download a .bpscript file to your
browser's default download directory (normally Users > Downloads or Quick Access > Downloads in Win-
dows).

If the link above does not work, you can also obtain the .bpscript file from the knowledge base link in the
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next step.

2. Follow the instructions on the support knowledge base to run the script.

Set user permission
A user will need the user permission Best Health Settings set to 'Add/Edit/Delete' to make changes in the Best
Health App Configuration window.

1. Log in to Bp Premier as an administrator-level user who can grant permissions.
2. From themain menu, select Setup > Users. Select the user to grant permissions to and click Edit.
3. Click Set Permissions.
4. Scroll down in the Permissions window and set Best Health Settings set to 'Add/Edit/Delete'.

5. Click Save and Save again to return to theUsers window.
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Onboard Your Bp Premier Location
You must onboard every location where you want to use the Best Health App functionality. Before onboarding
your location, check that the location details are correct in Bp Premier by navigating to Setup > Practice details
from themain screen. When you are sure the location details are correct, you can onboard on your location for
Best Health App:

1. Log in to Bp Premier as a user with access to Configuration.
2. Select Setup > Configuration from themain menu. Select the Bp Comms tab and click Configure Best Health

App.

3. Select a user and enter the user's password at the login screen and click Login. The Best Health Settings util-
ity will appear. In the example below, the location 'Gladstone' has already been defined in Setup > Practice
Details and the details for this location have been retrieved.
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4. Tick Enable Best Health App usage for this location. The tabs in the windowwill be enabled for editing.
5. You can update the practice details retrieved for this window. However, the details displayed here are for the

purposes of app onboarding only, and will not update the details stored in Setup > Practice Details. The details
that are entered into this screen will be visible to the users of the Best Health App who are enrolled at your loc-
ation.

6. You can set the location's Opening Hours, website if the practice has a website, and add a clinic logo to be dis-
played on the app.

7. If the practice location uses a third-party application to book appointments, enter the Appointment URL used
for third-party appointment booking.
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This link will be available from the appointment section of the patient's app. Clicking the link will open the
URL in themobile device's browser.

8. Click Save. Bp Premier will submit the request to Best Practice Software for processing. This may take a
minute.

Bluetooth beacon

Your Best Health App Welcome Pack contains one or more Bluetooth beacons that are configured to be used with
your location. The beacon allows patients to check in to their appointment within 30minutes of the appointment
start time if the app has detected the beacon is nearby. Once the appointment start time has elapsed, (60
seconds past the start time), check-in via the app is no longer available.

The beacon needs only to be plugged into a USB power source. The average range for the beacon is 20meters. If
your practice is large or has multiple reception areas, you may need more than one beacon. Best Practice Soft-
ware provides one free beacon in theWelcome Pack. Additional and replacement beacons are provided at an
extra cost.

The placement of the Best Health App beacon is significant, because walls, doors, and other obstructions can
impact the beacon’s signal quality. Materials like wood, synthetic materials, and glass possess low interference
potential. However, marble, bricks, concrete and metal have relatively high interference potential. Place the
beacon away from walls or any obstruction made ofmaterial with high-interference potential.
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Set up BpComms for SMS

This article explains how to enable Bp Comms for SMS messaging only. To set up Bp Comms and enrol patients for
both SMS and Best Heatlh App, review Bp Comms Consent on page 12

Obtain SMS user name and initial Bp Comms credit

You may already have performed this step as part of your initial setup of Bp Premier.

Contact Best Practice Software to register. Best Practice Software will ask you to complete and return a form. After
processing the registration form, Best Practice Software will supply you with an SMS user name to enter during Bp
Comms setup and your initial code to top up credit.
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Configure Bp Comms for SMS

Set up SMS

1. Select Setup > Configuration from themain Bp Premier screen. Select the Bp Comms tab.

2. Click Configure SMS at the top to open the SMS Connection Information screen.
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3. If your network uses a proxy server to access the internet, tick the I use a proxy when connecting to the Inter-
net checkbox, and enter the Proxy name, Proxy port, Proxy username, and Proxy password. If you are
unsure whether your practice uses a proxy, your IT support can assist.

4. Enter the SMS user name you were assigned.
5. Click Test Connection to test the SMS connection. If the connection is successful, click OK to return to the Bp

Comms screen.
6. Click Save to save your Bp Comms settings.

You can now record consent and enrol patients to receive SMS messages.

Page 11 Bp Premier Best Health App Guide



BpComms Consent

You must enrol a patient's mobile phone number and record their consent before they can receive Bp Comms
messages from your practice. If you have previously obtained Bp Comms consent for SMS, the same consent can
be used for Best Health App enrolment.

Because Bp Comms allows you to send more than just appointment reminders, Best Practice Software recom-
mend that your practice review its consent process and determine any changes that may be required.

How does Bp Premier handle consent when I run amail merge?

When you run a bulk message sendout like clinical or appointment reminders, Bp Comms will default themes-
sagemethod for each patient based on:

what the patient has consented to receive (set in demographics)
the practice's preferred method (set in Configuration > Bp Comms).

After you select your schedule criteria, Bp Comms will show the breakdown of howmany patients will receivemes-
sages of each type (for example 5 letters, 1 SMS and 2 App messages).

Record patient consent and enrol in Bp Comms
1. Search for the patient using any of the patient search methods: File > Open Patient, View > Patient, or

press F2.
2. Click View details to open the Patient details screen.
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3. If the patient does not have aMobile Phone number recorded, you must record a valid number before you
can click Bp Comms Consent. Mobile numbers should start with a 0 and not include the country code prefix.

4. Click Bp Comms Consent on the right-hand side of the screen.
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5. The Bp Comms Consentwindowwill appear.

Set consent
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6. Under Consent Options, tick the Bp Comms message types that the patient consents to receive. Ticking a mes-
sage type will enable other buttons in this window.

7. If you need to store a signed consent form for the patient, click Open Bulk Document Import to scan and
import the signed consent form into Bp Premier.

NOTE A user will need permission to access the Bulk Document Import tool.

8. Click Link to signed consent. The Select signed consentwindowwill appear.

9. Tick the form you want to link to as themost recent and correct consent and click Select to return to the Bp
Comms Consentwindow.

Enrol in SMS

1. Under Consent Status, you can change theMobile Phone number.

The number must be in the Australian format of ‘0400 000 000’ (with or without spaces). The number must not
have a ‘+’ or ‘61’ prefix. Incorrectly formatted numbers will be rejected by themessage provider service and will
not be delivered.
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2. Click Enable to verify the patient's mobile number. The action required by the patient will depend on your
Consent/Enrolment settings in Setup > Configuration: 

If Send patient SMS when enabling andMobile number verification is required are both unticked,
the patient receives no enrolment message, no patient action is required, and SMS enrolment is com-
plete.
If Send patient SMS when enabling is ticked, the patient will receive an enrolment SMS message but
no further action is required. SMS enrolment is complete.
IfMobile number verification is required is ticked, the Verification Requiredwindowwill appear, sum-
marising the patient's Bp Comms consent. Click Send to send a validation code to the patient's mobile
phone, and enter the code into the box that appears. Bp Premier will validate the code and SMS enrol-
ment is complete.

NOTE Best Practice Software recommend mobile number verification to ensure that the intended
patient receives messages from your practice.

3. Click Save.
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Enrol in Best Health App

1. Open the Bp Comms Consent window via patient demographics > Bp Comms Consent

2. In the Best Health App drop-down list, select the location where the patient is enrolling. Click the Enrol but-
ton. The Enrol button becomes active when at least one Consent Option is chosen.

If the patient attends more than one of your locations and you want to enable them to use the Best Health
App at those locations, you must enrol them using the above procedure but change the location selected in
the Best Health App drop-down list.

Inside the Best Health App, the patient can filter messages, health summaries and other information by the
location it was received.

3. A confirmation message displaying the chosen consent options is shown. Ensure the correct options are selec-
ted and click Send.
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4. The Best Health App status in the patient demographics window displays 'Pending' after the invitation is
sent.

5. The patient will receive an invitation to use the app including a link to download it from the appropriate
store. Once downloaded they create their account, using the samemobile number as is recorded in Bp
Premier. There will be a new Invitation to enrol message in their App Inbox which needs to be accepted.

6. When the patient has accepted the invitation to enrol, the status will change to 'Enrolled'. The change of
state from 'Pending' to 'Enrolled' may take a fewminutes to appear after the patient has accepted the invit-
ation.
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Best Health App FAQ

Bp Premier Jade edition includes integration with the Best Practice Software Best Health App, a mobile application
that your patients can install on their phones or mobile devices to receive health summaries, clinical fact sheets, and
practice communications such as appointment and clinical reminders.

Can I onboardmy practice to the Best Health App yet?

The Best Health App is available for general release. Your practice must upgrade to Jade SP1 and install the Octo-
ber 2019 data update before onboarding to use the Best Health App.

What can I send to the patient's app?

You can send the following types of content from Bp Premier to a patient's app:

Message type Description Includes

Appointment
reminder

A reminder sent to patients about an upcoming booked
appointment. Patients can reply from the app to confirm an
appointment and update the appointment book.

A list of reminders sent manu-
ally to many patients from the
appointment book
Reminders sent from an auto-
mated schedule
A one-off message sent manu-
ally to a single patient from the
appointment book

Clinical Reminder A reminder sent to patients about a regular or future
appointment that is required, such as a reminder for a Care Plan
review, cervical screen, or vaccination.

Reminder mail merge from
Reminders and Follow Up
Reminderswindows

Clinical
Communication

A practice communication about a patient's investigation results,
medication compliance or changes, or other important clinical
information or update to a patient's record.

Results followup mail merge
from Follow up Inbox
A message sent manually from
Inbox and Follow up Inbox
A message sent manually from
the patient record (Bp Comms
> Send Patient Message)

Health Awareness A practice communication about a health issue that may be
relevant to a group of patients, or important information about
the services your practice provides, such as changes to hours, or
new doctors.

Mail merge from Utilities > Data-
base search

Health Summary A summary of the patient's medications, allergies, medical
history, and immunisations. Providers can choose which items
from each category are sent.

Patient record > Bp Comms
> Send Health Summary
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Message type Description Includes

Patient Education
Material

MIMS product information or patient education leaflets of
relevance to a patient.

Patient record > View > MIMS
Consumer Medicines Inform-
ation > File > Send Leaflet
Patient record > View > Patient
Education Material > File > Send
Leaflet

Do I need patient consent to send amessage to their app?

Yes. Consent to receive the different message types is recorded in patient demographics when you enrol a
patient's app at your practice. The following patient has consented to receive three of the four communication
types.

Your practice needs to be aware of which message types can be considered implicit consent (implied as part of a
patient-doctor relationship), and express consent (where patient consent to the communication cannot be con-
sidered to be implied). Health awareness communications, such as advertising new services at your practice,
require express consent.

What can a patient send tomy practice?

With the current release of the Best Health App, patients can check themselves in for their appointment when the
patient arrives at the practice within 30minutes of the appointment time. Additional patient communications
options will be available in future versions of the app.

How do I send content to a patient's app?

Any function in Bp Premier that can send a message to a patient by SMS will also allow you to send themessage
to a patient's app. Just select 'App' from the Send viamenu when sending a message. You can also send health
summaries and patient information resources from the patient record. All of the functions in Bp Premier are listed
inWhat can I send to the patient's app? on the previous page

How do I enable Best Health App at my practice?

You need to upgrade to Bp PremierJade edition. After you upgrade:

enable app integration for one or more practice locations from Bp Premier Configuration
indicate which message types your practice will send by app and SMS
indicate whether app or SMS is the default method for patient communication.
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How do I enrol a patient in the Best Health App at my practice?

You enrol a patient via their demographics record. Click the Bp Comms Consent button and indicate which message
types the patient consents to receive. When the practice enrols a patient they receive two things:

1. An SMS with a link to download the app.
2. An invitation message in the Best Health App inbox.

If the patient already has the Best Health App installed they can ignore the SMS invitation and go directly to their
Best Health App inbox to accept the enrolment invitation.

How can I knowwhich patients have enrolled or received an invitation to enrol?

From themain window navigate to Utilities > Search and run the following query.

SELECT *

FROM BPS_Patients

WHERE StatusText = 'Active' and Internalid in

(Select internalid from PatientAppEnrolment where Enrol-

mentStatus = 0)

ORDER BY surname, firstname

Change the EnrolmentStatus filter to find patients with a different enrolment status:

EnrolmentStatus = 0, finds patients that are not enrolled.
EnrolmentStatus = 1, finds patients that are enrolled.
EnrolmentStatus = 2, finds patients that have been sent an invitation but not yet accepted (pending).

How do I unenrol a patient in the Best Health App at my practice?

Open the patient's demographics and click Bp Comms Consent. Under the Best Health App section, click Unenrol
and click Yes to confirm. If the patient is not enabled to receive SMS you will need to deselect all the Consent
Options before clicking OK.
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The patient can also unenrol from your practice in the Best Health App by going to Settings >UnEnrol.

Can I view a history of what has been sent to a patient's app?

Yes. Each time a message is sent to a patient's app, including health summaries and education material, Bp
Premier creates a contact note to record the patient contact attempt. You can view an audit trail of contact notes
in two ways:

From the Bp Premier main screen, select View > Contact notes. Set theMethod filter to 'App'. This shows the
contact notes sent to app for all patients.
From themain screen, press F10 to open the Patients window and search for the patient or patients you
want to review. Select a patient from the list and click Contact notes in the bottom right. Set theMethod fil-
ter to 'App'. This shows the contact notes sent to app for the selected patient only.

Will an appointment booked at my practice through a third-party application be for-
warded to a patient's Best Health App?

Yes. If the patient is enrolled at the location where the appointment was booked, Bp Premier will forward the
appointment notification when an appointment is booked through the third-party vendor.

If a practice has specified the URL used by the third-party booking software in the Appointment URL field of the
Best Health Settings setup utility, this URL can be clicked in the app to open the software in the patient's mobile
device browser.

How does the Best Health App Beacon work?

The Best Health App integrates with a Bluetooth Beacon that is configured to your Practice location. The beacon
allows patients to check in to their appointment within 30minutes of the appointment start time if the app has
detected the beacon is nearby. Once the appointment start time has elapsed, (60 seconds past the start time),
check-in via the app is no longer available.

A beacon is provided in your Best Health App Welcome Pack and needs only to be plugged into a USB power
source. The average range for the beacon is 20meters. If your practice is large or has multiple reception areas,
you may need more than one beacon. Best Practice Software can providemultiple beacons as part of your Best
Health App Welcome Pack on request. Replacement beacons can be provided at an additional cost.

Where do I placemy beacon?

The placement of the Best Health App beacon is significant, because walls, doors, and other obstructions can
impact the beacon’s signal quality. Materials like wood, synthetic materials, and glass possess low interference
potential. However, marble, bricks, concrete and metal have relatively high interference potential. Place the
beacon away from walls or any obstruction made ofmaterial with high-interference potential.

How do I request a new beacon?

If the beacon is not functioning correctly or you need an additional beacon due to your building size or layout or
your beacon has been misplaced, you can request another beacon by contacting the sales team. Theremay be an
additional cost depending on the reason.
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Your patients might ask the following questions about the Best
Health App

Is it safe for me to connect with my practice?

The connection between your practice and your patient's Best Health App installation is fully encrypted and highly
secure, based on the latest industry standards, security models and technologies.

Is mymedical information secure?

All data that passes through the cloud is fully encrypted and stored in Australia.

Why am I not being notified that I have received amessage from my doctor?

Make sure your patient has turned on notifications for the Best Health App. Go to your phone settings, find the Best
Health App and switch notifications on.

Do I need to havemobile data on to use the Best Health App?

Yes. The Best Health App uses mobile data to send information. The App has been designed to minimise data usage
as much as possible. You can monitor the amount of data usage in the phone settings.

Why does the Check In button take a long time to activate?

When patients arrive for their appointment, the App performs a search for the BHA beacon. Once the beacon is
detected the Check In button will activate on the Appointment Details screen enabling them to check in for their
appointment. The scan timemay vary depending on the number of Bluetooth devices in proximity.

When the device is detected the Check In button on the Best Health App Appointment Details screen is enabled,
and your patient can check in without waiting at the reception desk.

Troubleshooting
I have enabled my location for the Best Health App, and the Bp Premier sales team have activated my location,
but I can not select App as a Preferred Practice contact method from Setup > Configuration > Bp Comms.

This issuemay be a result of the required Best Health App Receiving Service or Best Practice Messaging Service
not running. To check that the necessary services are running:

1. Log in to your Bp Premier database server.
2. Hold down Ctrl, Shift and Esc together. The Task Manager appears.
3. Select the Services tab.
4. Find the Best Health App Receiving Service and the Best Practice Messaging Service.
5. If the Status is not Running, right-click the service and select Start.

Page 23 Bp Premier Best Health App Guide



Bp Premier Best Health App Guide Page 24



Send health information to a patient's app

You can send a summary of a patient's record to their Best Health App, and also send MIMS consumer information
and patient education leaflets.

All of the following instructions begin from the patient record.

SendHealth Summary

To send a health summary, the patient must consent to receivemessages of type Clinical Communication.

The Health Summary sent to a patient's app is a subsection of the clinical information from the patient's record. It is
not related to any Health Summaries uploaded to a patient's My Health Record. Only one copy of a health summary
is stored in the patient's app per location. If you send a new health summary for a location, the new version will over-
write the current version.

1. Select Bp Comms > Send Health Summary. TheHealth Summarywindowwill appear.
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2. In each section, click the ... button to send the Health Summary to the background and go back to the
patient record, where you can add additional items.

3. Bring the focus back to the Health Summary and click Refresh to see any changes.
4. Untick any items in each section you do want included in the health summary sent to the patient's app. In

the example above, the item from Medical History has been unticked and will not be included in the health
summary.

5. Click Send.

SendMIMSConsumer Medicines Information

To send MIMS ConsumerMedicines Information, the patient must consent to receivemessages of typeHealth
Awareness.

1. Select View >MIMS Consumer Medicines Information or press Shift+F12.
2. From theMIMS CMI viewer, search for a medication.

3. Select File > Send Leaflet or click the Send Leaflet icon from the taskbar.
4. Update themessage if the SMS template allows.

5. Click Send. Amessage is sent to the patient's app with a link to download the leaflet.

Send patient education leaflets

To send patient education leaflets, the patient must consent to receivemessages of typeHealth Awareness.
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1. Select View >MIMS Consumer Medicines Information or press Shift+F12.
2. From theMIMS CMI viewer, search for a medication.

3. Select File > Send Leaflet or click the Send Leaflet icon from the taskbar.
4. Update themessage if the SMS template allows.
5. Click Send. Amessage is sent to the patient's app with a link to download the leaflet.
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BpComms from the patient record

If you have upgraded to Jade, you can send SMS and Best Health App messages to patients from the patient
record. You can also add or review contact notes associated with reports, correspondence, clinical images, and
enhanced primary care.

You can use contact notes to record any attempted patient contact, whether successful or not. For example, if
you have explained a care plan to a patient, a contact note can quickly record the details.

How do I see contact notes in the patient record?

Notes are added automatically to Correspondence, Investigation reports, and Clinical images when a user carries
out clinical actions, such as sending a reminder or following up an investigation result. You can also manually
record a note in these sections and Enhanced Primary Care.

If a contact note is attached to an item in the record, a 'Y' will appear in theNote column:

Select the item and click Record Note from the row of buttons to view all attached notes, or to record a new con-
tact note.

What happens to notes when I move a document?

When you move a document from one section to another, all contact notes attached to the document are also
moved. The contact note Reason is updated to reflect the new section.

How do permissions affect contact notes?

To view and create contact notes, a user needs the Send Bp Comms Messages permission set to 'Allowed'.

In addition, the ability to view and modify contact notes in the patient record is determined by the corresponding
permission. For example, to view Correspondence in contact notes, the user must have the Correspondence In
permission set to 'View only' or greater. To delete a contact note linked to an investigation report, the user must
have the Investigation reports permission set to 'Add / Edit / Delete'.
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Send a BpCommsmessage to a patient

1. Select Bp Comms > Send patient message from themenu. The Send messagewindowwill appear.

2. Review the patient consent (green checkboxes) and ensure that the patient has consented to receive the type
ofmessage you are about to send.

3. Select whether to send via SMS or App. App will only be available if you have upgraded to Bp Premier version
Jade SP1 and the patient has enrolled for the Best Health App with your practice location. SMS is available if the
patient has enrolled for SMS messages. The default Send via selection is based on your practice's Preferred
Practice contact method configuration setting.

4. Select the Template you want to use.
5. Modify the text if the template permits and click Send. Themessage will be forwarded to themessaging ser-

vice.

Patient consent

The Patient Consents to Receive section shows themessage types to which the patient has consented, if any. Con-
sent displayed here provides guidance only to the provider. You can send a Bp Comms message from the patient
record even if the patient has consented to receive only appointment reminders. Providers must use their dis-
cretion in determining whether a Bp Comms message is appropriate regarding the patient's consent.
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Best Practice Software recommend creating specific Bp Comms templates for any standard messages sent from
the patient record and indicating this in the template name.
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