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Record immunisations

Immunisations are recorded from the patient record, including the childhood immunisation schedule.

Record immunisation for a child (<8 years)
1. Open the patient record for the patient you want to add an immunisation record for.
2. Select Immunisations from the left hand tree. The Vaccines given list will be displayed.

If the patient is under eight years old, the screen shows the childhood immunisation schedule to the left of
the Vaccines given list. Vaccinations for which the child patient is too young will be disabled.

3. If you are administering the birth Hep B vaccination, tick the Birth checkbox and select the date admin-
istered from the Birth Hepatitis B vaccination popup.
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4. To record a childhood schedule vaccination, tick the checkbox for that vaccine. The Immunisation screen will
appear.
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5. Select the vaccination from the Available Vaccines list at the top of the window.
6. The Billing provider and Given by fields default to the logged-in user, but can be changed. The Billing pro-

vider field is the name that appears on the AIR list when transmitted.

NOTE The Billing Provider field is set to the logged-in user if the user has a provider number. Otherwise,
Billing Provider is blank by default.

7. Select the Site and Route of administration.
8. Select the Sequence number for the vaccination.
9. Select a vaccination Batch No. if batch numbers have been defined, or enter a number as free text if known.
10. Enter any additional Comment for this vaccination.
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NOTE Site, Sequence, Route, Batch No., and Comments are not mandatory fields.

11. Click Save batch details if you free typed the batch number, but want it recorded against the vaccination type
in the Bp Premier list of batch numbers.

12. Tick Send reminder to add an immunisation reminder to the patient record for the date indicated in the
Reminder date field.

13. Click Save. The immunisation details will be recorded in the Vaccines given list.

Record immunisation for an adult
1. Open the patient record for the patient you want to add an immunisation record for.
2. Select Immunisations from the left hand tree. The Vaccines given list will be displayed.
3. Click Add. The Immunisation screen will appear.

4. Select the vaccination from the Available Vaccines list at the top of the window.
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5. The Billing provider and Given by fields default to the logged-in user, but can be changed. The Billing pro-
vider field is the name that appears on the AIR list when transmitted.

NOTE The Billing Provider field is set to the logged-in user if the user has a provider number. Otherwise,
Billing Provider is blank by default.

6. Select the Site and Route of administration.
7. Select the Sequence number for the vaccination.
8. Select a vaccination Batch No. if batch numbers have been defined, or enter a number as free text if known.
9. Enter any additional Comment for this vaccination.

NOTE Site, Sequence, Route, Batch No., and Comments are not mandatory fields.

10. Click Save batch details if you free typed the batch number, but want it recorded against the vaccination
type in the Bp Premier list of batch numbers.

11. Tick Send reminder to add an immunisation reminder to the patient record for the date indicated in the
Reminder date field.

12. Click Save. The immunisation details will be recorded in the Vaccines given list.

Print a vaccination list
1. Select Clinical > Immunisations from themain menu. The Immunisation listwill appear.

2. Click the Vaccine drop down box to select the immunisation list to be printed.
3. Use the options at the top of the screen to filter the search results:
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Given by
Start date
End date
Born before
Born after

4. Select Print each doctor's list on separate pages when printing details to separate the printed list of immun-
isations by doctor.

The Immunisation listwill display any immunisations recorded that meet the filter criteria.

5. To open a patient's record, select the name and select File >Open Patient or click on the toolbar.
6. After you have created a list of immunisations, you can save to file, resend to AIR, print a formatted list, or

print a simple list.

Save to file

7. Select File > Save.
8. Enter the File name to save the file as and select the file type required in the Save as type field: XML, CSV, or

TXT format.
9. Click Save.

Resend to AIR

7. Select File > Resend to AIR.

Use this function when you identify immunisations that have not been received by the Australian Immun-
isation Register (AIR) and need to be resent. All immunisations in the list will bemarked and appear in the Aus-
tralian Immunisation Register screen for transmission to Medicare.

Print a formatted list

7. Select File > Print details or click on the toolbar. This option prints an Immunisation Register in a format
suitable for submission to bodies such as the HPV Register. An example formatted printout is shown below.
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Print a simple list

7. Select File > Print list to print a simple list of the immunisations displayed.

Record an Influenza vaccination
Bp Premier can monitor influenza vaccinations administered at your practice. If your practice participates in a fun-
ded vaccination eligibility scheme, when a patient receives an influenza vaccination, the provider can record which
eligibility group the patient falls into.

Your practice can then send a list of immunisation records to a state health body.

To enable influenza vaccination monitoring:

1. From themain screen of Bp Premier, select Setup > Configuration >General.
2. Tick the Prompt for free vaccination eligibility after recording influenza vaccinations checkbox.
3. Click Save.

To submit a list of influenza vaccinations:

1. Select Clinical > Influenza vaccinations from themain menu. The Influenza vaccinations screen will appear.

2. Filter the list by Given by (administering doctor) and date range. The Eligibility column will display the cat-
egory selected for that patient when the immunisation was given.

3. To print a formatted version of the list suitable for submission, select File> Print.
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4. To save the list to file, select File > Save from themenu. Enter the File name to save the file as and select the
file type required in the Save as type field: XML, CSV, or TXT format. Click Save.
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Record immunisation batch numbers

When recording an immunisation for a patient, you are prompted for a batch number. Instead of free typing a
batch number each time, you can create a list of registered batch numbers to select from.

Add an immunisation batch number

1. Select Setup > Immunisation batches from themain screen. The Immunisation batch numbers screen will
appear.

2. Select the vaccine you want to record a batch number for and click Add.
3. Enter the Batch Number you want to register. Click Save.

The batch number will be added to the Batches in stock list and be available for selection when recording a
immunisation for a patient.

4. Click Close to close the Immunisation batch numbers screen.

Set the default influenza vaccination batch number

You can set the default vaccination and batch number for the Immunisations screen when administering the flu
vaccination, if your practice uses only one vaccination type and batch.

1. Select Setup > Immunisation batches from themain screen. The Immunisation batch numbers screen will
appear.

2. Add the immunisation batch number or numbers for the flu vaccination your practice uses.
3. Select theDefault brand of influenza vaccination.
4. Select theDefault batch number for the default brand.
5. Click Close.
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Record and print HPV vaccinations

Bp Premier provides a register for HPV vaccinations that you can save to file or print for submission to a health
body.

HPV vaccinations are recorded from the patient record like any other vaccination. Select the HPV vaccination type,
such as 'Gardasil', from the Available vaccines list in the Immunisations screen.

Print a HPV Vaccination List

1. From themain menu, select Clinical > Immunisations. The Immunisation list screen will appear.

2. Select the HPV vaccination type from the Vaccine drop-down menu.
3. Use the filters to control the displayed results:

Billing provider
Location
Start date
End date
Born before
Born after.

4. Select Print each doctor's list on separate pages when printing details to print separate pages for each pro-
vider.

5. To print a formatted list of records for submission, select File > Print details or click on the toolbar.

To print the list in a simple format, File > Print list.

To save the list of records to file, Select File > Save and save with a meaningful filename to XML, CSV, or TXT
format.
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A sample formatted printout is shown below.
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Send immunisation records to AIR

All immunisation data records for whole of life must be submitted electronically or in paper format to the Australian
Immunisation Register (AIR). In Queensland, the VIVAS state database is used for Queensland's centralised vac-
cinations system.

Each time an immunisation is recorded for a child, a record is written to the AIR register in Bp Premier. To regularly
submit immunisation information, your practice can:

transmit this data electronically, if your practice uses Medicare online claiming
print and submit immunisation records to the AIR manually, if you are do not use online claiming
export immunisation records to another software package, if you use a third party management or billing pack-
age.

Clear the vaccination register
If your practice has been using another clinical application to transmit immunisation records to AIR, you must clear
out the AIR register prior to your first transmission from Best Practice. You can ignore this step if your practice has
not submitted immunisation records from any other software.

1. Select Utilities > Australian Immunisation Register from themain Bp Premier screen. Select File > Print to
print the list.

2. After printing completes, Bp Premier will prompt you to mark all the immunisation records as notified to AIR.
Click Yes to mark all records.

Submit vaccination records to AIR electronically
If Medicare online claiming has been turned on, a Send to AIR button is displayed on theUtilities > Australian
Immunisation Register screen. This screen displays all whole-of-life immunisation records that have not yet been for-
warded to AIR.
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1. Click Send to AIR. Best Practice checks for an internet connection and transmits the list of immunisations to
AIR.

2. If any of the transmitted records are rejected, a windowwill be displayed with the reasons for rejection.
3. Vaccinations can be edited in the patient’s record and resent. Or, to exclude a record from being sent, select

the record in the Australian Immunisation Register screen and select File > Exclude current record.

NOTE Batch numbers aremandatory in Queensland.

Vaccinations that have been successfully transmitted will be removed from the Australian Immunisation Register
screen.

Submit records to AIRmanually
1. Select Utilities > Australian Immunisation Register from themain screen. The Australian Immunisation

Register screen will display all immunisation records that have not been marked as sent to Vivas or AIR.
2. Select from Filter by doctor to display immunisations administered by a specific doctor.
3. Select from Filter by location to display immunisations administered at a specific practice location.
4. To exclude an immunisation from the list, select the record, right-click, and select Exclude current record.

The immunisation record will not be included in future reports.

5. To print a report, select File > Print or click the button. After the report has been sent to the printer,
you will be prompted Do you want to mark these immunisation records as notified to AIR?. Check that
the report has printed correctly and answer Yes to mark all records as sent.

6. Forward the printed list with the documentation required for AIR manual submissions.

View sent records
1. To view immunisations that have been printed and sent, select View > Sent vaccinations. The Sent to Aus-

tralian Immunisation Register screen will be displayed.
2. Filter the records shown by Vaccine, Given by, Location, or Start date and End date.

Resend a submitted notification
1. From themain menu, select Utilities > Australian Immunisation Register.
2. Select View > Sent Vaccinations. The Sent to Australian Immunisation Register screen will be displayed.
3. Right-click a record and select Resend Notification.

You can only resubmit one record at a time.
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Export immunisation records to billing software

If your practice uses a third party management or billing package, such as PracSoft, the third party application may
be able to import an immunisation record file created by Best Practice. Immunisations can be sent to the Australian
Immunisations Register (AIR) register from the third party package. Check with the third party package Support to
confirm if the software supports this feature.

How does the export work?

If Best Practice is configured to export immunisation records to file, each time an immunisation is recorded for a
child, a record is written to a file called IMM.OUT. The third party application must be configured to import the
IMM.OUT file and forward it electronically. All Bp Premier workstations must be configured to export to the shared
IMM.OUT file on the server.

If linking to the third party package is possible, the process to transfer existing records and set up export is:

1. Set up the link to the third party package in Bp Premier.
2. Shut down the third party package.
3. Transfer existing immunisation records from Bp Premier.
4. Restart the third party package.

Set up linking to the third party package

If your practice uses PracSoft 3, you will have to set up two-way linking to import immunisation records.

If your practice uses another third party package, you must confirm if the software can import immunisation
records. If yes, you will have to set up linking to that package.

Transfer immunisation records

You must run a database search for immunisations and manually export each record to IMM.OUT.

1. Shut down the third party billing system. This will stop the application picking up the import file halfway
through the transfer.

2. From the Bp Premier main screen, select Utilities > Search. TheDatabase search screen will appear.
3. Create a database search for patients 16 years and under who have received any immunisations. The following

example shows a search for patients with a DOB less than 17 years from the current date:

SELECT *

FROM BPS_Patients

WHERE (StatusText = 'Active' OR StatusText = 'Inactive')

AND DOB > DateAdd(Year, -17, GetDate())
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AND InternalID IN (SELECT InternalID FROM Immunisations WHERE Givendate >= '20140704' AND
RecordStatus = 1)

ORDER BY surname, firstname

4. Click Run Query to populate the search list.
5. Double-click on the first immunisation record to open the patient record screen.
6. In the tree on the left hand side, select Immunisations. This will display the Vaccines given on the right hand

side.
7. Double-click the last immunisation given to open the Immunisation screen.
8. Select Force this immunisation to IMM.OUT and click Save.

NOTE This option will not appear unless the link to the third party package has been enabled from Setup
> Configuration > Links.

9. Repeat steps 7–8 for each immunisation in the Vaccines given list for this patient.
10. Close the patient record to return to theDatabase search screen.
11. In a file explorer, browse to the directory that IMM.OUT is located. Open the file using Notepad and check if

the file contains the immunisation data you just exported in steps 7–8. If IMM.OUT contains the records, the
local export to file is working.

12. From theDatabase search screen, repeat steps 5–8 for each immunisation record in the search list.
13. Restart the third party billing package. After a short time, view the software's immunisation records to check

that the application imports the IMM.OUT information correctly. The immunisation records you exported
should appear in the third party software.

14. If records have been imported successfully, you can now create immunisation records in Bp Premier as nor-
mal.
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