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Moving Bp Premier to a new server

Moving your installation of Bp Premier from one server machine to another requires planning. You may need to
involve your practice's IT support.

These instructions assume that you are working in a conventional server environment, and not a terminal server.

Some tasks require you to open a separate knowledge base topic. Right-click a link and select Open in new tab,
or click with themiddlemouse button to open knowledge base topics in a new browser tab.

Follow the instructions in each section in order.

Prepare for migration

Obtain the Bp Premier installationmedia

Check the websitewww.bpsoftware.net for the latest version of Best Practice. Download the .ISO program
upgrade file from the Downloads page.

Best Practice Software recommend upgrading to the latest version of the software. However, if you are using an
older version of the software, you can use that version's installation DVD to install Bp Premier on the new server.

To check the version of Bp Premier in use at the practice, log into Bp Premier and select Help > About.

Obtain the latest drug update

Download the latest drug update from the Best Practice Software website:

1. Open the Best Practice Software websitewww.bpsoftware.net in a browser.
2. Select Resources > Bp Premier Downloads from themenu.
3. Under theData Upates section, click theData Update type for themonth you need to install. The rowwill

expand to show the update details.
4. Click Download to download the .exe file to the default Downloads folder, or right-click theDownload but-

ton and select Save link as... or Save target as... to download the file to a known location.

In most cases, the latest comprehensive drug update will be sufficient. However, if you are using an older version
of Bp Premier, this will depend upon which version of the Best Practice installation DVD you have. If you are
unsure which drug database to download, contact Best Practice Support or email support@bpsoftware.net.

Record link information

1. Open Bp Premier and select Setup > Configuration from themain screen.
2. Select the Links tab and save a screen capture or make a note of all entries.
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Record results import information

1. Open Bp Premier and select Setup > Configuration from themain screen.
2. Select the Results Import tab and save a screen capture or make a note of all settings.
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Recordmessaging providers

1. Open Bp Premier and select Setup > Configuration.
2. Select theMessaging tab.
3. Double click on each messaging provider listed and make a screen capture or make a note of all the entries.
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Record scanning information

This step does not apply if your practice does not use a document scanner.

1. From themain screen of Bp Premier, open a patient record.
2. Select Patient Visit > Correspondence In, and click Scan. The Scan document screen will appear.
3. Make a note of the default settings (such as theDPI setting).

RecordMedicare Online information

1. From themain Bp Premier screen, select Setup > Configuration >Online Claiming.
2. Record all settings on this screen, such as Location name, Location code, A5 vouchers, and Path to certificate

store.
3. Click Check Certificate Expiry record certificate details.
4. Browse to the folder C:\ProgramData\BPOnline\ on the existing server. Take a copy of the fileHIC.psi. This is

the certificate store file and will need to be copied to this folder on the new server.
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eRx Script exchange

1. Browse to the folder C:\Program Files\Best Practice Software\BPS and run eRx Setup.exe.
2. Click Setup users.
3. If there are any users listed with Entity IDs, the site uses eRx Script Exchange.

4. Browse to the folder C:\Program Files\Best Practice Software\BPS\eRx and take a copy of the file Erx.ScriptEx-
changeAdapter.StandardAdapter.exe.Config.

5. Copy this file and store in a known folder. You will need to copy the eRx configuration file to the new server
after installation and run the file eRx Setup.exe.

Preparation for moving the server is now complete.

Install Bp Premier on new server
1. Log all users out of the current server.
2. Perform a backup of the data using BP Backup.
3. Install Bp Premier on the new server.
4. Restore the backup made in step 2 to the new server.
5. Stop the SQL Server database instance on the old server. Consult the SQL Server documentation or your

database administrator for instructions on stopping the database.

IMPORTANT Best Practice Software recommend stopping your old database and keeping it inactive until you
are satisfied that the new live server is functioning without any problems. You can then uninstall Bp Premier
and SQL Server from the old server.

If your old database remains running and connected to the network, workstations that have not been
updated may make updates to the old database instead of the new database.
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Update registry to point to server

After moving a Bp Premier server, you must edit theWindows registry on each workstation to connect to the new
server. You will need the Bp Premier server's IP address or hostname. You can run 'ipconfig' to identify a machine's
IP address, or 'hostname' to obtain a machine's hostname.

Obtain server hostname or IP address

1. Log in to Windows on the Bp Premier server.
2. From theWindows Desktop, go to Start > Apps > Windows System > Command Prompt.
3. Type 'hostname' at the prompt and press enter. The command prompt will return the computer's hostname

on the next line.
4. If you need the IP address, type 'ipconfig' at the prompt and press Enter.
5. The IP address will be listed under the active ethernet card's IPv4 Address. In the following example, the

IP address is '192.168.1.10'.

Update workstation registry

IMPORTANT Updating theWindows Registry incorrectly has risks. Update only the entries indicated in the
instructions. Record initial values on entries that you change, in case an entry needs to be restored.
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1. Log in to Windows on a Bp Premier workstation.
2. Open theWindows command prompt.
3. Type in ‘regedit’ and press Enter. The Registry Editorwill open.
4. Scroll down to the following folder:

On 32-bit operating systems, scroll to HKEY_LOCAL_MACHINE > Software > Best Practice Software
On 64-bit operating systems, scroll to HKEY_LOCAL_MACHINE > Software >Wow6432Node > Best
Practice Software.

5. Scroll to Best Practice Software > Best Practice > Database.
6. You will see an entry for Server on the right hand side. Double-click this and an Edit String dialog box will

appear.

7. Type in the hostname or IP address for the Bp Premier server into the Value data field.
8. Click OK.
9. Locate the registry folder HKEY_LOCAL_MACHINE > Software > ODBC > ODBC.INI. If this folder contains any

sub-folder starting with BPS, delete these keys.
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10. Log in to Bp Premier on the workstation.
11. Modify a test patient's record on the workstation with a minor change and save the changes.
12. Log in to the Bp Premier server and view the patient's record you just modified. If the change is visible, the

workstation has successfully connected to the new server.
13. Occasionally, this setting will not work the first time. If the workstation cannot connect to the Bp Premier

server, repeat steps 4—8 to update the registry and test the connection to the server again.

Repeat steps 1—12 for each Bp Premier workstation.

Finalise installation
Finalising the server move involves setting up configuration for your practice's workflows and clinical integrations on
the newly moved server.
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Update drug database

Install all drug database updates that are required to bring the installation to the latest version. Browse to the
Best Practice Software web sitewww.bpsoftware.net to obtain the latest drug data update.

Start BP Service

To start BP Service, go to Control Panel > Services in Windows, locate 'Bp Service', right-click and select Restart or
Start Service. Your IT support can assist with starting Windows services.

Create any required directories

If you needed to create specific Windows folders up on your previous Bp Premier server, such as export and
import folders for results importing, you will need to create the same directories on the new server. If you are also
reinstalling other software such as PracSoft Pathology Download software, you must point these applications to
the new folders on the new server.

Backup schedule

1. From the Bp Premier main screen, select Setup > Configuration.
2. Select the Bp Service tab.
3. Check theUse Bp Service for running automated backups check box.
4. Click the Configure Automated Backup button.
5. Use the settings saved inMoving Bp Premier to a new server on page 3 to reconfigure the backup sched-

ule.
6. Tick the boxDelete old backups in same folder if you don't want to keep old backup files.
7. Click Save.

Results import

Install any result download software required by your pathology or imaging labs, just as if you were installing Bp
Premier for the first time.

1. From the Bp Premier main screen, select Setup > Configuration.
2. Select the Results Import tab.
3. Use the settings saved in Record results import information on page 4 to reconfigure results import.
4. Bp Premier will recognise that you have previously set up results import on a different computer and alert

the user.
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5. Click Yes. All links to old results import will be deactivated, and the new server configuration will be used for all
future results import.

6. Click Save to save your configuration.

Messaging Providers

Obtain and install any messaging software from your securemessaging software vendor, just as if you were
installing Bp Premier for the first time.

1. If you obtained the utility to clear out old messaging provider paths from the Best Practice database, run the
utility on the new server.

2. From the Bp Premier main screen, select Setup > Configuration.
3. Select theMessaging tab.
4. Use the settings saved in Record messaging providers on page 5 to reconfiguremessaging providers.
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Email (Optional)

1. From the Bp Premier main screen, select Setup > Configuration.
2. Select the Email tab.
3. Use the settings saved inMoving Bp Premier to a new server on page 3 to reconfigure email. Confirm with

your IT support whether email settings remain the same for your new Bp Premier server.

Scanning

1. If your practice scans documents from the Bp Premier server, you must install the scanner software on the
new server machine.

2. Perform a test scan from Best Practice: open a Patient visit, select Correspondence In, and click Scan.
3. Use the settings saved in Record scanning information on page 6 to reconfigure your scanner. Scan a test

document in to confirm the scanner works correctly.

Medicare Online

On the new server:

1. Close Bp Premier.
2. Copy the HIC.psi file you copied in Record Medicare Online information on page 6 to the folder C:\Pro-

gramData\BPOnline\.
3. Change the permissions of the file HIC.psi so that all users on the network have full access to the file.
4. Share the folder C:\ProgramData\BPOnline\ on the network so that all users have full access to this folder.
5. Open Best Practice and select Setup > Configuration >Online Claiming.
6. Check that the settings are exactly as you recorded in Record Medicare Online information on page 6 and

click Save.
7. Select View > Patients. Select a patient and open their record. Click theMedicare/DVA Eligibility check but-

ton. If Bp Premier connects to Medicare, configuration is correct.

On each workstation that uses Bp Premier Management:

1. Open Bp Premier and select Setup > Configuration >Online Claiming.
2. Ensure that the field Path to certificate store is a UNC path that points to the shared folder \BPOnline\ on

the new server, for example, '\\newservername\BPOnline' . If the field does not contain a UNC path to this
folder, enter the correct path and click Save.

3. Select View > Patients from the Bp Premier main screen. Select a patient and open their record. Click the
Medicare/DVA Eligibility check button. If Bp Premier connects to Medicare, configuration is correct.

eRx script exchange

Search for 'configure eRx' in the Bp Premier Knowledge base for more information.

New server configuration is now complete.

Uninstall Bp Premier from old server

After all workstations have been redirected to the new server, and you have tested that:
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updates from workstations are visible from the new server
the new server connects to Medicare
results import is working
messaging services are working

you can uninstall your old version of Bp Premier and reconnect themachine to the network.
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Troubleshoot installation

If you receive the error 'Unable to connect to servername\BPSINSTANCE' when you try to log in to Bp Premier
after installing a new client, or the Bp Premier server will not launch, work through the sections below relating to
installation issues. If you cannot resolve the issue from the solutions below, see Troubleshoot general client con-
nections on page 19 for more issues and resolutions.

Install log cannot be found

If you receive the error ‘Install.log cannot be found’ while trying to install the software, this usually means that a
previous Bp Premier installation did not complete successfully.

You may require the assistance of your practice's IT to perform some of the steps.

If you have attempted to install Bp Premier previously on the computer, you must uninstall all components of
the previous installation and rerun the installation.

Did SQL Server install on the server?

1. On the Bp Premier server, navigate to the following path in a file explorer:

C:\Program Files\Microsoft SQL Server-

\MSSQL<version>.BPSINSTANCE\MSSQL\Data\

Where <version> is the version number for the SQL Server database you installed. For example, if you
installed SQL Server 2014 Express, look in the folder:

C:\Program Files\Microsoft SQL Server\MSSQL12.BPSINSTANCE\MSSQL\Data\

All of the following files should be present in the folder:

BPSPatients.mdf
BPSPatients_log.ldf
BPSDocumentsinbox.mdf
BPSDocumentsinbox_log.ldf
BPSDocuments1.mdf
BPSDocuments1_log.ldf
BPSDRUGS.mdf
BPSDRUGS_log.ldf
BPSSAMPLES.mdf
BPSSAMPLES_log.ldf
BPSSampleDocs1.mdf
BPSSampleDocs1_log.ldf
BPSSampleDocsInbox.mdf
BPSSampleDocsInbox_log.ldf
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master.MDF
mastlog.ldf
model.MDF
modellog.ldf
MSDBData.mdf
MSDBLog.ldf
tempdb.MDF
templog.ldf

If the files are not present or the SQL configuration manager is unavailable, the SQL server installation failed. You
must uninstall and reinstall the database.

Check that the operating system of the client machine is supported for the version of SQL Server installed with the
server. Database component installation can fail if you try to install a SQL Server version that is not supported.

Is the BPSINSTANCE service running on the server?

1. On the Bp Premier server, select Start > Programs >Microsoft SQL Server > SQL Server Configuration man-
ager.

2. Select SQL Server Services from the list on the left.
3. In the window to the right, check that the State column for SQL Server (BPSINSTANCE) says 'Running'. If not,

right-click SQL Server (BPSINSTANCE) and select Start to start the instancemanually.

If the instance cannot be started, there is an issue related to the operating system or an incompatibility with
existing programs.

4. Navigate to the following path in a file explorer: C:\Program Files\Microsoft SQL Server-
\MSSQL<version>.BPSINSTANCE\MSSQL\Log\.

5. Look for errors in the SQL Server ERRORLOG file. You can open these files in Notepad orWordPad. Your
IT Support can assist in using the log files to troubleshoot.

6. If the BPSINSTANCE service is running, but the database files aren’t present in the DATA folder (seeDid
SQL Server install on the server? on the previous page), database installation was not successful. Reinstall
the database and check if the database files listed have been installed. If they have not, contact Best Practice
Software General Products Support Support for assistance.
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Have the TCP/IP ports been set so clients can access the server? 

If you have installed a client but cannot find the Bp Premier server, your firewall settings may be preventing detec-
tion. The Bp Premier server Windows firewall must allow connections to and from Bp Premier clients. This is nor-
mally configured during installation, but you may need to run a utility to set the port values correctly.

1. On the Bp Premier server, open an Internet browser and go to the Best Practice Software website
www.bpsoftware.net.

2. Select Updates > Utilities from themenu.
3. Under Utility H SQL Port Utility, enter your site ID and email address and click Login. The Login button will

change to Download. Click Download to download the utility file BPS_SQLportsV2.exe.
4. Double-click the utility file. The utility will open at the welcome screen. Click Next.
5. The utility will show the ports that must be opened for server-client connection. You can make the changes

manually, or tick Configure Firewall and click Finish to have the utility configure the port settings.

Does yourWindows user account have limited permissions?

If you are logged in as a Windows user with limited permissions, you may be restricted from installing applications
successfully. Bp Premier installation must be run from aWindows Administrator account.

Check the Bp Premier installation log files in the folder C:\Program Files\Best Practice Soft-
ware\BPS\BPSupport\INSTALL.log. This log file lists all files that were copied during the install process, and will log
any copy errors due to insufficient user permissions.

To changeWindows permissions, contact your IT technician or refer to:

http://support.microsoft.com/default.aspx/kb/279783
http://www.microsoft.com/windows/windows-vista/features/user-account-control.aspx.

Is your firewall preventing access to the database?

Some firewall systems can stop SQL servers from operating. You may need to adjust your firewall settings to allow
connection.

To adjust your windows firewall settings, contact your IT technician or refer to:

http://support.microsoft.com/kb/875357
http://www.microsoft.com/windows/windows-vista/features/firewall.aspx.

If you run third party software that has a built-in firewall, you will need to contact the software's product support
or your IT technician for assistance.

As a short term solution to verifying the problem, you may wish to disable all firewalls for the duration of a test to
connect to the database.

Is your Antivirus preventing SQL installation or connection?

Some antivirus software program can stop applications from installing correctly. You may need to adjust your fire-
wall settings to allow connection.
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If you have an antivirus software application that could impact prevent SQL from installing correctly, you may need
to disable the software during the installation process and when starting Best Practice Software for the first time.
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Troubleshoot general client connections

If a workstation has trouble connecting to the Bp Premier server after being added to the network, or after
changes to your practice's network, follow the instructions below to troubleshoot the client-server connection.

If a Bp Premier client cannot connect to the server, the Available Servers list is blank:

or the error ‘Unable to connect to the server\BPSInstance Server’ appears.

Work through the possible problems and solutions below.
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Check network connection
Check the following items if existing installations have server connection problems.

Physical problems

1. Are other workstations in the practice able to connect to the Bp Premier server?
2. Is the server turned on?
3. Is the network cable plugged in to the computer correctly?
4. Are the cables from the client connected to the server or network switch?
5. Is the network card in the computer connected and seated properly, if there is a network card?

Internet access

Open your internet browser and enter the websitewww.microsoft.com.au. Does the browser display Microsoft’s
website? If not, contact your network administrator for assistance. If yes, continue.

The next two tests require that you access the command prompt on your PC. You will need to know the name of the
Bp Premier server on your practice network.

1. Select theWindows flag in the bottom left, click the down arrow to view applications, and open the Command
Prompt underWindows System. TheWindows command prompt will appear.

2. In the black command prompt box, type:

ping <Bp server name>

3. Press Enter.

If unsuccessful, the ping will time out or return an error message that it could not find the host. Contact your
network administrator for assistance.

If the ping is successful, the command prompt will return your server's IP address. Write down the IP address.
Continue diagnosing the problem.

4. In the command prompt, type:

ipconfig

5. Press Enter. The command prompt will return a set of information about the workstation's IP configuration.
6. In the section of the returned information titled Ethernet adapter, look at the value for 'Media State'. If the

'Media State' is 'Media Disconnected', a problem exists with your network card or the cable plugged into it.
Contact your network administrator for assistance.

7. Go to theWindows Control Panel and open Network Connections,Manage Network Connections, orNet-
work and Internet, depending on yourWindows version.

8. Check that your current network connection is enabled and active. If not, contact your Network administrator
for assistance.
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TCP/IP settings

If the resolutions above do not work, make sure that Enable LMHOSTS lookup and Enable NetBIOS over TCP/IP
are enabled in yourWindows TCP/IP configuration. Your IT support can assist. You must restart the SQL Server
Browser service after any changes to TCP/IP configuration.

Check firewalls
If your practice's network has firewalls installed, this can often be an issue for new installations of Bp Premier. If
there is a firewall active on the server, you will need to open the appropriate ports to allow access by work-
stations.

You will need the Bp Premier installation DVD.

If your server usesWindows firewall

1. Log in to Windows on the Bp Premier server as an administrator.
2. Make sure that Windows firewall is turned on.
3. Insert the Bp Premier Installation DVD and wait for the initial installation screen to appear.
4. Click Utilities and select the option for BP SQL Ports. This will run an installation utility and walk you through

enabling the ports.
5. Close the utility when done.
6. Go to a workstation and try to log in to Best Practice again.
7. If the workstation still cannot connect to the server, continue with Check dynamic ports below.

If your server uses third-party firewall software

1. Log in to Windows on the Bp Premier server as an administrator.
2. Make sure that the third-party firewall is turned on.
3. Insert the Bp Premier Installation DVD and wait for the initial installation screen to appear.
4. Click Utilities and select the option for BP SQL Ports. The installation utility will open.
5. Click Next to display the list of ports required by Bp Premier. The ports will need to be opened in your fire-

wall.
6. Close the utility when done.
7. Open the required ports on the server using your firewall configuration software.
8. Go to a workstation and try to log in to Bp Premier again.
9. If the workstation still cannot connect to the server, continue with Check dynamic ports below.

Check dynamic ports

On some systems, the dynamic port will not be displayed and could block the connection from a workstation.
You will need to check SQL server to identify these ports.

1. Go to Programs or Apps >Microsoft SQL Server > SQL Server configuration Manager.
2. Select SQL Server Network Configuration.
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3. Select Protocols for BPSINSTANCE.
4. Double click on the protocol TCP/IP.
5. Click on IP Addresses.
6. Scroll to the bottom and identify the entry for 'TCP Dynamic Ports'. This is the dynamic port that needs to be

opened within the firewall.
7. Open the dynamic port on the server using your firewall configuration software.
8. Go to a workstation and try to log in to Bp Premier again.

If you still cannot connect to the server, you may need to check that theWindows registry entry is pointing to the
correct server.

Update registry to point to server

After moving a Bp Premier server, you must edit theWindows registry on each workstation to connect to the new
server. You will need the Bp Premier server's IP address or hostname. You can run 'ipconfig' to identify a machine's
IP address, or 'hostname' to obtain a machine's hostname.

Obtain server hostname or IP address

1. Log in to Windows on the Bp Premier server.
2. From theWindows Desktop, go to Start > Apps > Windows System > Command Prompt.
3. Type 'hostname' at the prompt and press enter. The command prompt will return the computer's hostname

on the next line.
4. If you need the IP address, type 'ipconfig' at the prompt and press Enter.
5. The IP address will be listed under the active ethernet card's IPv4 Address. In the following example, the
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IP address is '192.168.1.10'.

Update workstation registry

IMPORTANT Updating theWindows Registry incorrectly has risks. Update only the entries indicated in the
instructions. Record initial values on entries that you change, in case an entry needs to be restored.

1. Log in to Windows on a Bp Premier workstation.
2. Open theWindows command prompt.
3. Type in ‘regedit’ and press Enter. The Registry Editorwill open.
4. Scroll down to the following folder:

On 32-bit operating systems, scroll to HKEY_LOCAL_MACHINE > Software > Best Practice Software
On 64-bit operating systems, scroll to HKEY_LOCAL_MACHINE > Software >Wow6432Node > Best
Practice Software.

5. Scroll to Best Practice Software > Best Practice > Database.
6. You will see an entry for Server on the right hand side. Double-click this and an Edit String dialog box will

appear.
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7. Type in the hostname or IP address for the Bp Premier server into the Value data field.
8. Click OK.
9. Locate the registry folder HKEY_LOCAL_MACHINE > Software > ODBC > ODBC.INI. If this folder contains any

sub-folder starting with BPS, delete these keys.
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10. Log in to Bp Premier on the workstation.
11. Modify a test patient's record on the workstation with a minor change and save the changes.
12. Log in to the Bp Premier server and view the patient's record you just modified. If the change is visible, the

workstation has successfully connected to the new server.
13. Occasionally, this setting will not work the first time. If the workstation cannot connect to the Bp Premier

server, repeat steps 4—8 to update the registry and test the connection to the server again.

Repeat steps 1—12 for each Bp Premier workstation.

User is prompted to reconnect each login
If a Bp Premier workstation prompts a user to reconnect to the server each time you log in, the issue is most likely
related to theWindows user having limited permissions to update the registry.

1. Log in to the workstation as a Windows administrator.
2. Log in to Bp Premier and connect to the server.
3. Close Bp Premier.
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4. Open theWindows command prompt.
5. Type in ‘regedit’ and press Enter. The Registry Editorwill open.
6. Scroll down to the following folder:

On 32-bit operating systems, scroll to HKEY_LOCAL_MACHINE > Software > Best Practice Software
On 64-bit operating systems, scroll to HKEY_LOCAL_MACHINE > Software >Wow6432Node > Best Practice
Software.

7. Right-click on the folder Best Practice Software and select Permissions. The Permissions for Best Practice Soft-
ware screen appears.

8. Select a user group to which the user who cannot connect to server belongs (most likely ‘Users’ or ‘Everyone’).
9. Tick the box in the Allow column for Full Control. Click Ok.

10. Close the Registry Editor.
11. Log out as administrator and back in as theWindows user who cannot connect to server.
12. Log in to Bp Premier and connect to the Bp Premier server.
13. Log out and back in to Bp Premier to test that the problem is resolved.

Page 26 Bp Premier Server Move Guide



Terminal servers unable to connect to server
The steps above apply to troubleshooting terminal server workstations in addition to PC workstations. However,
if your practice has a terminal server that will not connect to the Bp Premier server, the steps belowmay resolve
the issue.

1. Log in to the terminal server that is unable to connect to the server.
2. Open theWindows command prompt.
3. Type in ‘regedit’ and press Enter. The Registry Editorwill open. IfWindows displays a UAC control dialog,

click Yes.
4. Scroll down to the following folder: HKEY_LOCAL_MACHINE > SOFTWARE >Wow6432Node >Microsoft >Win-

dows NT > CurrentVersion > Terminal Server > Install > Software > Best Practice Software > Best Practice >
Database.

5. You will see an entry for Server on the right hand side. Double-click this and an Edit String dialog box will
appear.

6. Type in the IP address for the Bp Premier server into the Value data field.
7. Click OK.
8. Log in to Bp Premier again on the workstation.
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