
Bp Premier Orchid Release Notes
These release notes describe the changes made to Bp Premier since Saffron SP3 Rev1 build 1.11.3.974.

Release Date  24 January 2023

Release version Bp Premier version Orchid (1.12.0.998)

Notes last updated 23 January 2023.

What is in this release? This release includes clinical enhancements described in New Features on page 3.

Which version can I
upgrade from?

You can upgrade to version Orchid from Bp Premier version Saffron SP1 (1.11.1.934) or
later. To check the current program version that you have installed, select Help > About.

Which data update do
I need?

You must install the June 2022 Data Update or later before you can upgrade to version
1.12.0.998. However, Best Practice Software recommend making sure you have the most
recent Data Update installed before you run a program upgrade.

Which database and
operating system versions
are supported?

Windows operating system Windows 10 or higher is supported. Microsoft Windows
Server 2012 and higher is supported. Microsoft SQL server 2012 and higher is supported.

When should I upgrade? Best Practice Software recommend running the program upgrade outside of business
hours.

How do I upgrade? Brief upgrade instructions are included in this document.

What do I do after
upgrading?

No configuration is necessary to enable new features.
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Upgrade to Orchid 1.12.0.998

You must have the June 2022 data update or later installed before you upgrade to 1.12.0.998.

1. Back up your Bp Premier database before running the upgrade.
2. Synchronise all workstations in remote database mode with the Bp Premier server before you upgrade.
3. Download and run the latest Drug Update on your Bp Premier server computer.
4. Log all users out of the server and all clients before you upgrade.
5. Download and run the 1.12.0.998 update on your server and all clients.
6. Log back in to Bp Premier and resume use.

Upgrade notes

For information on registering with PRODA, select Help > Online to open the Bp Premier knowledge base and
search for 'proda'. For information on setting up Medicare Web Services in Bp Premier, search for 'mws'.

Upgrade notes

Enhanced password security

Password security has been enhanced in Orchid. Bp Premier now enforces case sensitivity for user passwords,
regardless of whether or not strong password complexity is enabled in Setup > Configuration > Security.

If your practice did not previously have strong password complexity enabled, ensure users are aware that case
sensitivity will be enabled on upgrade.

Legacy eOrdering set up functionality has been partially removed

As of Orchid, eOrdering providers must be configured in the Setup E-Ordering screen accessed via View >
Contacts > Setup > E-ordering. eOrdering contacts can no longer be set up via View > Contacts > Add new.

eOrdering will continue to function for any providers that had been configured for eOrdering prior to the
upgrade. However, the eOrder path for the provider can no longer be changed by editing the contact. To change
settings for an existing provider, you must merge the provider using the enhanced eOrdering functionality.
Instructions on merging providers for eOrdering are provided in the Bp Premier Orchid Knowledge Base.

In Bp Premier Orchid Service Pack 1 legacy eOrdering functionality will be fully removed. In this version, legacy
eOrder labs will no longer generate eOrders. Only providers configured through the Setup eOrdering screen will
have functionality to generate eOrders.
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Where do I find more information?

Select from the main screen of Bp Premier or select Help > Online from Bp Premier to open the Knowledge
Base from any main screen toolbar.

New Features

Add multiple observations

As of Orchid, you can add multiple sets of observations to a patient record in one day.

If a set of observations have already been added to a patient record on a single day and the Add button in the
observations section is clicked again, you will have to option to edit the existing set of observations or create a
new set.

Only one set of observations can be marked as the day's Primary observations. Only the primary observations for
the day will save to Today's notes.

Adding observations via other clinical functions in Bp Premier (for example, adding a BMI via Clinical > BMI) will
enter the observation into the primary set of observations for the day.

Add medical exemptions for immunisations

Medical contraindications and natural immunities can now be uploaded to the Australian Immunisation Register
via Bp Premier using the Add medical exemptions screen.

To access the Add medical exemptions screen from the patient record, select View AIR in the immunisations sec-
tion, and select either theMedical contraindications or the Natural immunity tab.

Set text for outgoing emails

In Orchid, custom text can be added to the body of outgoing emails. The limit for custom outgoing email text is
500 characters.

If set, outgoing custom text will apply to all emails sent from the practice, and will be the same text for all pro-
viders.

You may wish to use outgoing email text to include information in your emails such as:

practice details (address, phone number, email address)
privacy disclaimer
a 'no reply' message, for example: 'This email address is not monitored. If you need to contact us, please call
us on 07 xxxx xxxx.'
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Improved patient search

When using the Patient list (F10) or Open patient (F2), when creating or finding an appointment, creating
patient accounts and viewing patient billing history, patients can now be searched for using the following inform-
ation:

first name
last name
combination of last name and first name
preferred name e.g. surname, preferred Name
home phone number
work phone number
mobile number
email e.g. admin@brisbanestreetpractice.com
home address
postal address e.g. 1 Brisbane Street
record number
preferred name
Medicare number
IHI
postcode
date of birth e.g. DD/MM or DD/MM/YYYY, 02/01/91.

Internal message search functionality added

In the Messages window, internal messages can now be searched for by message subject, from user (unless
searching on sent messages), sent to user, or patient.

Messages can also be sorted by message date, from user or patient, in ascending or descending order.

Email invoices and receipts directly from the patient and account billing history

Invoices and receipts for privately billed accounts can now be emailed directly to patients and contacts from the
patient billing history and account holder history screens.

A contact note will be automatically recorded if an email has been successfully sent. This contact note will
record that the invoice was sent via email and will contain the patient name and email address used.
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Bp Cloud Connector

A new component of Bp Premier, Bp Cloud Connector, will be installed as part of the installation or upgrade to
Orchid. Bp Cloud Connector is a core component that will support cloud services available in future releases of Bp
Premier and other Best Practice Software products that may integrate with Bp Premier.

As part of Bp Cloud Connector, two new Windows Bp services will be installed:

Best Practice Field Controller
Best Practice Field Recovery Agent

Other enhancements

Bp Function Release Notes Key

Webview2 Issues were experienced with Webview2, the third-party application used to view
documents in Bp Premier. In Orchid, we have rectified the identified issues and built
additional resilience into the document viewing process in Bp Premier.

71180/71144

Online
Claiming

Programmatic changes have been made to support the claiming of MBS item 294. 70843

System
Requirements

When updating Bp Premier or performing a fresh install .NET Framework 4.7 will now
be installed.

70548

Supplied
queries

The supplied query Patients with no allergies or nil known recorded has been edited for
improved accuracy.

67841

Online help A new 'lightbulb' icon is available from the toolbar on main Bp Premier screens that will
open the Bp Premier Knowledge Base in the default browser.

58127

Bp eMail You can now choose whether or not PDF documents attached to emails are PIN
protected by default via Setup > Preferences > General

69524

Bp eMail When sending an email from the patient billing history, the email template will now
include the ABN. The claim number will now be included on the email template for
emails sent from the account holder history. For invoices sent to someone other than
the patient, the greeting will default to 'To whom it may concern.'

70247

Bp eMail The Email Sending Window that appears for the duration that an email is being sent is
now modal, allowing the user to interact with Bp Premier immediately after sending an
email.

Sending an email from the patient record now records a contact note.

69682

Bp eMail When using the Practice email account to send emails from the patient billing and
account holder history, the logged-in location will now appear in the from field rather
than the sender's name.

70076
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Bp Function Release Notes Key

eOrdering When merging an existing eOrdering contact with an eOrdering provider via View >
Contacts > Setup > E-ordering, the existing lab's preferences will be retained.

If more than one existing lab is being merged with an eOrdering provider, one lab can
be selected. The user preferences and eOrder path for the selected lab will be retained.

59449

Healthlink When the word processor is opened from the patient record, clicking the Healthlink
Smartform icon opens the list of available Smartforms.

32672

Immunisations The patient's immunisation list can be filtered by disease using the Filter by disease
drop down menu. All diseases that the patient has been immunised for will appear in
the menu, ordered alphabetically.

64133

Immunisations Immunisations that were sent to the AIR prior to upgrading to Medicare Web Services
now have Sent listed in the AIR Status column.

69104

Installer The list of operating systems compatible with Bp Premier has been updated in the
installer.

68272

Installer The Medicare online claiming client adaptor install logic has been removed. 69762

Medicare Web
Services

Medicare Web Services errors are now encrypted when logged. Any Medicare Web
Services errors logged without encryption via previous Bp Premier versions are
removed.

68854

My Health
Record

Special characters can now be uploaded to My Health Record without causing an error. 44520

Patient
demographic

A prompt will now appear when saving patient demographic information if the HI
number is unverified.

64024

Patient
demographic

You can now choose to perform HI lookups and validations via an existing HI number
(validations only), or via Medicare or DVA number (lookups and validations).

64026/64032

Patient record When the patient record is opened, the patient's IHI number is automatically validated. 61582

Patient record Multiple observations are catered for in other areas of Bp Premier that display or
collect observation information.

68233

Patient record Using the location AIR Provider Number, users can upload immunisations to AIR via
Medicare Web Services, allowing AIR payments to be recorded against the practice
location rather than the specific provider.

69671
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Bp Function Release Notes Key

Social and
family history

Additional options are now available when recording sexuality in the family and social
history screen in the patient clinical record.

Asexual
Gay
Lesbian
Pansexual
Skoliosexual
Queer

58947

Patient
verification

When a bulk patient verification is performed via the appointment book, the patient's
Verified status in the patient demographic now changes to the show the current date.

67368

Preferences A new option has been added to Setup > Preferences > General that enables a prompt
to appear in the Finalise Visit window when you replace an existing item number with
a new item number.

68518

Prescribing Printed scripts for S8 and S4 drugs will contain the patient’s Date of Birth where
required by the state’s Department of Health, based on the prescribing provider’s
Usual Location (not the logged-in location at time of prescribing).

67640/70053

Prescribing Navigation in Consumer Medicines Information is working correctly. 68457

Reports The Payment by Payment Method Grouped by Payment date report no longer prints an
extra page due to the edge of the report being cut off.

55486

Search Utility When an SQL query is run via Utilities > Search, the query is logged in an audit table. 24369

Utilities The Bp Backup utility has been updated to put databases into SINGLE_USER mode
before restoring.

32944
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Bug fixes

Bp Function Release Notes Key

Tyro EasyClaim If the date of claim in Bp Premier differs from the lodgement date that Medicare
stores due to different time zones, Bp Premier will now reconcile the claim if the
payment and processing reports are correct.

69712

Online Claiming If the date of claim in Bp Premier differs from the lodgement date that Medicare
stores due to different time zones, Bp Premier will now reconcile the claim if the
payment and processing reports are correct.

70828

eOrdering Pathology Contacts with an EORDERLABID and/or NATACODE greater than 0 in
CONTACTS table no longer results in fatal errors when opening a pathology
request.

Callstack indicator:

CREQUESTPAGE:SETEORDERMSHDETAILS Line: 20

70486

Patient Health
Summary

When printing a Patient Health Summary from the patient record using the File
> Print Health Summary, if the Health Summary contained any PDF's, JPG, PNG,
or HTML files, the files would print on an empty page with the text "PK". These
are now printing correctly.

70350/

69091

HI Lookups A fatal error no longer occurs when performing HI lookups in certain situations.

Callstack indicator:

DEMOGRAPHICSWINDOW:VALIDATEHI Line: 156
DEMOGRAPHICSWINDOW:LOOKUPHI Line: 192

64622

Installer When Setup 3rd Party is unticked in the installer, the third-party setup window
no longer appears.

70229

Contact Notes The fields can now be navigated through in the Contact List by using the tab key
in a logical order.

58292

Sessions Users will no longer be able to save a standard session or create extra sessions
with a blank length. A prompt will now appear asking the user to select a length
for the session.

59804

Online Claiming When printing a processing report with no data, an error will no longer occur.
The user will now be prompted to choose a report to print.

61522

WorkCover QLD When sending an account to WorkCover QLD, the account will now use the
Billed to user's ABN. The Location ABN will be used if the user does not have an
ABN recorded. If the Location doesn't have an ABN recorded, it will use the
Practice ABN.

68280
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Bp Function Release Notes Key

Patient Record When closing the Utilities > Deleted Clinical Data window, the patient clinical
record will now refresh if opened.

68692

Online claiming The column headings will now display correctly when printing the Online
Claiming list from Management > Online Claiming > File > Print list.

69120

Patient Record Users will no longer be able to save immunisation batch details if no expiry date
has been entered.

69297

Patient Record When opening the patient record, an error will no longer occur for
immunisations where the AdministeredBy and/or CreatedBy was recorded by a
user not at that practice.

69624

BP Utilities Bp Utilities > Restore missing note — Visits that were not saved and closed
prematurely now have a status other than 'Blank' to show that the notes
contain content.

61505

e-Ordering Selecting Help > About from the Contacts window now launches the correct
About Bp Premier window.

69483

e-Ordering The ORM file is now successfully saved to the selected directory when creating
an eOrder for pathology or radiology.

70075

Invoices The Notes from provider field in Account Details no longer appears blank after
storing or holding an invoice.

69425

Online claiming Service details, when adjusting an Online Claiming service, allowed you to
exceed 50 characters, which could result in an error resending service to
Medicare. This is fixed.

69247

Patient claiming The error message when claiming 'Object reference not set to an instance of an
object' is now more informative.

69159

Online verification Bulk OPV Check was failing for every patient after encountering an Invalid
Medicare Card Number from an imported patient record. This has been fixed.

68808

Prescribing Selecting an alternate availability for a drug in New Rx now shows information
from the correct PBS listing.

50054

Reports Management reports now display all DVA item codes correctly. 18884

Appointment book The correct user is now listed in the Cancelled appointments screen when
appointments are moved or cut.

67768

Billing DVA item number OT80 can now be billed. 68367

Billing If a private account with custom items is created for a user who has Requires a
referral for Medicare billing ticked in the New user or Edit user screen, a
referral prompt no longer appears.

67313

Configuration Fixed an issue where in some circumstances, the value in theMax document
database sizemenu in Setup > Configuration > General was not correct.

67531
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Bp Function Release Notes Key

Electronic prescribing When re-prescribing an electronic prescription token from the current Rx screen
using MediSecure, the correct bar code is now included on printed tokens.

64676

eOrdering The eOrdering setup screen now works correctly for users with the user
categories Contract Doctor, Registrar, Senior Receptionist, Junior Receptionist or
Receptionist.

69132

Electronic prescribing A provider's first name field in the Edit user details screen no longer needs to be
completed in order to send electronic prescriptions. This is useful for providers
who do not have a legal first name.

65207

HealthLink Forms When opening HealthLink forms, the error message 'Failed to authenticate the
request with sessionKey' no longer appears.

68899

HealthShare
Directories

The Send eReferral button in the HealthShare window now works as expected. 69003

Immunisations If an immunisation was 'given by' a user without a provider number, and the
'Billing provider' is registered at a location that the 'given by' user does not have
access to, an error no longer occurs.

Users without an individual provider number are now able to send
immunisations to the AIR via Utilities > Australian Immunisation Register.

69067

Inbox When a patient record is opened from the Inbox, the patient record no longer
closes if the Inbox is closed.

63425

Medrefer An error no longer occurs when using Medrefer sign up or sign in functionality. 68676

Medicare Web
Services

When updating a Minor ID, Bp Premier will now check if a PRODA B2B device is
registered and active with the existing Minor ID. If a device is registered and
active with the existing Minor ID, a prompt will appear indicating that changing
the Minor ID will remove the PRODA B2B device.

67104

Medicare Web
Services

The View MWS Log utility now works correctly. 69462

Online claiming When sending a batch via online claiming and a validation error occurs, a single
invoice can be unticked correctly.

68582

Online claiming A certificate store no longer needs to be set up for the practice to be able to
send batches.

68388

Patient demographic If the patient demographic is opened and the IHI is checked and a match is
returned but with a different IHI status (either Deceased, Retired or Expired) the
IHI status in now updated to blank and unverified.

69187
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Bp Function Release Notes Key

Prescribing Fixed an issue where complex instructions for prescriptions were printing twice
on drug sheets and health summaries.

68141

Prescribing The new term Regulation 49 had reverted back the old term Regulation 24 in
Saffron SP3. This has been fixed.

68323

Reports Management reports now show the correct number of items completed within
a date range. If the report includes adjustments completed within the date
range for items completed outside the date range, Then these items are not
subtracted from the item count.

68688

SQL search When running an SQL query via Utilities > Search, the query now uses a read-
only SQL login. This resolves an identified security issue.

24371

Templates The correct referring doctors are now printed on letters when performing a mail
merge.

65345

User category If a provider has the category of Contract Doctor or Registrar, the status column
now populates correctly in Setup > Users.

69107

User category Healthlink forms can now be submitted by users with the Contract Doctor or
Registrar user category. The Provider column no longer shows No
provider/non-clinical for users with the Contract Doctor or Registrar user
category.

69142
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Known issues

Bp Function Issue Fixed In Key

TX Control When trying to view a corrupted document type, the TX Control may encounter a
rare fatal error, which prevents it from being displayed in Bp Premier.

Callstack indicator: BPDOCUMENTVIEWER:VIEWFILEONDISK Line: 16

Workaround: If you encounter this issue, right-click the file and select Export to
save the file outside of Bp Premier, You can then view the file externally using an
appropriate application such as Microsoft Word or Adobe PDF Reader.

Orchid
SP1

70873

Online
Claiming

Where there has been an underpayment from Medicare as a result of a derived
fee calculation, batches may reconcile with payment records created; however,
the services are left in a Sent (not paid) status.

Workaround: If you encounter this issue, right-click on the reconciled batch
where there are services are marked as Not paid and select get processing report.
This will reset the batch and place it in a Received status, allowing you to
reconcile with Accept fee of.

Not yet
resolved

71109

Legacy
eOrdering

Pathology eOrders created for legacy Douglass Hanly Moir eOrdering contacts will
no longer have the DHM prefix on ORM files after upgrading from a previous
version to Orchid.

Workaround: We recommend merging legacy eOrdering contacts on the Setup >
eOrdering > Existing eOrder Contacts Detected screen to prevent this issue. See
Merge eOrdering provider contacts for more information.

Orchid
SP1

-

Bp Email Invoices and receipts sent via email from a Terminal Server with TLS disabled may
appear blank.

Orchid
SP1

71621
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