
Bp Premier Orchid SP2 Release Notes
These release notes describe the changes made to Bp Premier since Orchid SP1 build 1.12.1.1018.

Release Date 27 June 2024

Release version Bp Premier version Orchid SP2 1.12.3.1042.

Notes last updated 27 June 2024

Which version can I
upgrade from?

You can upgrade to version Orchid SP2 (1.12.3.1042) from Bp Premier version Saffron
SP3 (1.11.3.968/1.11.3.974) or later. To check the current program version that you have
installed, select Help > About.

Which data update do
I need?

You must install the February 2024 Data Update or later before you can upgrade to
version 1.12.3.1042. However, Best Practice Software recommend making sure you have
the most recent Data Update installed before you run a program upgrade.

Which database and
operating system versions
are supported?

Windows operating system Windows 10 or higher is supported. Microsoft Windows
Server 2012 and higher is supported. Microsoft SQL Server 2016 and higher is supported.

When should I upgrade? Best Practice Software recommend running the program upgrade outside of business
hours.

How do I upgrade? Brief upgrade instructions are included in this document.

Copyright Statement

This material is classified as commercial-in-confidence. Unauthorised distribution of this information may constitute a breach of
our Code of Conduct, and may infringe our intellectual property rights. This information is collected and managed in accordance
with our Privacy Policy, available on our website. © Copyright 2024.
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Upgrade to Orchid SP2 1.12.3.1042

You must have the February 2024 data update or later installed before you upgrade to 1.12.3.1042.

1. Back up your Bp Premier database before running the upgrade.
2. Synchronise all workstations in remote database mode with the Bp Premier server before you upgrade.
3. Download and run the latest Drug Update on your Bp Premier server computer.
4. Log all users out of the server and all clients before you upgrade.
5. Download and run the 1.12.3.1042 update on your server and all clients.
6. Log back in to Bp Premier and resume use.

Upgrade notes

Orchid Service Pack 2 contains all the features included in Orchid Service Pack 1
Revision 1

Orchid Service Pack 1 Revision 1 includes changes associated with:

n Security Enhancements for BP Browser SQL Logins
n Mandatory AIR Vaccination Encounter Reporting Changes starting 1 March 2024
n Enhancements to support Level E Consultation Item Numbers.
n Enhancements to help capture patients who have registered for MyMedicare.

For further details, view the Orchid Service Pack 1 Revision 1 Release Notes.

Orchid Service Pack 2 requires Microsoft .NET Framework 4.8

Bp Premier version Orchid Service Pack 2 requires Microsoft .NET Framework 4.8 to operate successfully.

If you are running an older version of Windows, Best Practice Software recommends that you consult your IT
provider to consider upgrading your operating system before upgrading Bp Premier.

See Bp Premier System Requirements for more information.

Where do I find more information?

Select from the main screen of Bp Premier or select Help > Online from Bp Premier to open the Knowledge
Base from any main screen toolbar.
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New Features

The future of healthcare is coming! Lyrebird is available in Bp Premier

Lyrebird uses artificial intelligence to revolutionise medical scribing. Lyrebird helps healthcare professionals to
save time and improve patient care.

With Lyrebird, you can automate patient notes with a fully integrated AI Medical Scribe specially engineered for
clinical environments. With Lyrebird, start recording from the patient record and complete your consult, and
Lyrebird will generate clinical notes in a standard format, ready for one-touch write-back into Bp Premier.

Manage Payment Integrations

The configuration menu in Orchid SP2 has been redesigned, and a new tab for managing Payments Integrations
has been added. As part of the Payment Integration changes, configuration through the Tyro Setup.exe utility has
been deprecated; CommBank Smart Health and Tyro can now be activated and configured by navigating to Setup
> Configuration > Payments.

Payment Integrations available in Bp Premier are:

n HICAPS
n Tyro
n CommBank Smart Health

Payment integrations configured prior to upgrading to Orchid SP2 will remain active and will be set as the default
payment integration.

HICAPS now integrates with Bp Premier

We are excited to announce our new partnership with HICAPS which will provide our Practices with the following
integrated functionality:

n integrated Medicare Easyclaim
n integrated Medicare Online
n integrated EFTPOS
n integrated EFTPOS Refunds

These new features are currently being piloted and are hidden until the completion of the pilot phase. Practices
will be notified by email when the HICAPS integration is publicly available.

Enhancements to the Cardiovascular Risk Assessment Tool

When accessing Clinical > Cardiovascular Risk from the patient record, an embedded browser will open the
Australian Chronic Disease Prevention Alliance's CVD Risk (AusCVDRisk) calculator. AusCVDRisk is a
comprehensive tool designed to assist health professionals in assessing, communicating, and managing
cardiovascular disease risk.
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Improvements to the Patient Demographics screen

The patient demographics screen has been enhanced to capture information regarding the patient's Preferred
Language, Interpreter requirements, and Country of Birth.

When recording Preferred Language, the top ten languages recorded by the Australian Bureau of Statistics will
display at the top of the drop down menu, followed by an alphabetical listing of all other languages.

When recording Country of Birth, the top ten Countries of Birth recorded by the Australian Bureau of Statistics
will display at the top of the drop down menu, followed by an alphabetical listing of all other countries.

When the Interpreter check box is ticked, users will be notified that an interpreter is required when adding,
viewing, or editing appointments, arriving, or starting visits from the appointment book and in the patient's
clinical record.

Permissions to control access to Patient Bank Account Details

Orchid SP2 introduces enhanced control over the management of Patient Bank Account information. We've
added a new permission type called Patient Bank Account, which gives you greater control over who can View,
Add, Edit, or Delete these details.

Permissions to send emails from the Practice Email account

Orchid SP2 introduces enhanced control over Practice Email accounts. We've added a new permission type
called Send Email on behalf of Practice, which gives you greater control over who can send emails using the
shared Practice email account.

When you upgrade to Orchid SP2, the Send Email on behalf of Practice permission will be set to Allow access by
default.

Bp Email supports Modern Authentication (OAuth2.0) for Gmail and Microsoft 365

Open Authorisation 2.0 or OAuth2.0, is a standardised protocol that enables secure access to user data without
requiring the user to disclose their credentials. OAuth2.0 is the recommended method for securely connecting
yourMicrosoft 365 and Gmail accounts to Bp Email.

Argus Integration and National Health Services Directory Updated

The Argus API integration has been updated to support version V7; the functionality that restricted it to V6 has
been removed.

The National Health Services Directory (NHSD) is a comprehensive national directory of health practitioners
and services. Bp Premier users with an active Argus subscription can access the National Health Services
Directory (NHSD) from the main Bp Premier screen, View > Contacts > Directory.
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Schedule SQL Index Rebuild to run Automatically

The SQL Index Rebuild utility can now be scheduled to run automatically using the Bp Service.

The SQL Index Rebuild utility rebuilds the internal indexes of the SQL database. Rebuilding indexes can improve
index fragmentation and have a considerable impact on database maintenance and performance, lowering the
risk of performance degradation and IT support time or expense.

Enhancements allow users to repair Suspect Databases

A Suspect Database occurs when one or more SQL databases are identified to be potentially corrupt or
unavailable. When the Bp Premier database starts up, SQL will perform a series of checks to confirm data
integrity. If these checks identify any potential issues the individual database is marked as Suspect.

By selecting the Repair button on the Suspect Database error in Orchid SP2, users will be able to initiate a
Database Console Command (DBCC) consistency check on the database server without having to contact Bp
Premier Support for assistance in resolving the error. This will significantly reduce the length of time Bp Premier
is offline, allowing your practice to resume operations as soon as possible.

Other enhancements

Bp Function Release Notes Key

Clinical Tools When accessing Clinical > Cardiovascular Risk from the patient record, an
embedded browser will open the Australian Chronic Disease Prevention
Alliance's CVD Risk (AusCVDRisk) calculator.

73382

Lyrebird Health
The embedded Lyrebird Health browser is accessible via a newly added icon
to the toolbar within the patient record.

73850

Lyrebird Health A new button labelled Lyrebird Health has been added to the Setup > Users >
Edit.

The Lyrebird Health button will be available for users with Add/Edit/Delete or
Add/Edit permissions for Clinical Notes.

To connect Lyrebird Health to Bp Premier, enter the user's Lyrebird Health API
Key in Setup > Users > Edit > Lyrebird Health.

73854

Lyrebird Health When clicking Save to Bp from the Lyrebird Health browser, initial and review
consult notes generated by Lyrebird will write back to the Today's notes section
in the patient record.

73851

Lyrebird Health When the Lyrebird Health button is pressed in the patient clinical record and
WebView2 disabled, the user will be prompted to contact Bp Premier Support to
activate WebView2 to access Lyrebird Health within Bp Premier.

74353
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Bp Function Release Notes Key

Lyrebird Health A new stored procedure (BP_AddObservation) and supporting user-defined table
(BP_ObservationsTable) have been created to allow Lyrebird to add primary or
secondary observations to the patient record.

A new Stored procedure (BP_UpdateLyrebirdConsent) has been created to allow
Lyrebird to add or update patient consent for Lyrebird recordings.

74685 /
74441

Lyrebird Health Bp Premier allows you to open multiple patient records simultaneously, and from
each patient record, you can launch an associated Lyrebird Health browser. To
bring the Lyrebird Health browser into the foreground for the associated patient,
click the Lyrebird Health icon from the toolbar of that patient record.

73852

Best Health Booking BHB customers who wish to prevent specific Patients from scheduling
appointments via BHB can select the check box Don't allow patient to book via
BHB in the patient demographic window.

71167

Best Health Booking When adding or editing the Appointment type in the Lists tab of Setup >
Configuration, the following options will appear:

n Allow multiple bookings per appointment slot check box.
n Maximum number of appointments allowed label textbox.

72343

Best Health Booking After upgrading to Orchid SP2, two columns will be added to the
AppointmentTypes database to accommodate GroupBooking and MaxGroupSize;
both will be disabled.

72342

Australian
Immunisation Register

When submitting a vaccine to AIR and the user has not entered the Vaccine Type
and the vaccine selected requires a Vaccine Type to be specified, the user will be
prompted to enter a Vaccine Type when clicking Save.

74745

Australian
Immunisation Register

Unless the user explicitly selects a vaccine from the list of available vaccines, no
vaccinations will be highlighted or selected by default when a new immunisation
is added.

74348

Bank Accounts Multiple payment integrations can now be configured against a single bank
account in Setup > Configuration > Bank Accounts.

73404

Payment Integrations HICAPS payment integration has been toggled off for the initial Beta release
testing phase.

73768

Payment Integrations The Configuration menu has been redesigned, and a new option for managing
payment integrations has been added.

HICAPS, CommBank Smart Health and Tyro can be enabled in Setup >
Configuration > Payments.

72415

Payment Integrations The HICAPS integration forMedicare Easyclaim has been activated between Bp
Premier and Bp Payments Utility.

73441

Payment Integrations The HICAPS integration for Processing Payments has been activated between Bp
Premier and Bp Payments Utility.

73322 /
73319

Payment Integrations Practices with multiple payment integrations enabled can configure a default
payment integration.

72443
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Bp Function Release Notes Key

Payment Integrations Configure the default HICAPS Terminal ID (TID) for practice and provider bank
accounts in Setup > Configuration > Bank Accounts.

For practice bank accounts, a Global Default Terminal IDmust be selected;
however, it is not mandatory to assign a default HICAPS Terminal ID for provider
accounts.

Where a payment provider has no default Terminal ID specified in Setup >
Configuration > Bank Accounts, the following will apply:

n If the default Terminal ID of a provider is not specified, the workstation's
default Terminal ID is used.

n If a default Terminal ID is not specified for the workstation, the practice global
default Terminal ID is used.

72828

Payment Integrations Submit fully or partially paid private accounts to Medicare using the HICAPS
Integrated Easyclaim solution.

73440

Payment Integrations Submit unpaid private accounts to Medicare using the HICAPS Integrated
Easyclaim solution.

74566

Payment Integrations Refund EFT payments directly from Bp Premier using HICAPS Integrated EFTPOS. 72762

Payment Integrations When HICAPS is selected as the payment integrator in Setup > Configuration >
Bank Accounts clicking Authenticate will launch the Bp Payments Utility
Authentication window.

73400

Payment Integrations Deposit transactions can now be processed using the HICAPS terminal. 73876

Payment Integrations For greater visibility over the Payment Integrations that can be configured in Bp
Premier they have been grouped under Setup > Configuration > Payments.

72413

Payment Integrations When upgrading to Orchid SP2, the installer will prompt users to install the Bp
Payments Utility on the server and workstations where HICAPS or Commbank
Smart Health will be used.

73112

Payment Integrations The Bp Payment Utility can be downloaded and installed through the Setup >
Configuration > Payments. If API actions are performed without the Bp Payment
Utility installed or running, a pop-up message will be displayed.

72914

Payment Integrations In the Setup > Configuration > Payments screen, the check box label for Activate
Integrated EFTPOS has been changed to Activate Payment Integration for
HICAPS, Tyro and CommBank Smart Health.

73101

Payment Integrations To provide greater visibility on which payment integrations are configured for
each bank account in Setup > Configuration > Bank Accounts, the MID column
has been replaced with a new column called Integrated, allowing users to quickly
identify which payment integrators are linked with each bank account.

73329

Payment Integrations The Payment Integration Transactions window, formerly known as the Tyro
Transactions window, now includes transaction information for Tyro and HICAPS.
To access Payment Integration Transactions, navigate toManagement >
Payment Integration Transactions on the Bp Premier main screen.

72764
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Bp Function Release Notes Key

Payment Integrations A new check box, Show refunds, has been added to theManagement > Payment
Integration Transactions screen to increase visibility on EFT Transactions
refunded via the HICAPS payment integration.

73102

Payment Integrations When a Tyro or HICAPS payment integrator is deactivated in Setup >
Configuration > Payments, no configuration or bank account information is
removed from the Bp Premier database. The stored configuration details will be
restored if the payment integration is reactivated.

When an HICAPS payment integrator is manually removed from Setup >
Configuration > Bank Accounts, the user is notified that they will need to re-
authenticate with the payment integrator in the future if they want to use it with
this bank account.

73516

Payment Integrations The HICAPS terminal status window in Bp Premier has been enhanced and will
now display:

n The previous terminal screen updates in the HICAPS terminal status window.
n The purchase / refund amount.
n The transaction type: Purchase / Refund / Medicare Easyclaim / Deposit.

74625

Payment Integrations When connecting to the Bp Payments Utility via a remote session, the local
machine name (the one from which you are connecting) is saved in the Bp
Premier database.

When connecting via a remote session and configuring the HICAPS terminal for
Practice Bank Accounts, the local machine name will be displayed in the list of
workstations (the one from which you are connecting).

74787

Payment Integrations Tyro Setup.exe has been deprecated as part of the Payment Integration changes
and will no longer be deployed during the Bp Premier installation process.

72991

Payment Integrations When a Medicare Easyclaim transaction is processed via the HICAPS terminal and
the claim is approved by Medicare, a successful message is retrieved from the
notifications cache, and the HICAPS status window is displayed to the user via the
Bp Payments Utility, prompting the user to confirm Yes or No on whether
the customer rebate was completed successfully.

n If the user clicks Yes, the Payment Details screen will close, and the Payment
Integrations Transactions screen will show a Success status.

n If the user clicks No, the HICAPS status screen closes, and the user will be
returned to the Payment Details screen, with an Error recorded in the Pay-
ment Integrations Transactions screen.

74814

Payment Integrations The Bp Payments Utility now includes a Cancel Transaction button, which allows
users to cancel HICAPSMedicare Easyclaim transactions.

73450

Patient Demographics On the Patient Demographics screen, you can now specify whether the patient
requires an interpreter and their preferred language. The top ten languages
recorded by the Australian Bureau of Statistics will appear at the top of the drop
down menu, followed by an alphabetical listing of all other languages.

72097
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Bp Function Release Notes Key

Patient Demographics The Patient's Country of Birth can now be specified on the Patient Demographics
screen. The top ten Countries of Birth recorded by the Australian Bureau of
Statistics will appear at the top of the drop down menu, followed by an
alphabetical listing of all other countries.

72094

Patient Demographics When the Interpreter check box is selected, the user is notified that an
interpreter is required when adding, viewing, or editing appointments, arriving,
or starting visits from the appointment book and in the patient clinical record.

72110

User Permissions User Permissions can now be sorted alphabetically. 72553

User Permissions A new user permission called Patient Bank Account has been added to restrict
who can view, edit, or delete a patient's Bank Account details.

72555

User Permissions A new user permission called Send Email on behalf of Practice has been added to
control access to sending emails from the Practice Email account. Upon upgrade,
the default setting for the Send Email on behalf of Practice permission will be
Allow access.

72852

User Permissions A new user permission called Bp Browser Access has been added to limit who
can access the Bp Browser tool. By default, this permission is set to 'No Access.'

72749

Word Processor The patient's country of birth, preferred language, and interpreter requirements
have been added to the word processor's data fields.

72096

Active Ingredient
Prescribing

The XML payload fields of <PrescribedItem_Reserved_03> and
<TherapeuticGoodIdentificationDisplayName> have been updated to replace
escape characters '&#xD;' with commas.

72185

Prescribing Providers will no longer be prompted to handwrite drug details on printed S4 and
S8 prescriptions in Queensland, Western Australia, South Australia, the Australian
Capital Territory, and the Northern Territory.

Handwritten drug details are still required for printed S4 and S8 scripts in New
South Wales, Victoria and Tasmania.

72277

Prescribing When creating a script, if you tick or untick the Consent to Upload to ASL check
box and switch between the New Rx screens, the consent to upload to ASL check
will remain ticked/unticked.

72204

Prescribing ACT Health will mandate the inclusion of the patient's date of birth on all
Schedule 4 and Schedule 8 prescription drugs, including private prescriptions
from mid-2024. To ensure that prescribing providers are not impacted by this
change, the patient’s date of birth will be printed on all Schedule 4 and Schedule
8 prescription drugs, where required by the state's Department of Health, based
on the prescribing provider's Usual Location (not the logged-in location at the
time of prescribing).

74801

Online Claiming Programmatic changes have been made to support the claiming of MBS item
46100.

73029

Online Claiming When you click Adjust Service in Online Claiming, the service text is now pre-
validated before being transmitted to Medicare.

72490
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Bp Function Release Notes Key

Third Party Integration The Argus API integration has been updated to support V7; the functionality that
restricted it to V6 has been removed.

60983

Configuration The database browser password and button have been deprecated and replaced
by Third-Party Backups. Setting a database backup password allows database
backups to be performed using the BPSBackup login.

72748

System Requirements Bp Premier version Orchid Service Pack 2 requires Microsoft .NET Framework 4.8
to operate successfully.

69886

Installer The Orchid SP2 program update installer will no longer provide details on Online
Claiming and will only display the Bp Payment Utility. In the Prescription
exchange provider section of the installer, MediSecure will no longer be shown;
only eRx will be displayed.

73454

Bp Email To improve the user experience, the OAuth2.0 sign-in procedure has been
updated to better handle the cancellation/closure of the OAuth2.0 window; Bp
Premier will no longer wait for an unfinished process.

73085

Bp Email Google (like Microsoft) has withdrawn support for Basic Authentication, which
requires a user name and password. We have introduced OAuth2.0 support for
Gmail accounts to ensure these changes do not impact Bp Premier customers.

69714

My Health Record The Organisation Logic in CDA and SOAP requests, used for My Health Record
CDA creation and upload functionality, has been updated.

73078

HealthLink Online Form HealthLink Online Forms started from the patient's clinical record via View >
HealthLink forms or the New HealthLink form icon will add a comment to the
patient's Today's notes when the form is parked or sent during the same visit.

71969

HealthLink Online Form When a Healthlink Online Form is parked and subsequently submitted during the
same visit, the Action in Today's notes will update from Created and saved as
draft to Created and sent.

Where the form was parked in a previous visit, when the form is parked or
submitted, a corresponding progress note is saved to Today's notes.

73484

Halo Link When installing the Orchid SP2 program update or the full ISO installer, Halo Link
will not be installed if the InstallHalo registry value is set to 0. If the InstallHalo
flag does not exist or is not equal to 0, Halo Link will be installed silently.

73092

Suspect Databases A Suspect Database occurs when one or more SQL databases are identified to be
potentially corrupt or unavailable. When the Bp Premier database starts up, SQL
will perform a series of checks to confirm data integrity. If these checks identify
any potential issues the individual database is marked as Suspect.

By selecting the Repair on the Suspect Database error in Orchid SP2, users will be
able to initiate a Database Console Command (DBCC) consistency check on the
database server without having to contact Bp Premier Support for assistance in
resolving the error.

74042

Bp Utilities The SQL Index Rebuild utility can now be scheduled to run automatically using
Bp Service via Setup > Configuration > Bp Service.

65255
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Bp Function Release Notes Key

Bp Utilities The Bp Script Runner utility has been updated to accommodate new Orchid SP2
code changes.

73665

Patient Import
/Export Utility

When exporting or importing the patient's clinical record, the patient's Country of
birth, Preferred language and Interpreter required fields will be exported or
imported.

72194

Msg Queue (MSMQ) Improvements have been made to the automatic internal message notification
that occurs when Bp Premier fails to Contact the Message Queue Processor to
specify the name of the affected machine.

73419

Msg Queue (MSMQ) A new option,Message Queue check delay, has been added to Setup >
Configuration > General, allowing Practices to delay the automated check for
Message Queue connectivity that occurs when logging in to Bp Premier.
Increasing the value in this field will give the Message Queue Processor check
more time to complete.

73411

Active Script List Bp Premier has been optimised to improve performance when obtaining ASL
tokens.

73563

Active Script List Prescriptions created prior to upgrading to Saffron will not have any Consent to
upload to ASL options recorded and will not be visible in MySL when
represcribed. In Orchid SP1 Revision 1, providers will be provided with the
opportunity to provide Consent to Upload to ASL when represcribing
prescriptions that were created prior to upgrading to Saffron.

73992

Banking Batches The Banking Batch window will no longer be locked if users attempt to use it
from multiple logged-in locations. When a payment is already processed as part
of an existing Banking Batch, no new Banking Batches are created; instead, the
user is prompted that ‘Some details of the bank batch have changed. Please
recreate the banking batch to view the updated unbanked payment details.'

73549

Bp Comms To support the September 2023 ACMA industry code changes, unless a custom
Alpha Tag has been registered and whitelisted by the Best Practice Sales Team,
the default value of Alpha Tags will be set toMyPractice.

The Alpha tag fields in the following areas will be greyed out, disabled, and
cannot be modified:

n Setup > Configuration > Bp Comms > Configure SMS
n Setup > Practice Details > Practice Locations

74406
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Bug fixes

Bp Function Release Notes Key

Best Health Booking Resolved an issue where, after the patient matching workflow, the Appointment
Details screen displayed the prior demographic information and overrode the
original matched patient details if the user clicked Save changes.

73639

Best Health Booking An error that prevented the unmatched patient icon from appearing in the
Appointment Day window has been resolved.

72327

Appointment Book When right-clicking in the Daily Message text field in Appointment Book > Daily
Message, a non-fatal callstack error will no longer occur.

Callstack Indicator:

n CRICHEDIT:ONMOUSEBUTTONUP Line: 12
n APPOINTMENTWINDOW:VIEWDAILYMESSAGES Line: 10
n APPOINTMENTWINDOW:UTILITIES_DAILYMESSAGE Line: 6

74500

Waiting Room Resolved an issue where, when adding a patient to the waiting room under 'any
doctor', the appointment failed to link to the doctor once the visit started; the
appointment will now be visible under the doctor who started the visit.

73540

National Cancer
Screening Register
(NCSR)

Resolved an issue where users encountered an Unknown Error when accessing a
new NCSR form using a supported version of Bp Premier; the error prevented
NCSR forms from loading.

75283

Payment Integrations Resolved an issue when performing the Orchid SP2 upgrade where the logged-in
user account had limited access, causing Tyro registry keys to be blank.

77043

Payment Integrations When performing a Tyro Check for Payments, Bp Premier will no longer create a
new bank account record if a bank account with the identical Account No. and BSB
No. already exists.

71964

Payment Integrations Checking for Bulk Bill EasyClaims payments will no longer generate a REPORT_
NOT_FOUND error for Providers whose Provider number has only seven digits.

72121

Billing When account text is determined by the Service date, the correct account footer
will be populated on the email invoice.

71819

Billing An error will no longer occur when clicking Pay All in the Patient Billing and
Account Holder history screens to process bulk payments where there are invoices
with partial payments.

73923

Billing When invoices are printed, providers who have enabled the option 'Display
Payment information on Invoices' in Setup > Configuration > Bank Accounts will no
longer have payment details overwritten on the account details section.

74179

Bp Email When the Enable TLS email check box is not selected, the test connection is not
performed automatically, and no error occurs for SMTP email accounts.

72356
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Bp Function Release Notes Key

Bp Email On the Account Holder History and Patient Billing History screens, clicking Email
without selecting any items will no longer result in an error. The user will be
prompted to choose an invoice or receipt.

Callstack Indicator:

n RECEIPTWINDOW:GETLOCATIONNAME Line: 7

71710

Bp Email When emailing an invoice with multiple payment records on one invoice from the
Patient Billing History, a fatal callstack error will no longer occur.

Callstack Indicator:

n RECEIPTWINDOW:GETLOCATIONNAME Line: 10
n RECIEPTWINDOW:SUBSITUTEFIELD Line: 32

73993

Bp Email When the Enable TLS email check box is not enabled, neither a test connection nor
an error is generated for SMTP email accounts.

72356

My Health Record The Patient Clinical Record will no longer be minimised when the My Health
Record button is clicked.

67255

My Health Record Resolved an issue where when uploading a Shared Health Summary to My Health
Record, an error message displayed if a Medical History item with no recorded
date is selected.

In Orchid SP2, if a Medical History item does not have a date specified, the user
will be prompted with 'Procedure items without a date will not be transmitted to
My Health Record. Please add a date in the Past history section.'

73912

My Health Record Resolved an issue when displaying My Health Record documents in the Patient
Clinical record. A recent Microsoft enforced an XML document attribute that, if
missing, prevented the documents from being rendered correctly. The following
My Health Record documents were affected and failed to display correctly,
appearing blank:

n Medicine View
n Pathology Overview
n Diagnostic Imaging Overview

Orchid SP2 will pre-validate My Health Record Documents and then insert the
missing XML document attribute into the document header, ensuring that the
document is rendered correctly in Bp Premier.

The Australian Digital Health Agency will also address this issue and ensure that
documents generated from My Health Record can be rendered correctly in Bp
Premier.

74188

My Health Record An issue that prevented Terminal Services environments from locating Advance
Care Planning documents when previewing attachment links in My Health Record
has been resolved.

73135

ePrescribing Resolved an issue where practices using eRx were unable to resend eScripts tokens
from past prescriptions via SMS. SMS eScript tokens from past prescriptions are
now successfully delivered via eRx.

73882
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Bp Function Release Notes Key

ePrescribing Resolved an issue where if a prescriber sends an eScript token via SMS, leaves that
patient file open, and then sends another eScript token via another token method,
such as email, the eScript token was still sent via SMS.

73960

ePrescribing Resolved an error where practices that upgraded to Orchid SP1 and completed eRx
registration and configuration received a Bp Comms credit error message when
sending eScripts via SMS. eScripts can now be sent via SMS without requiring a Bp
Comms user name or SMS credits to be available in the database.

73780

ePrescribing When copying from the dose field and pasting it into the Complex Instructions field
in the New RX window, the correct values are now included in the payload when
sending via eScript.

72565

ePrescribing An error no longer occurs when sending eScripts containing </& symbol in the
Reason for the prescription field or any fields related to the drug (e.g., where the
drug name has something like <19%).

69363

Prescribing Resolved an issue where editing the Current RX dose did not populate the
medication and previous dose in Today's Notes.

73379

Prescribing An issue that prevented the 'Interval between repeats (days)' value from being
printed for schedule 4 drugs has been resolved.

74182

Patient Demographics Resolved an issue that prevented the ‘Opt Out De-Identified Data Extraction’
option from saving to the database when a new Patient was added.

71839

MyMedicare Resolved an issue where the green check box for MyMedicare eligibility displayed
in the Account Details window for a previous invoice and when creating a New
Complex Account for patients who are not registered with MyMedicare.

74770

eOrdering When executing the BP.SetupEOrdering.exe via the installer, the utility will
function correctly and run without encountering any errors.

72606

eOrdering Resolved an issue where a legacy imaging contact exists and an enhanced
eOrdering contact with the same name is configured and saved, but the contacts
are not merged; the error occurred when returning to the Setup E-Ordering utility
and attempting to editing the duplicate enhanced eOrdering provider.

Error:

n Exception has been thrown by the target of an invocation.

73773

Australian Immunisation
Register

Resolved an issue that prevented the Send to AIR check box from being selected
when editing an unsent immunisation.

74862

Australian Immunisation
Register

Resolved an issue that prevented the AIR Transmission Status prompt from
appearing when selecting File > View AIR status description in the Australian
Immunisation Register window.

72395

Australian
Immunisation Register

Double-clicking the Send to AIR button will no longer result in a callstack error.

Callstack Indicator:

n VIVASWINDOW:ACIRSEND Line: 173
n VIVASWINDOW:ACIRBUTTON Line: 9

72399
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Follow up Reminders When Bp Comms SMS configuration is not enabled, the Bp Comms Message Status
refresh will not occur, and a callstack error is no longer generated.

Callstack Indicator:

n SMSSOAPCLIENT:CHECKDELIVERYREPORTS Line: 12
n SMSSENDER:CHECKANDCONFIRMDELIVERYREPORTS Line: 7

72353

eReferrals When sending eReferrals through Argus, the Message ID displays the Argus-
assigned messageID rather than the Bp Premier-assigned Message ID.

72821

Database Search Resolved an error where the user did not have permission to search the
patientconsent table via database search.

72302

Patient List An issue has been resolved in which merged patients are displayed in the
enhanced patient search when searched using the DOB year.

74771

Active Script List Resolved an issue where, when selecting the View MySL button, the eScript token
drop down supplied the user contact details instead of the patient's details.

73471

Active Script List Resolved an issue in which the Active Script List Client failed to locate file or
assembly 1.12.1.1016/7.

73164

MediSecure When MediSecure Detector is run, the BP_Premier password is updated and no
longer reverts to the deprecated BP_Administrator Password.

73513

Msg Queue (MSMQ) Resolved an issue where the MSMQ failed to validate computer names that started
with numbers.

73757

HealthLink Online Forms An issue that prevented HealthLink Online Forms from removing records of
sessions that were not properly ended from the HEALTHLINKSESSION table has
been resolved.

Error:

n The object cannot be deleted because it was not found in the
ObjectStateManager.

at System.Data.Entity.Core.Objects.ObjectContext.DeleteObject(Object
entity, EntitySet expectedEntitySet)

at System.Data.Entity.DbSet`1.Remove(TEntity entity)

at BP.HealthLink.Service.HealthLinkService.ClearSessions()

at BP.HealthLink.Service.HealthLinkServiceHost.Main(String[] args)

69557

HealthLink Online Forms Resolved an issue when creating a HealthLink Online Form using the Private
Specialist option, clicking the back and forwards buttons in the browser window
resulted in the error 'Failed to pre-populate for invalid/expired sessions.'

74633
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HealthLink Online
Directory

Resolved an error that occurred when searching for a contact in the HealthLink
Online Directory using a word processor template containing an addressee field.

Callstack Indicator:

n BPSETUPELECTRONICORDERING:CLOSE Line: 2
n MAINWINDOW:ONCLOSE Line: 63

74347

Document Viewer An issue has been resolved in which the margin widths of an RTF investigation
report in the Inbox caused the text to wrap into the next line. In Orchid SP2, when
viewing RTF investigation reports from the Inbox, Correspondence In and
Investigation reports are consistently displayed with sufficient margins to prevent
line wrapping

21885

Pathology and Imaging
Results Import

An issue that prevented some MDM/CDA documents from being imported via the
Bp Service has been resolved, and no callstack errors are generated.

Callstack indicator:

n RESULTIMPORTER:MATCHCDAPATIENT Line: 57
n ALLOCATECDAPATIENT Line: 49

74414

Remote Databases Resolved an issue where client-side remote database instances created before
upgrading to Orchid SP1 Revision 1 generated a call stack error and unsuccessfully
synchronised with the Bp Premier Database Server.

Client-side remote database instances created before upgrading to Orchid SP1
Revision 1 will now synchronise with the Bp Premier database server without
encountering any errors.

Callstack Indicator:

n MAKEJADELOGINCHANGES Line: 41
n CBPREMOTE:TRANSFERDATA Line: 19

74873

Halo Link Resolved an issue in which Halo Link was being deployed to the Bp Premier client
machine; in Orchid SP2, when installing via the program update or the full installer,
Halo Link will only be deployed to the Bp Premier Database Server.

75243
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