
Bp VIP.net Topaz SP1 Rev 3 Release Notes
These release notes describe all enhancements and modifications made to Bp VIP.net since version
Topaz SP1 Rev2.1 (2.1.530.017).

Release Date  5 July 2023

Release version Topaz SP1 Revision 3 (version 2.1.531.054)

Notes last updated 4 July 2023

What is in this release? Bp VIP.net 2.1.531.054 contains bug fixes, new features and enhancements.

Which version can I
upgrade from?

There is no version dependency for upgrading to 2.1.531.054. If you experience
difficulties upgrading from your version, contact Best Practice Software
Specialist Product Support.

Users updating from Topaz Revision 2 (2.1.526.057) or lower will need to
update the .NET Framework to version 4.8 before updating Bp VIP.net. The
operating system and database requirements have not changed since the last
release.

When should I upgrade? Best Practice Software recommend running the program upgrade outside of
business hours to minimise the impact of the upgrade on your practice.

How do I upgrade? Upgrade instructions are included in these release notes.

What do I do after
upgrading?

You do not need to perform any configuration after you upgrade.
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Upgrade Bp VIP.net to Topaz SP1 Revision 3
(2.1.531.054)
You should be able to upgrade to 2.1.531.054 from any version of Bp VIP.net. Users updating from
Topaz Revision 1 (2.1.526.057) or lower will need to update the .NET Framework to version 4.8 before
updating Bp VIP.net. Best Practice Software recommend that the upgrade be performed outside of
normal business hours.

Notes on upgrading

If you did not upgrade to the most recent version Topaz SP1 Rev 2.1 (2.1.530.017), review the
release notes to see the changes in that version.
TheWebview2 install required for Bp VIP.net has been included in the Bp VIP.net installer and
will run silently in the background when users perform Bp VIP.net updates. Best Practice Soft-
ware recommends installing Webview2 manually for users updating Bp VIP.net on terminal serv-
ers. See Download and Install Webview2 for further instructions.
Check the version of Microsoft .NET Framework on the Bp VIP.net server and workstations.
Topaz SP1 Revision 3 requires aminimum .NET Framework version of 4.8.
Copy the install file to and run the upgrade from the SQL Server database computer first. This
will upgrade the Bp VIP.net database structure in preparation for terminal server or workstation
upgrades.
If your practice uses Terminal Services, you must run the installation from the Terminal Server
(after upgrading the database server).
Log in to the Bp VIP.net server computer as a Windows administrator. You may require Win-
dows administrator permissions to install and update some Bp VIP.net components.
After completing the upgrade, Best Practice Software recommends restarting VIPServices.net.
See Configure and Start VIP Services for further instruction.

How to upgrade Bp VIP.net

1. Back up your existing database before upgrading and test that the backup restores successfully.
Information on how to back up and restore your database is available on the knowledge base.

2. To download the Bp VIP.net update file: 
Log into Bp VIP.net as an administrator-level user. Go to Help >What's New. Bp VIP.net will
launch a web browser to the Bp VIP.net downloads page. Select the heading for Bp VIP.net
Topaz SP1 Rev 3 (2.1.531.054) and select the Download button. The setup.zip file will down-
load to the default Windows downloads folder.

3. Before running the Bp VIP.net installer, Best Practice Software recommends to stop VIPSer-
vices.net from Windows Services and restart the services again after the update is complete. See
Configure and Start VIP Services

4. Copy the setup.zip file to the folder nominated in Setup > Facility Preferences > General Prefer-
ences > Login/Tasks tab > New version location field. This field must contain a UNC path to a
network location accessible by Bp VIP.net workstations.

5. When a user next logs in to a workstation, Bp VIP.net will detect that a new setup.zip file exists
in this folder and will automatically upgrade the workstation.
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6. If your practice uses a MIMS database, check your version of MIMS and update to the latest ver-
sion if available.

New Features

Gender and Sex fields

The Patient Details (F3) screen has been updated to include a Gender field. This new field supports
Australian Day Stay reporting requirements and is optional for New Zealand users.

For more information see Recording Patient Gender and Sex.

Gender field for Daystay reporting in Tasmania

In the Personal and Admission Details tab of a Daystay Operation Tasmanian users can enter the
patient's Gender. If the patient's gender is already recorded in the Patient Details (F3) screen this
field will auto-populate.
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For further definitions of the gender values see Recording Patient Gender and Sex.

ACC Claiming API

Integration with the new ACC API due to the pending deprecation of the eBusiness gateway has been
enabled in Bp VIP.net to ensure practices can continue to claim with ACC.

How has the ACC Claiming process changed?

eBusiness Gateway deprecation – Users will no longer need to launch the eBusiness Gateway
from Bp VIP.net to send claims or invoices.
ACC Claim and ACC Invoice – The eSchedule and eLodgement options have been replaced from
File > Communication > Services with ACC Invoice and ACC Claim. Once Proceed is selected
invoices and claims are sent to the ACC API and a response is received.
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Batching Method – From the ACC Organisation Details in the Charging Details tab,
ACC Invoicing should be selected as the Batching Method and the options Send Batches Elec-
tronically and via ACC Claim should both be enabled.

ACC45 Claim Form – The fields Other Ethnicity and Other Employment have been added to the
ACC45 Claim form. When one of these options is selected, a text box will display for the user to
enter details.

Enhancements

Function Release Notes Key

Medical Desktop The Glasses UDF in theMedical Desktop has been updated to
highlight the latest prescription record when opened.

54888

Medical Desktop Additional formatting has been applied to the Complete Notes
History printout in the Medical Desktop for improved readability.

70776

My Health Record The ability to File to Provider has been added toMyComms for
downloadedMy Health Record documents in Bp VIP.net. The File
to Patient function from the Change Details screen has been
disabled for these record types.

70060

Webview2 TheWebview2 install required for Bp VIP.net has been included in
the Bp VIP.net installer and will run silently in the background
when users perform Bp VIP.net updates.

Important: Best Practice Software recommends installing
Webview2 manually for users updating Bp VIP.net on terminal
servers. See Download and Install Webview2 for further
instructions.

70624
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Function Release Notes Key

Setup Charges From the Setup Charges grid view, values can no longer be edited
by clicking into the amount column and typing the fee in. The fee
must be selected and modified or double-clicked on to make
changes.

70901

Manual Batches The button Create Manual Batch in the Batch Preview screen was
often mistakenly selected due to the close proximity to the
Create/Send Batches button. The Create Manual Batch button has
been relocated on this screen next to the Remove Errors button to
avoid its accidental selection.

68998

My Health Record Users can use the FIle to Provider function to file My Health Record
documents in Bp VIP.net. The File to Patient button cannot be
selected for My Health Record documents.

70060

Tasks Previously, all replies to a Task would be displayed in the task list
for the creator. This feature has been updated and is now toggled
on from Personal or Facility Preferences under Login/Tasks.

64705

Allergies A search box function has been added to the Medication Class
screen when searching through Allergies.

69424

IMC and IHC Claim
Reporting

Reports older than 6 months will not display in the IMC and
IHC reporting screens.

71965

Bulk Billing Claims A Clear From List button has been added to the Bulk Billing Claims
screen for All paid and All unprocessed claims.

72108

Day Stay Reporting If the Sex recorded in the Patient Details (F3) screen is not selected
as Male (M) or Female (F), the patient's recorded Sex will be sent as
X in Day Stay Reporting for Queensland practices.

72495

Day Stay Reporting Gender fields have been added to support future reporting
requirements. Additional reporting requirements have been
updated to comply with 2023-2024 state reporting requirements
including a default field under Daystay Preferences > Discharge
Defaults to streamline workflows.

72497

Community Health
Program

In the Community Health Program screen accessed from the
Medical Desktop the option Diabetes Education is now available
from the Service Stream drop down list.

72851

Bug fixes

Aged Debtors Report

Updates have been made to the Aged Debtors Report:

When grouping by Provider, the Revenue Account will not display in the report results unless
selected in the Revenues filter.
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SelectingWrite-off will open theWrite-off Bad Debt screen where users can specify debt ages
and amounts to write off. No default is set for this screen. The field Amount to Write-Off
becomes enabled once an option is selected.
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Report on Creditors only grouped by Providers will display patients with Credit On Hold.

Report on Debtors only grouped by Debtors will accurately display values matching the results
when grouped by Provider.

Function Release Notes Key

System Wide When using Bp VIP.net, users experienced screen flickering throughout all
areas of the software. Updates have been made to mitigate this issue.

68837

Exporting Financials An error message stating the system was out of memory would occur when
running a New Export from File > Accounts > Export > Exporting Financials.
This error has been resolved and users can export financial data without
issue.

69694

DVA  OPV Check When performing an OPV Check to verify a patient's DVA number, an error
would occur if there was a space in the number informing the user they are
unable to proceed without a valid DVA number. This field has been updated
to allow a space as a valid character and Bp VIP.net will no longer produce
an error.

69754

Print Medicare Form Selecting Print Medicare Form from the Transactions (F8) screen would
produce no response from Bp VIP.net. This issue has been resolved and
users can print forms as usual.

23133

Patient Details After a patient's IHI number had been verified, users experienced issues
saving DVA numbers to the Patient Record. This error has been resolved
and DVA numbers will save correctly.

69635

IHC Claiming When sending IHC claims the Service Quantity of items was not
transmitted to DVA or the health funds. This issue has been resolved.

69759

IHC Claiming Users experienced a System Out Of Memory Exception error when
transmitting IHC Claims. This error has been resolved.

70067
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Function Release Notes Key

IHC Claiming Sending IHC Claims with specific item codes would result in error when
sending through Medicare Web Services due to invalid characters added to
the theatre band value. These invalid characters have been removed and
claims can be sent without error.

70331

Bulk Bill Reporting When selecting Get Report(s) from the Bulk Bill Claiming screen Bp VIP.net
would return a Medicare Web Services error Object reference is not set to
an instance of an object. This error has been resolved.

70139

Aged Debtors Report Previously, when running the Aged Debtors Report and grouping by
Debtor, the totals in the report did not match the totals printed or
exported to Microsoft Excel. This issue has been resolved and all totals
from the Aged Debtors Report are accurate.

23312

My Health Record Opening attachments inMy Health Record caused Bp VIP.net to freeze.
This issue has been resolved and attachments can be accessed without
error.

70545

MyComms With the retirement of Internet Explorer, users experienced issues in the
MyComms screen when viewing PDF documents. Bp VIP.net has been
updated to accommodate this change and PDF documents will now open in
MyComms without Internet Explorer successfully.

69810

Medical Desktop Attempting to Add an existing Procedure to Actions in aMedical Note
would result in an error when the patient had existing operations in the
Operations screen. This error has been resolved and Procedures can be
linked to Medical Notes successfully.

69954

Page-Owners Additional Columns set in Page-Owners for the Appointment Book were
not honoured when appointments were accessed from a patient's
Appointment History. This issue has been resolved.

69035

Statement Run Associates would show as a blank record in the Available records to select
when printing a Statement Run. This issue has been fixed and Associates
will now display correctly.

69167

Prescribing When repeat prescribing Regular Medications with Active Ingredients
present, the Brand Name would previously print on the script regardless if
this selection was checked. This issue has been resolved and scripts will
print as intended.

69155

MIMS Prescribing TheMIMS explorer window previously did not display images or GIFs of
Chemical Structures when prescribing. Bp VIP.net has been updated to
restore these images.

70649

NZLUM Prescribing When Repeat Prescribing an existing NZLUM generic medication one of
two errors would occur, script errors or Bp VIP.net freezing. These errors
have been resolved.

70646

Transmit Day-Stay
Episodes

The Care Type of 03 non-acute in the Admission Defaults of Day Stay
Preferences was not honoured when transmitting Day Stay data to the
AHSA health fund in Tasmania. This issue has been resolved and Day Stay
preferences are honoured for Day Stay Operations.

70948
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Function Release Notes Key

Transmit Day-Stay
Episodes

When transmitting Day Stay data for the Tasmania State Government, an
error in the Patient Number transmitted would result in a failure of
submission. This was due to the number being one character short of the
required 10 digits. This error has been resolved and patient numbers
transmit correctly,

70750

Transmit Day-Stay
Episodes

When transmitting Day Stay data for the Tasmania State Government, Bp
VIP.net would produce a transmission error stating that the "Medicare
Eligibility Status" cannot be blank. This error occurred regardless if the
Medicare Eligibility Status was blank in the Admission Details of the Day
Stay Episode. This error has been resolved and users can transmit Day Stay
data to the Tasmania State Government without issue.

70079

Live Update The radio button for DVA in section 3 of Live Update has been renamed to
Non MBS DVA to accurately reflect the contents of the update.

69767

Maintain Item
Details

If a Diagnostic Imaging Item Code contained a letter character in the User
Code field of the Maintain Item Details screen the Bulk Bill incentive would
not apply. This issue has been resolved.

69710

Transactions Screen The Subsidy and Debt columns in the Transactions (F8) screen were
highlighted in red text where in previous versions of Bp VIP.net the correct
columns to be displayed with red text were Batch, Owing and Balance. This
functionality has been restored and the correct columns now show with
red text.

70090

Patient and
Organisation Details

When switching focus in the snapshot between patients and organisations
with both records open, Bp VIP.net would return an error. This issue has
been resolved and no errors will occur when switching between records.

70891

Maintain Custom
Medications

When adding Medications to a Custom Formulation, selecting OK with a
Custom Medication highlighted will insert the record into the new
formulation. The search function from the Medications screen will display
all results containing the search words.

71852

Bulking Billing Some users experienced issues sending DVA Assistant Bulk Billing
claims. This error has been resolved.

71350
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