
Upgrade Bp VIP.net to Topaz SP2 (2.1.532.058)

Release Date  07 February 2024

Notes last updated 07 February 2024

What is in this release? Bp VIP.net2.1.532.058 contains ePrescribing for Australian users, bug fixes, new
features and enhancements.

What version can
I upgrade from?

You should be able to upgrade to 2.1.532.058 from any version of Bp VIP.net.

Users updating from Topaz Revision 2 (2.1.526.057) or lower will need to
update the .NET Framework to version 4.8 before updating Bp VIP.net.

System Requirements
Windows Server 2012 and 2012 R2 end of support

○ Microsoft support for Windows Server 2012 and 2012 R2 ended on October 10, 2023. Best
Practice Softwarerecommends users running Bp VIP.net on Windows Server 2012 or 2012 R2
upgrade to a supported Windows server operating system. See the Bp VIP.net System Require-
ments and the Microsoft website for further details.

Webview2 installation

○ TheWebview2 install required for Bp VIP.net is included in the Bp VIP.net installer from version
Topaz SP1 Revision 3 onwards, and will run silently in the background when users perform Bp
VIP.net updates. Best Practice Software recommends installing Webview2 manually for users
updating Bp VIP.net on terminal servers. See Download and Install Webview2 for further instruc-
tions.

Microsoft .Net Framework version 4.8

○ Check the version of Microsoft .NET Framework on the Bp VIP.net server and workstations. Bp
VIP.net version Topaz SP1 Revision 2.1 or higher requires aminimum .NET Framework version
of 4.8.

Step 1: Before you upgrade

1. If you did not upgrade to the most recent version Topaz SP1 Rev 3 (2.1.531.054), review the
release notes to see the changes in that version.

2. Before running the Bp VIP.net installer, Best Practice Software recommends to stop VIPSer-
vices.net from Windows Services and restart the services again after the update is complete.
See Configure and Start VIP Services for further instruction.

3. Best Practice Software recommend that the upgrade be performed outside of normal busi-
ness hours.
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Step 2: Upgrade Bp VIP.net

1. Go to Help > What's New.
2. Right-click the upgrade zip file link and select Save Link As or Save Target As under the head-

ing for Bp VIP.net Topaz SP2 (2.1.532.058).

TIP You can also download the upgrade zip file from the Bp VIP.net Downloads
page.

3. Double-click the file to begin the installation. The Bp VIP.net InstallShield Wizard will open at
the Welcome panel.

4. Click Next to begin.

See Install Bp VIP.net for full instructions.

Step 3: After you upgrade

1. Log in to the Bp VIP.net server computer as a Windows administrator. You may require Win-
dows administrator permissions to install and update some Bp VIP.net components.

2. If your practice uses a MIMS database, check your version of MIMS and update to the latest
version if available.

3. After completing the upgrade, Best Practice Software recommends restarting VIPSer-
vices.net. See Configure and Start VIP Services for further instruction.

4. Check the new features, enhancements and bug fixes below for any required configuration.
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New Features & Enhancements

ePrescribing for Australian users

New articles on how to set up, create and send eScripts in Bp VIP.net Topaz SP2 for Australian users
are available on the ePrescribing landing page in the Bp VIP.net Knowledge Base. Go to Help > Online
Knowledge Base to launch the website from within the software.

Selecting the green information icon from Setup > Facility Preferences > General Preferences > ePre-
scribing will launch the Bp VIP.net Knowledge Base ePrescribing landing page.
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My Script List (MySL) for Australian users

MySL is a service available for Australian practices that displays a view of both active ePrescriptions
and paper prescriptions for patients that have consented to the service. Pharmacists can use MySL to
see a list of active prescriptions, removing the need for ePrescription tokens.

MySL is available in Bp VIP.net Topaz SP2 for Australian users. Learn more about My Script List on the
MySL website or see the new My Script List Knowledge Base article for more details.
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Bp SMS credit updates

Changes have been made in Bp VIP.net to update Bp SMS from credit to dollar based values.

From the SMS Configuration section in the Communications tab of Facility Preferences:

○ Credits Remaining - Displays the dollar value of Bp SMS credits purchased, excluding GST.
○ Unused messages - How many SMS messages or eScripts can be sent with the total value of Cred-

its Remaining.

○ Bp SMS activation codes sent from Bp Sales will now be supplied as a 7 segment code. When
selecting Top up BP SMS credit > Validate Code, Bp VIP.net will check for an activation code of
this length.

○ Entering a Bp SMS activation code less than 7 segments will prompt Bp VIP.net to warn the user
that the code entered is incorrect or invalid.

From the Appointment Book:

○ For New Zealand users, the appointment book will display the number of SMS messages remain-
ing.
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○ For Australian users, eScript SMS messages are fully funded. The remaining eScript messages
will display as unlimited.

○ When eScripts are no longer funded for Australian users, the number of SMS messages and
eScript SMS messages remaining will display.

See Set up and top up Bp SMS for more details.
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Bp SMS spam policy updates for New Zealand users

Due to recent policy changes by some New Zealand telecommunication providers, Best Practice Soft-
ware has made changes to the way SMS messages are created and sent in Bp VIP.net for New Zealand
users.

To align with these updated policies and to streamline the setup of Bp SMS, Best Practice Software
has created a range of SMS system templates. If Bp SMS is already configured, after upgrading to Bp
VIP.net Topaz SP2 you will need to import and update the default templates to one of the newly sup-
plied system templates.

The autotext SMS system templates provided cannot be modified or edited. To retain functionality of
customisable autotext SMS messages, New Zealand sites will need to purchase their own short code
from the Bp Sales team.

To begin using Bp SMS (NZ) system templates: 

1. Go to File > Utilities > Live Update.
2. Select Import > Bp Library > Auto Text > Bp FTP.

3. From the AutoTexts to import... screen, select \New Zealand Specific > \SMS Auto Text >
NZ SMS restricted autotexts and click OK.

4. Default autotexts are configured in Setup > Facility Preferences > General Preferences > Com-
munications.

See Bp SMS Autotext (NZ) for more information on importing and using Bp SMS Autotext templates.

SMS Autotexts for Australian practices

The new SMS checkbox added to the AutoText Setup screen must be selected for autotext entries
intended for SMS use in Bp VIP.net.
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Only autotext entries with the SMS checkbox enabled will display in the selection of available auto-
texts when sending SMS messages in Australia.
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ACC45 claim number updates for New Zealand users

Accident Compensation Corporation (ACC) have made updates to the ACC45 claim number format
due to trends indicating that the current pool of available numbers will soon run out.

Updates have been made in Bp VIP.net Topaz SP2 to accommodate for these changes. The existing
ACC45 number format will continue to be accepted by ACC and in Bp VIP.net.

Current ACC45 Numbers

7 characters comprised of 1-2 letters, followed by 5-6 numbers

One letter followed by six numbers - A123456
Two letters followed by five numbers- AB12345

Updated ACC45 Numbers

7 characters comprised of 4-5 numbers, followed by 2-3 letters

Four numbers followed by three letters - 1234ABC
Five numbers followed by two letters - 12345AB

NOTE When creating a new ACC45, the Claim number field is submitted with a blank value.
The field will populate with an ACC45 number after the claim is returned from the ACC API.
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Financial archiving for organisations

The Archive Financial Transactions utility is designed to assist with organisations that have large trans-
action history which can often result in performance and account reconciliation issues.

Found in the Utilitiesmenu, the function can archive any transactions between a date range for a spe-
cified organisation. Archiving can be undone for an organisation, and every interaction with the utility
is recorded in the Archive Log. This utility is currently available for administrative users of Bp VIP.net
Topaz SP2.

See Archive Financial Transactions for more information.
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Visual Acuity measurements for Ophthalmology

Updates have been made to Bp VIP.net to include additional Visual Acuity (VA) measurement systems
in the Medical Desktop.

The following additional VA measurements can be added from Setup > Visual Acuities. See Record
visual acuity for more information.

Abbreviation Full Name Display format

HOTV (6m) HOTV 6m 6/12

Lea (3m) Lea Chart 3m 3/12

Kay (3m) Kay Pictures 3m 3/12

CAC (100cm) Cardiff Acuity Cards 100cm 6/12

CAC (50cm) Cardiff Acuity Cards 50cm 6/12

TAC (84cm) Teller Acuity Cards 84cm 0.32 cyc/cm

TAC (55cm) Teller Acuity Cards 55cm 0.32 cyc/cm

Lea Paddles (57cm) Lea Paddles 57cm 0.32 cyc/cm

Lea Paddles (29cm) Lea Paddles 29cm 0.32 cyc/cm

NOTE If no values are selected for a measurement system, they will not display in the drop
down list of measurements from the Medical Desktop.

Regulation 49 prescriptions

The field Regulation 24 has been updated to Regulation 49 in the Prescription Item Details screen. This
change is in compliance with Australian PBS updates.

Letter and Auto templates containing the lookup field (Ctrl + l) Regulation 24 Applies? will need to be
manually updated to the new field Regulation 49 Applies?, found under Medications > Prescriptions >
Chosen Prescription or Last Prescription.
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Other enhancements

A full list of enhancements made to Bp VIP.net Topaz SP2 can be found in the table below.

Function Release Notes Key

ACC Claiming ACC45 Claim Numbers have been updated to conform with new
ACC changes to the claim number format. The ACC number format
has 7 characters comprised of 1-2 letters, followed by 5-6 numbers
(e.g. A999999, or AA99999). This has been updated to also allow 4-
5 numbers, followed by 2-3 letters still with the 7 characters total
(e.g. 9999AAA, or 99999AA).

72419

Active Ingredient
Prescribing

Formatting and content changes have been made to align with the
conformance criteria for Active Ingredient Prescribing.

71818

Addresses Postcode numbers for Streets and Towns have been updated for
Australian users.

68885

Aged Debtors When running an Aged Debtors report for Creditors theWrite Off
button has been removed.

70307

Audit Log The logged in user will display in the Other Notes column of the
report when searching the Audit Log for user logins.

69216

Bp SMS In accordance with the changes to Bp SMS from credits to a dollar-
based value, validation of codes when using Top up Bp SMS Credit
has been updated to restrict redemption of previous SMS code
formats. See Set up and top up Bp SMS for more details.

71891

Email The label for the Use SSL email option in Facility Preferences has
been updated to Use SSL/TLS to accurately reflect the function.

71702

Facility Preferences The setting to Enforce authentication for prescribing Schedule 8
Controlled drugs has been removed from Facility Preferences.
When prescribing Schedule 8 drugs Bp VIP.net will automatically
prompt the prescriber for their Bp VIP.net password.

72409

Financial Summary When running a report from the Financial Summary using the
Service date, the time component of the To and From fields has
been removed for more accurate reporting results.

72930

General Preferences The Columns display order list field found in Setup > Facility
Preferences > General Preferences > Appointment Book 1 has
been expanded for ease of use.

44358

HI Verification Changes have been made to the HI Verification services when
updating patient details in the Patient profile (F3) to allow for more
accurate data entry. See for more details.

73341
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Function Release Notes Key

IMC Claiming New Medicare reason codes have been added to Bp VIP.net in
accordance with updates from Services Australia to allow for more
accurate feedback.

72994

Internal Providers The Preferred Prescribing System for Internal Providers can now be
set to Custom orMIMS when using eRx for ePrescribing in
Australia, where the custom option was previously disabled.

70979

Live Update HCP Hospital Provider Numbers can now be updated in Bp VIP.net
for Australian Day Stay users. To run the update, go to File > Live
Update > Update > Daystay Facilities > Bp FTP > Next.

73275

Lookup fields (Ctrl+l) Under theMedical Notes heading in the lookup field (Ctrl+l) tree
view selection for autotexts, letter and auto templates, new lookup
fields Chosen Visit Notes and Last Visit Notes have been added to
Bp VIP.net.

67483

Medical Desktop The Visual Acuity measurements have been updated to include
VA measurement methods for children or individuals who are
unable to complete traditional tests. These new measurements are
disabled by default and can be added from Setup > Visual Acuity.

67463

Medical Desktop If no values are selected for a measurement type in Setup > Visual
Acuities, the measurement type will not appear in theMedical
Desktop under the Visual Acuity drop down selection.

69527

Medical Desktop When a Regular Medication is discontinued or expired, it will
display in the Medical Desktop with strikethrough text and
(Expired) next to the name of the medication. It will also move to
the bottom of the list.

71285

MyComms Updates have been made to improve database functionality in Bp
VIP.net where larger practices with a high number of users
previously experienced performance degradation.

72804

NHI Number Updates have been made to the NHI Number field to
accommodate new changes to the NHI numbering format from Te
Whatu Ora.

72290

Password Policies A new Enforce inactive period lockout password policy setting has
been added to the ePrescribing tab in Facility Preferences for
prescribers only, to conform with ADHA requirements. These
updates have also been applied to the Enforce inactive period
lockout setting in the Password Policy tab. If both settings are
enabled in each tab, the field with the lowest value entered will
take priority for the prescriber.

73356
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Function Release Notes Key

Patient Details New Insert fields (Ctrl + L) have been added to Bp VIP.net for the
recorded gender in Patient Details to include They, Them and
Theirs pronouns.

70077

Patient Details The Sex field in the Patient Details screen has been updated for IHI
validation purposes.

72752

Prescription Item
Details

The field Regulation 24 has been updated to Regulation 49 in the
Prescription Item Details screen. This change is in compliance with
Australian PBS updates. Letter and Auto templates containing the
lookup field (Ctrl + l) Regulation 24 Applies? will need to be
manually updated to the new field.

71303

PRODA B2B Device A new button Re-create Device has been created for the
PRODA B2B Devices screen accessed from Setup > PRODA >
Activation. When Re-create Device is selected the previous B2B
device will be deleted, and a new B2B device record will be created
with the User Device Name field populated from the previous
device details.

70230

PRODA B2B Device Two new fields have been added to Bp VIP.net to set a Default
B2B Device and a Default Minor ID per user. The setting is
accessed from Setup > Personal Preferences in the Financial tab.

69020

PRODA B2B Device When a user selects Re-create Device from the PRODA B2B Devices
screen, the Default B2B Device will update for any users with the
previous B2B device set as their default in Personal Preferences.

72209

Provider Details If the First Names field is left blank when modifying internal
provider records, before saving Bp VIP.net will ask Does the
Provider have a First Name? Select No to save and close the
record without entering a first name for the provider.

69605

Real Time
Prescription
Monitoring

The NDE Precheck has been enabled forWestern Australian
practices. See the Real Time Prescription Monitoring Knowledge
Base article for more information.

71421

Transmission Status The column Resend? has been removed from File
> Communications > Transmission Status as the function is no
longer required for Medicare Web Services or ACC claiming.

69139

Page 14 Bp VIP.net Topaz SP2 Release Notes

https://kb.bpsoftware.net/vipnet/Clinical/Prescribing/RTPM.htm?


Bug Fixes

Function Release Notes Key

ACC Batching Previously when sending ACC batches in Bp VIP.net the service date did not
transmit correctly. This error has been resolved.

73257

Aged Debtors Previously when reporting on Creditors Only in the Aged Debtors Reports
and specifying Revenue Accounts to report on, the Revenue Account
details would not display in the report. This issue has been resolved.

72084

Aged Debtors Updates have been made to the Aged Debtors report to remove the time
portion of date field when filtering results by service date for more
accurate reporting.

72933

Aged Debtors Updates have been made to the Aged Debtors report to resolve
inconsistencies with Credit on Hold (COH).

73172

Bulk Appointment
Reminder

SMS messages could not be deselected from the Preview TXT Messages
screen when sending Bulk Appointment Reminder Messages. This error has
been resolved.

75092

Check OPV (DVA) When running an OPV check for DVA patients, an error message has been
updated to prompt the user to update the patient Sex field where the error
previously requested Gender.

72934

Daystay episodes Updates have been made to Bp VIP.net for the correctMode of Separation
value entered in the Discharge details of a Daystay Episode to be sent when
transmitting health fund data.

71288

Daystay episodes The Gender field has been removed from the Personal and Admission
details section of the Daystay episode for WA practices.

73537

Daystay Reporting Validation of Discharge Defaults has been restored when resubmitting
Daystay reports for the state of Victoria to reduce the risk of rejections and
incorrect data.

72935

Financial Summary When running the Financial Summary, Bp VIP.net would display incorrect
data in the Revenue Account column where the values should be blank.
This issue has been resolved.

71780

IHC Claiming An issue has been resolved for Bp VIP.net where IHC claims for item 13950
would be rejected by the NIB Health Fund.

70954

IHC Claiming Updates have been made to resolve issues with the Service Code and
Service Type Code fields in the PSG segment of an IHC claim when sending
to the HBF Health Fund.

71284

IHC Claiming Updates have been made to Bp VIP.net to restore character length
validation checks for provider numbers and Facility ID numbers when
sending IHC Claims.

71461
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Function Release Notes Key

IMC Claiming An issue has been resolved for Bp VIP.net where provider and phone
number character length validations were not applied when sending
IMC claims, resulting in Medicare Web Service errors.

71419

Medical Desktop Updates have been made to resolve display issues with the Visual Acuity
format drop down menu in the Medical Desktop.

73198

MyComms When attaching multiple letters to an email, Bp VIP.net would duplicate the
contents of files with the same name. This issue has been resolved.

73160

NDE PreCheck The NDE PreCheck instructions available from the information icon have
been updated to accurately reflect the function. This feature has also been
relocated to Setup > Facility Preferences > General Preferences >
ePrescribing.

70569

Online Eligibility
Check

Previously when running an Online Eligibility Check (OEC), validations to
check for the provider number character length were not applied. This
issue has been resolved.

71452

Patient Details Changes have been made to Bp VIP.net to counteract an issue with
unrelated external providers appearing in the Patient Details (F3) screen.

72996

SMS Messaging An issue has been resolved in Bp VIP.net where the Automated profile
would not populate details when sending as an SMS message.

73009
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