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Integrate with Epiphany CardioServer

Bp VIP.net integrates with Fuji Epiphany systems to allow synchronisation of relevant patient and
appointment data, and to submit and receive cardiology examinations and results.

Fuji Epiphany clinical software (Epiphany) is not supplied or maintained by Best Practice Software. For
more information on installing Fuji Epiphany software, contact Fuji Epiphany Support for the appro-
priate software. The instructions below assume that Epiphany software has already been successfully
installed on your practice network.

Bp VIP.net communicates with Epiphany in two ways:

& Bp VIP.net creates HL7 messages and delivers the messages via TCP/IP. The message files contain
patient demographics and patient appointment booking data. Bp VIP.net Services polls the Bp
VIP.net database periodically to determine if there are messages to create.

B A Bp VIP.net TCP/IP listener waits for incoming connections from Epiphany. When an incoming
connection is accepted, Bp VIP.net accepts incoming HL7 results, determines the patient record
to which they belong, and imports the embedded PDF result into the patient’s record.
Unmatched results are added to Unfiled Images in Bp VIP.net, and can be manually allocated to
the correct patient.

The Fuji Epiphany integration with Bp VIP.net will always use a Patient Matching method of 'Internal
unique ID".

Note: Because the Epiphany interface relies on Bp VIP.net Services to poll the database, Bp
VIP.net Services must be running for data to be transferred between Bp VIP.net and Epiphany.
Contact Best Practice Software Specialist Product Support if you need more information on
installing and starting Bp VIP.net Services.

Before you begin

The Fuji Epiphany integration uses a nominated TCP/IP port, instead of a Windows folder, to send and
receive data between the two systems. You will need to know the port number used by your Epiphany
software when setting up the interface definition in Bp VIP.net.

Set up the Epiphany interfaces

Install interfaces

1. Login to Bp VIP.net as a Bp VIP.net Administrator.
2. Select File > Utilities > Live Update to open the VIP Live Update screen.
3. In the VIP Live Update screen:

i Section 1 — Select Import.

i Section 2 — Select Interface Definitions.

i Section 4 — Select Bp FTP.
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@= VIP Live Update
1 O Update ® Import
2 (O) Charges () Coding O MIMS
() Ethnicity (O) Occupstions () Bp Library
() Patient Info (O) Regions (® Interface Definitions
3 MBS Prostheses Health Fund Theatre Band Custom
Auto Text UDFs Auto Templates Letter Templates Daystay Facilities
Reports Providers Streets D SLA
4 () Browse @B FTP MIMS FTP Site
5

Click Next to proceed

4, Click Next.

5. In the Live Update window, check the Status column for the two interfaces:

& Fuji ORM Worklist.
& Fuji Worklist

-

If the Status column shows 'Installed’, you do not need to reinstall the interfaces. Click
Cancel, and click Cancel again to close the VIP Live Update window. Go to Set up interfaces

on the facing page.

If the Status column shows 'Not Installed', select 'Install' from the Action column for both

interfaces and click OK. The interfaces will be installed.

In the following example, the two Fuji interface files have been installed and require no

action.
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Live Update

MName Status Action fa
Appoirtment Boaoking Installed Mo Action W
Canon EQS Capture Installed Mo Action Wil
DICOM Mutti-File Impart Installed Mo Action W
Dicom Storage & Worlklist SCP Installed Mo Action hd
Fuji ORM Warklist Installed Mo Action
Fuji Worldlist Installed Mo Action
Heyex Eye Explorer Remote Control Installed Mo Action W
Humphrey Field Analyser Service Installed Mo Action W
Humphrey HARK 537-555 Autorefractor Installed Mo Action vl |
Image Importer (Falder) Installed Mo Action W
Image Imparter (TCF) Installed Mo Action W
IPIX Installed Mo Action v
LA350-360 Lens Meter Installed Mo Action w
Medment Studio Installed Mo Action v
OK Cancel

Set up interfaces
Add Fuji Worklist

1. In Bp VIP.net, select Setup > Medical > External Interfaces. Click New in the Maintain
External Interfaces screen.

2. Click New. The Details tab will open.
3. Enter a descriptive Name for the Fuji Epiphany interface, such as 'Fuji Cardio'.
4. Select the Interface 'Fuji Worklist'.
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Maintain External Interfaces

Browse  Details |

MName
Interface

wlorkstation

Program Falder

Transfer Folder

Test

| Fuji Cardio

Tag |!§|

| Fuji Worlist

v]

7 |

‘Warklist Filter Settings...

[-]

]

This interface is to support the built in Fuji Worklist/Exam report
interface. Use the Worklist filters section to limit the bockings that
are sent to Fuji

5. Leave the Program Folder and Transfer Folder empty.

6. Click Worklist Filter Settings. The Work List Filters screen will appear.

7. Select the Page Owners, Locations, and Appointment Types that you want transferred to Syn-
ergy when new records are created or changes are made.

In the example below, all options have been ticked, which means any new patients or appoint-
ments, or any updates to patients or appointments will be transferred to Fuji Epiphany. If you
did not select the Page Owner 1. 'Dr Harry Cardiology', for example, appointments booked for
this provider would not be transferred.

Only send bookings to the Work st where they fit the following cnitena

Page Owners Locations Appointment Types
1. Cardialogy, Dr Harry CLIMIC, Clinic Avvall
2. Dematalagy, Dr Fred HaM, Harmilton Hospit: Leave
3. Ophthalmalogy. Dr Sarah NP
4. Orthopedic, Dr Nancy Oper
B. Recovery PO
Publc
Few

8. Click OK to return to the Maintain External Interfaces screen.

9. Click OK to save the interface.

Add Fuji Worklist
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1. In the Maintain External Interfaces screen, click New to create the second interface.
The Details tab will open.

2. Enter a descriptive Name for the Fuji Epiphany interface, such as 'Fuji Cardio ORM'.
3. Select the Interface 'Fuji ORM Worklist'.

4. This step is optional. Select where in Bp VIP.net you want descriptive text from Fuji Epiphany
imported to:

i Do not insert Tag (ignore)
® Exam Field in medical note
# Assessment Field in medical note

# Management Field in medical note.

&= Maintain External Interfaces -

Browse  Details |

Name [Fui Cardio ORM Tag |@
Interface [ Fuli ORM Workiit v]
‘wiorkstation | w ‘ | ‘wiorklist Filter Settings..

This interface ensures ORM/ORR messzages are sent for the
type etc via the Fuji Interface.
To configure which types and locations etc are sent, please click on
the “worklist Filters™ button
Mo other fields are required

Insert Image Tag into:

[ ] Append Tag ta Exal
[] Append Tag to Assessment Field
[7] &ppend Tag to Management Field

Test | 0K | | Cancel |

5. Click OK to save the interface.

6. An image file, contained within the incoming message, will be displayed in the Medical
Desktop, in the filmstrip.

Set TCP/IP ports

The method will depend on the version of Bp VIP.net you are running. To find out which version of
Bp VIP.net you have installed, select Help > About from the main menu and inspect the Version
field.

When setting the ports that will be used, you also must ensure that your practice network and fire-
walls have been configured to allow connections on those ports. Your IT service provider can assist
with network configuration.

For Bp VIP.net version 2.1.517.033 or later

1. Login to the Bp VIP.net server as a Bp VIP.net administrator.
2. Select File > Utilities > VIP Service Controller. The VIP Service Controller window will appear.
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3. Enter the incoming and outgoing ports to use:

¥ Fuji Message IP & Port — The IP address and port which the VIP services component

will listen on for incoming HL7 embedded PDF messages.

¥ Fuji Worklist IP & Port — The IP address and port to which the VIP services component

will send HL7 messages.
4. Click Update Service. Bp VIP.net will indicate if VIP Services has been updated. Click OK.

5. Restart VIP Services.

For Bp VIP.net versions earlier than 2.1.517.033

You need to edit the VipServices.Net.exe.config file to add the IP address and TCP/IP port that Bp
VIP.net will use to send and listen for incoming updates.

1. On the Bp VIP.net server machine, open a Windows file explorer and browse to C:\Program
Files (x86)\Houston Medical\VIP.net.

LA A L CA\Program Files (x86)\Houston Medical\VIP.net
Home Share WView
i(-) * 4 | v ThisPC » SYSTEM(C:) » Program Files (x26) » Houston Medical » VIP.net

[ Favorites
B Desktop
4 Downloads

=l Recent places

M| This PC

.+ Corporate Files
B Desktop

| Documents

4 Downleads

W Music

= Pictures

B Videos

, SYSTEM (C)

Mame

%] System.Windows.Forms.DataVisualizatio..,

%) Systern.Windows.Forms.DataVisualizatio...

%) 23_css.dll

(%) x23_doc.dll

(%) 23_dox.dll

%) x23_htm.dll

%) b23_pdf.dll

[ x23_rtf.dll

(%) b3 _xml.dll

%) T¥DocumentServer.dil

%] T¥DocumentServer.Windows.Formes.dll
) baic.dll

1% tkernel.dll

%) tepdf.dll

%] T¥TextControl.dil

%) T¥TextControl.Server.dll

%) T¥TextControl.Windows.Forms.Design.dll
%) T¥TextControl.Windows.Forms.dll
%] btools.dll

%] Tyro.dnteg.dll

(%) Ucs32P.dll

| UserDictionary.bt

| vfpoledb.msm

@= VIP.exe

Mj WIP.exe.config

8= vip.ico

571 VIPReportUtilities.exe

Mj VIPReportUtilities.exe.config

| VipServices.Log

=] VipServices.Net.exe

Date modified

Type

Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
Application extens...

Text Document
MSM File
Application
COMFIG File
10 File
Application
CONFIG File
Text Document

Application

34,126 KB
KB
2KB

2KB

| ﬂ VipServices.Net.exe.config

COMFIG File

%] VipServices.Net.Logger.dIl
%] Kceed.Compressionv3.1.dll
%] Kceed FileSystemav3. 1.dll
%) Keeed Zipv31.dil

%) XeroApidll

Application extens...
Application extens...
Application extens...
Application extens...
Application extens...
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2. Right-click on the file VipServices.Net.exe.config and select Edit. The config file will open in
Notepad.

3. Add the following lines inside the section <appSettings> </appSettings>

<add key="FujiReportMessagePort" value="IncomingPort"/>
<add key="FujiReportMessagelpAddress" value="IncominglPAddress"/>
<add key="FujiWorklistPort" value="SendtoFujiPort"/>

<add key="FujiWorklistlpAddress" value="FujilPAddress"/>

Where the values should be:

¥ IncomingPort / IncominglPAddress — The IP address and port which the VIP services com-
ponent should listen on for incoming HL7 embedded PDF messages.

® SendToFujiPort / FujilPAddress — The IP address and port to which the VIP services com-
ponent should send ADT, SIU, and ORM messages.

The following example shows the lines added with values. The exact values will depend on
your specific practice and Fuji software.

e VipServices.Net.exe.config - Notepad

File Edit Format View Help

<«?xml version="1.8"2>
<configuration»

<appSettings>

<add key="ServerName” value="VIPNET-PC"/>

<add key="DatabaselName" value="VIPDB"/>

<add key="IntegratedSecurity" wvalue="True"/>
<add key="LogFileName" wvalue="VipServices.lLog"/>
<add key="DicomblorklistSCPPort” value="7881"/>
<add key="DicomStoreSCPPort” value="7862"/>

<!-- one of Detailed, ExceptionOnly, Normal--»>
<add key="Loglevel"” value="Normal"/>

<add key="UnmatchedDicomImageStoreFolder” value="d:\unmatcheddicom'"/>
<add key="PollingInterval” value="15"/>

<add key="DicomAETitle" value="VipServices.Net"/>

<!--FUJT interface -->

<add key="FujiReportMessagePort"” value="7807"/>

<add key="FujiReportMessagelpAddress” value="192.168.1.118"/>
<add key="FujillorklistPort" wvalue="7868"/>

<add key="FujiWorklistIpAddress"” value="192.168.1.118"/>

</appSettings>

4. Save the file and close Notepad.

Restart VIP services

Go to the Windows Services screen and stop and restart VIPServices.net:
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0,

Services

File Action

View Help

I IEEEEN =R D

£} Services (Local)

Name

P’

5 TCP/IP NetBIOS Helper

% Telephony
5 Themes

£, Thread Ordering Server
%, UPnP Device Host
% User Access Logging Service

..e User Profile Service

k=3 V/IPServices.net
., Virtual Disk

Start h

% Volume Shadow

.'.;{;Windows Audio

£ Windows Audio B
£, Windows Calor §
.'.lef,Windows Conneg
i Windows Driver F
.'.;é,-.Windows Encrypt
% Windows Error Re
% Windows Event C

.-e Windows Event L

Stop
Pause
Resume

Restart

All Tasks
Refresh
Properties

Help

3

.« Windows Firewall

er Fra...

Description

Provides support for the NetBIOS over TCP/IP (NetBT) se...
Provides Telephony AP| (TAPI) support for programs tha...
Provides user experience therme management.

Provides ordered execution for a group of threads within ...
Allows UPnP devices to be hosted on this computer. If th..,
This service logs unique client access requests, in the for...

This service is responsible for loading and unloading use...

Port 5canning and Import File Polling Services for VIP.net.

Provides management services for disks, velumes, file sy..

Manages and implements Yolume Shadow Copies used f...
Manages audio for Windows-based programs. If this ser..,
Manages audic devices for the Windows Audio service, 1.
The WesPluglnService service hosts third-party Windows..,
Makes autormnatic connect/disconnect decisions based o...

Creates and manages user-mode driver processes, This .
Windows Encryption Provider Host Service brokers encry...
Allows errors to be reported when programs stop werkin...,
This service manages persistent subscriptions to events f...
This service manages events and event logs. It supports L.
Windows Firewall helps protect your computer by preve...

Your IT provider or system administrator can assist with restarting this service.

Epiphany interface setup is complete.

How does Bp VIP.net transfer data to Epiphany?

If a new patient is created, or changes are made to the following fields, Bp VIP.net will create or

update the corresponding patient record in Epiphany:

& NHI Number
& First name
i Surname

# DOB

i Sex

® Address

If any appointments associated with the selected Work List Filters are created or updated, Bp
VIP.net will create or update the corresponding appointment book information in Epiphany.

Bp VIP.net Services will look to see if Epiphany (and other interfaces) has been installed, and if so,
polls the database about every two minutes for new or updated records. If any changes or new
records are created, the interface will export the data to Epiphany. If the interface is scanning or
exporting, the poll timer stalls and restarts when the process is finished.
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When you install the Epiphany interface for the first time, the process may take some time to trans-
fer existing data, depending on the number of patients and appointments you have stored, for
example.
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